UConnect screen not turning on at startup - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 2 Old 09-16-2019, 12:00 PM Thread Starter
Junior Member
 
Jco23's Avatar
 
Join Date: Sep 2019
Posts: 26
 
Garage
UConnect screen not turning on at startup

curious to see if anyone else has had their UConnect/NAV screen NOT turn on when turning on the car. This has happened only once, but after 2-3 minutes, it eventually came on.

I've gotten into the habit over the years to turn off the radio and air before turning off the car. My understanding is that leaving them off will help extend battery life and allow the car to startup easier (I also typically let the car sit for 30 seconds if it hasn't been used in several hours).

but the other morning, when I started the car, I pressed the power button for the radio, but nothing happened. I pressed harder, and again, nothing. I cursed, and again nothing. I pressed different buttons, and again, nothing. eventually, the radio came on, but the screen was unresponsive. I cursed again, but nothing. I pressed the talk button on the wheel, and the screen went dark. I pressed the power button to the radio, and then it came on and was fully responsive.

clearly, my cursing and mashing of the buttons were unaffective. so I'm not really sure what else to do. /sarcasm

but seriously, just wanted to know if this happened to anyone else.

thanks!
Jco23 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 09-16-2019, 12:20 PM
Member
 
RadRacer's Avatar
 
Join Date: Sep 2018
Location: Florida
Posts: 99
 
Garage
Well first off, turning the AC and Radio off isn't going to extend your battery life. Possibly the radio if it had an excessive parasitic draw, but it should draw the same whether you turn it off or the key does.

As for the unresponsiveness. The uConnect systems do take a couple minutes to boot. It's possible you got it hung up by mashing the buttons repeatedly, lol. I usually crank my car up, and by the time I've put on my seat belt, and adjusted the air, everything else is up and ready for me.

Sent from my GM1915 using Tapatalk


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2018 Jeep Compass Lattitude - Billet Silver, 4x4
2014 Jeep Grand Cherokee Limited, EcoDiesel - GONE
RadRacer is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome