How to: upgrade 7" to 8.4" uconnect - Page 2 - Jeep Compass Forum
 11Likes
Reply
 
LinkBack Thread Tools Search this Thread
post #31 of 46 Old 06-13-2019, 03:19 PM Thread Starter
Senior Member
 
n4cr2k's Avatar
 
Join Date: Nov 2017
Posts: 147
 
Here is one of my latest working BCM configs if that helps anyone

https://pastebin.com/WfmftCNi
n4cr2k is online now  
Sponsored Links
Advertisement
 
post #32 of 46 Old 06-13-2019, 06:00 PM
Junior Member
 
Join Date: May 2019
Location: Phoenix, AZ
Posts: 20
 
Quote:
Originally Posted by n4cr2k View Post
Here is one of my latest working BCM configs if that helps anyone

https://pastebin.com/WfmftCNi
Did you enable passive entry or did that come with your model? If you enabled, did it work?
babaganoush is offline  
post #33 of 46 Old 06-13-2019, 08:15 PM Thread Starter
Senior Member
 
n4cr2k's Avatar
 
Join Date: Nov 2017
Posts: 147
 
It came with my model.
n4cr2k is online now  
Sponsored Links
Advertisement
 
post #34 of 46 Old 06-14-2019, 02:54 PM
Junior Member
 
Join Date: Jun 2019
Posts: 11
 
some info i found apparently my instrumental panel clusters is vin locked. so when nav presence is enabled it does not not allow me to complete the write 😞
tecknozzz is offline  
post #35 of 46 Old 06-14-2019, 03:41 PM
Junior Member
 
Join Date: May 2019
Location: Phoenix, AZ
Posts: 20
 
I'm not sure if this will work, but in the radio module in AlfaOBD, there's an active diagnostic that allows you to write your vin to the radio.
babaganoush is offline  
post #36 of 46 Old 06-14-2019, 06:46 PM
Junior Member
 
Join Date: Jun 2019
Posts: 11
 
yea i attempted to play with that or even add sales codes right away i get the ecu outside parameter message 😞
tecknozzz is offline  
post #37 of 46 Old 06-15-2019, 03:41 PM
Junior Member
 
Join Date: Jun 2019
Posts: 11
 
okay guys i was able to finally write the nav and gps presence and performed a proxi alignment successfully, i just tried it on a different android device and it worked, also i would like to add that if you want to keep up to date with the radio software and happen Not to have the original donor vin associated with the radio, i found a solution.
what i did was following:
1: go to apps and look for GO (activate services)
2: go to option enter email and enter a valid email
3: you should receive a activation link
4: once you click the link at the very top, you will then see the year model and make and VIN

ive only tested this on a jeep compass 2018 with a 2019 uaq 8.4 nav

hope this helps someone
n4cr2k likes this.
tecknozzz is offline  
post #38 of 46 Old 06-18-2019, 12:40 PM
Senior Member
 
Compass2ndgenguy's Avatar
 
Join Date: Dec 2018
Location: Ann Arbor, MI
Posts: 110
 
Garage
Quote:
Originally Posted by n4cr2k View Post
Here is one of my latest working BCM configs if that helps anyone

https://pastebin.com/WfmftCNi
Good info for my swap I am doing soon. Btw sent you a PM, please check

"Wannabe Blacked Out - Oscar" - 2017 Jeep Compass 2nd gen body "Latitude 4x4"
"The Black Castle - Cassie" - 2014 Chevy Tahoe LTZ 4x4 (Wife's Castle) Slight mods with lighting and head and tail lights
Compass2ndgenguy is online now  
post #39 of 46 Old 07-01-2019, 10:30 PM
Senior Member
 
Compass2ndgenguy's Avatar
 
Join Date: Dec 2018
Location: Ann Arbor, MI
Posts: 110
 
Garage
Found this on the Wrangler forums I think it could prove helpful for people salvaging from junkyards.

Quote:
The security code is a 4 digit number generated by the radio company. Once the radio is installed into the original vehicle, that number is assigned to the VIN #. Each time that the ignition is powered up, the PCM sends the VIN to the cluster which then sends it to the radio. If the VIN matches the VIN that is stored in the radio's memory then the radio will turn on. If not then the radio will not power up.
When a person buys a radio without the code, they will take the radio, vehicle, and receipt for the radio to the dealer where the service or parts department can retrieve the code. At this time they will delete the original VIN and apply the new VIN to the system. This way if in the future you lose the code, they will see that you're VIN is the one that belongs to the radio.
Instructions for retrieving the code:

Steps to getting the radio security code

This bulletin is supplied as technical information only and is not an authorization for repair. No part of this publication may be reproduced, stored in a retrieval system,
or transmitted, in any form or by any means, electronic, mechanical, photocopying, or otherwise, without written permission of Chrysler Group LLC.
SUBJECT:
Radio Anti-Theft Codes
MODELS:
2012 (JK) Jeep Wrangler
2012 (JC) Journey
2012 (LD) Charger
2012 (LX) 300
2012 (LC) Dodge Challenger
2012 (KK) Jeep Liberty
2012 (LX) Chrysler 300
2012 (JS) Chrysler 200/Dodge Avenger
2012 (MK) Jeep Compass/Patriot
2012 (PM) Caliber
2012 (WK) Jeep Cherokee
2012 (WD) Dodge Durango
2012 (DS) Ram 1500 PICKUP
2012 (DJ) Ram 2500 PICKUP
2012 (DD) Ram 3500 CAB CHASSIS
2012 (D2) Ram 3500 PICKUP
2012 (DP) 4500/5500 CAB CHASSIS
2012 (DD) (MEXICO) REG CAB CHASSIS
DISCUSSION:
Starting in 2012 model year radios will come equipped with an anti-theft feature. Once a
radio is installed in a vehicle, it learns the vehicle’s VIN and cannot be used in another
vehicle unless an anti-theft code is applied.
NUMBER:
08-051-11
GROUP:
Electrical
DATE:
August 20, 2011


PROCEDURE TO OBTAIN ANTI-THEFT CODE:
1. Call 1-800-448-0944
2. Request anti-theft code.
3. State dealer code.
4. State radio serial number.
5. State VIN
6. The 4-digit anti-theft code will be provided.
NOTE: Radio anti-theft code call center support is available from 8:00 am to 8:00 pm
Eastern Time Monday through Friday.
RADIO ANTI-THEFT CODE PROCEDURE
1. Ignition in the run position.
2. Press the ON/VOL control.
3. The word
CODE
or
Please enter Anti-Theft Code
will appear on the display.
4. Enter the 4-digit code by pressing the corresponding preset buttons in sequence.
NOTE: If three successive attempts are made to enter an invalid anti-theft code the
radio will enter a ‘WAIT’ state. While in this state the radio display will read
‘WAIT’. To exit the ‘WAIT’ state the radio must remain powered with the
ignition in the run position for a continuous 30 minutes (the vehicle may be
driven during this time). After exiting the ‘WAIT’ state the radio will again
display ‘CODE’ and a valid anti-theft code may be entered.
Policy:
Information only.
08-051-11 -2-

"Wannabe Blacked Out - Oscar" - 2017 Jeep Compass 2nd gen body "Latitude 4x4"
"The Black Castle - Cassie" - 2014 Chevy Tahoe LTZ 4x4 (Wife's Castle) Slight mods with lighting and head and tail lights
Compass2ndgenguy is online now  
post #40 of 46 Old 07-19-2019, 09:32 PM
Senior Member
 
Compass2ndgenguy's Avatar
 
Join Date: Dec 2018
Location: Ann Arbor, MI
Posts: 110
 
Garage
@babaganoush @n4cr2k

Finally got things to settle down. Took a while to proxy then got that but the sound system was unavailable and had ecu mismatch error codes. I think that had to change it back to mono controls to make that error go away and have the sound system unavailable not showing up anymore at start up.

Only problem is.. I have no sound! I have a couple of ideas but do you guys offer any help.

Also any idea on how I can get dual zone control with my new HVAC controls?

Thanks,

K

"Wannabe Blacked Out - Oscar" - 2017 Jeep Compass 2nd gen body "Latitude 4x4"
"The Black Castle - Cassie" - 2014 Chevy Tahoe LTZ 4x4 (Wife's Castle) Slight mods with lighting and head and tail lights
Compass2ndgenguy is online now  
post #41 of 46 Old 07-22-2019, 12:57 PM Thread Starter
Senior Member
 
n4cr2k's Avatar
 
Join Date: Nov 2017
Posts: 147
 
Quote:
Originally Posted by Compass2ndgenguy View Post
@babaganoush @n4cr2k

Finally got things to settle down. Took a while to proxy then got that but the sound system was unavailable and had ecu mismatch error codes. I think that had to change it back to mono controls to make that error go away and have the sound system unavailable not showing up anymore at start up.

Only problem is.. I have no sound! I have a couple of ideas but do you guys offer any help.

Also any idea on how I can get dual zone control with my new HVAC controls?

Thanks,

K

What all car configuration changes did you edit in alfaobd? Just a guess, but maybe there is one or two missed or set incorrectly causing the mismatch? I think I have a recent BCM on one of these threads with my factory dual zone setup.
n4cr2k is online now  
post #42 of 46 Old 07-24-2019, 04:12 PM
Senior Member
 
Compass2ndgenguy's Avatar
 
Join Date: Dec 2018
Location: Ann Arbor, MI
Posts: 110
 
Garage
Quote:
Originally Posted by n4cr2k View Post
What all car configuration changes did you edit in alfaobd? Just a guess, but maybe there is one or two missed or set incorrectly causing the mismatch? I think I have a recent BCM on one of these threads with my factory dual-zone setup.
I used your configuration but it did not work for me. I even changed to @babaganoush recommendations based on we both came from 5" screens and it didn't work.

I will pull my configuration now, but I think I lost my front tweeters and subwoofer. Going to try and some other setting, but to be honest I am not sure I want too because I finally have sound again. I also lost my compass at some point as well. I can't get the nav to show up either.

I have learned a lot with this and going through two 7" and finally getting an 8.4" to work. One is that certain 7" radios are flashed directly to the VIN and there is no unlock code. This is depending on the radio manufacturer, and continental is the worst offender of locking off their radios to only be flashed by dealerships. SO BEWARE UPGRADING TO A 7" FROM A 5"

I got my 8.4" screen here for dumb cheap: https://www.lkqonline.com/

There was only two and there is still one left for $380, $390 shipped

I highly suggest this site: https://www.mmsa-radiocode.uk/

It is one guy named Kevin that does it personally, look at the UK time to make sure he is awake. Legit and used his services twice with ease. Just give him time to get back to you, he will help you out and look into why a code he gives doesn't work or not. That is how I learned about the continental radio problem with FCA. cost around USD 15

I also used these guys and they got the same code for my 8.4 unit: https://www.onlineradiocodes.co.uk/

Getting the same code is promising but I would still trust Kevin's personal touch. Again look at standard UK times to help. They did reach out for the back of the unit label to get the code as well, so they doing more but they were more expensive. They are more of a company so they might still be around in 5 years and Kevin might have moved on so I wanted to give two choices. Price USD 25


Back to the swap, after many failed proxy alignments over two days to the ETM. I have concluded a couple of things. 1. The 2017.5 compass ECU is different than the ones with 7" and 8.4" screens and that is why we can not copy and paste things. or 2. We need legit sales codes and take it to a dealership to flash our ECU correctly to pair the VIN. Again like I stated before, I will post my configure that I finally came to but I do not think it is possible to copy and paste this to for people coming from 5" or people upgrading from a 2017.5 model. Changes from the half-year model to the full-year production models is very apparent even down to my 6-month headliner issue. That being said, I do have the 8.4" working without nav(or a compass at this time) and my tweeter and front subwoofer speaker working. I do have all the connections needed for the nav to work with the yellow connection. Problem is that my ECU knows says that is out of my configuration range because I do not have the sales codes and fails the proxy alignment. I just wanted android auto to work and it does so I just nave through my phone like I wanted to do anyways.

Either way, It is 98% working, going to mess with a little more. Not much as it is working and I do not want to end up in a non-working state. Any ideas on how to get XM to connect without dealer intervention. using my phone but would be a nice feature to have just to have. Not a deal-breaker.

Thanks for all the help here! Hope to add to our success!

K

"Wannabe Blacked Out - Oscar" - 2017 Jeep Compass 2nd gen body "Latitude 4x4"
"The Black Castle - Cassie" - 2014 Chevy Tahoe LTZ 4x4 (Wife's Castle) Slight mods with lighting and head and tail lights
Compass2ndgenguy is online now  
post #43 of 46 Old 07-25-2019, 07:14 PM
Senior Member
 
Compass2ndgenguy's Avatar
 
Join Date: Dec 2018
Location: Ann Arbor, MI
Posts: 110
 
Garage
https://docs.google.com/document/d/1...it?usp=sharing

My log.

I got my tweezers and subwoofer to work. Got dual zone to work. Changed some other things to see if it would help with the compass with no luck. I am going to turn nav off to see if that connects it as I read on other jeep forums that if you have nav then the compass doesn't work. The nav menu isn't working anyway so I would rather it connected the compass.

Got the XM to reset by calling XM, but no go on it making a sound yet. Still, get the go to the dealer message, but it does have stations at the top menu now so I know something is connected.

I think how I got the radio to finally play sound and start connecting properly had to do with moving my RADIO setting from level 2 to high-level radio. To be honest, I still don't know, but it is working almost 100%. Just no nav and no compass and no XM.

K

"Wannabe Blacked Out - Oscar" - 2017 Jeep Compass 2nd gen body "Latitude 4x4"
"The Black Castle - Cassie" - 2014 Chevy Tahoe LTZ 4x4 (Wife's Castle) Slight mods with lighting and head and tail lights
Compass2ndgenguy is online now  
post #44 of 46 Old 07-31-2019, 05:07 PM
Senior Member
 
Compass2ndgenguy's Avatar
 
Join Date: Dec 2018
Location: Ann Arbor, MI
Posts: 110
 
Garage
Learning more and more as things go on with this project. For now, I have figured out the problem where I lost audio and pinpointed it to the: Audio System Type.

Mine needed to be set to "Base" to work. I also turned GPS and NAV off to get both compasses on the infotainment system to work and on the gauge cluster.

Next, if you set your "Infotainment Configuration" system to anything but No Audio Brand it will give you the Beats version. From what I can tell this does change the amp values some or at least base bass in the car is different. They must limit what the dynamic range is when it is set to No Audio Brand, it is noticeable to the ear. I heard a difference then I had my wife come out twice and didn't tell her what I changed or let her see the Beats boot up screen and she notice a difference as well. You can also change your "Brand Configuration" to change whatever startup is on the screen, did this once while I was trying to get the sound to work back when I was having no audio issues(chose no brand and it gave me a Fiat screen boot up). (there is a Ferrari option, but I did not try it )

Lastly, I got to drive 2019 jeep compass limited with nav and the menu is way different than mine. Mine seems much more old school and does not have all the options that this one does. I can also hold down the driver side cold and hot temp buttons to still pull up the engineering menu while the one is 2019 can only pull up dealer mode by pressing and holding the bottom left and right icons. I am now 100% sure mine does not have nav and I can not unlock a nav option.

Anyway again that is all for now and this has to do with all Infotament things so I stuck it here and not on the AlfaOBD thread.

K

"Wannabe Blacked Out - Oscar" - 2017 Jeep Compass 2nd gen body "Latitude 4x4"
"The Black Castle - Cassie" - 2014 Chevy Tahoe LTZ 4x4 (Wife's Castle) Slight mods with lighting and head and tail lights
Compass2ndgenguy is online now  
post #45 of 46 Old Yesterday, 09:43 PM
Junior Member
 
tbrown405's Avatar
 
Join Date: Feb 2019
Posts: 3
 
Garage
Quote:
Originally Posted by babaganoush View Post
Yeah I was reading about some people doing that, but looked like only worked for some models so wanted to see if anyone did it on a Compass yet. I'm going to do some more research to see if my car has the temperature sensor and sun sensor. I don't really care about dual-zone climate, but would be nice to have the climate feature. Assuming I'll need to some fiddling with AlfaOBD as n4cr2k mentioned.
Have you had any luck? I swapped my 5 for a 7 as soon as I bought my Compass, and haven't made the dive to swap out the temp control panel. Kind of miss having a volume knob, but the CarPlay is definitely worth the sacrifice.
tbrown405 is offline  
post #46 of 46 Old Today, 06:09 PM
Senior Member
 
Compass2ndgenguy's Avatar
 
Join Date: Dec 2018
Location: Ann Arbor, MI
Posts: 110
 
Garage
Quote:
Originally Posted by tbrown405 View Post
Have you had any luck? I swapped my 5 for a 7 as soon as I bought my Compass, and haven't made the dive to swap out the temp control panel. Kind of miss having a volume knob, but the CarPlay is definitely worth the sacrifice.
Yes, I have done this swap with the controls and it was very plug and play. Are you still on mono settings now when you go to the touch screen potion or is it already dual-zone on that screen? Do you use your controls on the screen on turn dials still?

let me know where you're at, but it wasn't very hard to get those new controls working for myself.

K

"Wannabe Blacked Out - Oscar" - 2017 Jeep Compass 2nd gen body "Latitude 4x4"
"The Black Castle - Cassie" - 2014 Chevy Tahoe LTZ 4x4 (Wife's Castle) Slight mods with lighting and head and tail lights
Compass2ndgenguy is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Similar Threads
Thread Thread Starter Forum Replies Last Post
Jeep Compass 2018 with Uconnect 8.4" - map update mrmrmrmr 2nd Gen Jeep Compass Forum General Discussion 2 06-13-2019 12:52 PM
Uconnect 7" vs 8,4" michael007 Audio Systems 5 01-23-2019 11:17 AM
UConnect Issues with the 2017 Compass 10-64 2nd Gen Jeep Compass Forum General Discussion 6 01-16-2019 03:15 PM
2014 Compass UConnect system... Jinxmaster7 Jeep Compass General Discussion 0 11-13-2014 02:59 AM
Mopar dodge chrysler jeep uconnect upgrade kit for touch screen nav radio JC_RSSBOT Ebay Forum 0 12-24-2011 03:21 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome