Radio Help! - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 7 Old 12-24-2014, 06:22 PM Thread Starter
Junior Member
 
fasthemiram12's Avatar
 
Join Date: Nov 2014
Location: Orlando Fl
Posts: 5
 
Radio Help!

I have a 2014 Compass that came with the factory base radio with Sat and Bluetooth. I recently purchased the upgraded Mygig RBZ radio and installed it today.
It doesnt turn on and my lights in the speedo cluster went nuts while fladhing the headlights. It also wont idle for longer tgan 3 seconds.
Im guessing this is some sort of anti theft feature.
Anyone heard of this before?
Thanks in advance.
fasthemiram12 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 01-03-2015, 09:52 PM Thread Starter
Junior Member
 
fasthemiram12's Avatar
 
Join Date: Nov 2014
Location: Orlando Fl
Posts: 5
 
103 views but no help...

Thanks
fasthemiram12 is offline  
post #3 of 7 Old 01-03-2015, 11:02 PM
Super Moderator
 
Tyler-98-W68's Avatar
 
Join Date: Feb 2012
Posts: 530
 
Garage
Was it completely plug and play, almost sounds like a lose ground wire somewhere?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2012 Red FDII Jeep Compass Limited
235/75/15 Wranger Territory AT
WK2 Headlight Swap
Magnaflow Muffler

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Full Interior LED's + Front/Rear Signal & Backup LEDS

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Tyler-98-W68 is offline  
Sponsored Links
Advertisement
 
post #4 of 7 Old 01-06-2015, 03:12 PM Thread Starter
Junior Member
 
fasthemiram12's Avatar
 
Join Date: Nov 2014
Location: Orlando Fl
Posts: 5
 
Completely plug and play...

Radio works fine in my 2012 ram but not in this 14 compass.
fasthemiram12 is offline  
post #5 of 7 Old 01-17-2015, 06:21 PM
Junior Member
 
Join Date: Jan 2015
Posts: 1
 
Doesn't the dealer have to flash the computer to recognize the new radio?
rfrjr is offline  
post #6 of 7 Old 01-18-2015, 10:56 PM
Junior Member
 
Join Date: Apr 2011
Posts: 10
 
Quote:
Originally Posted by fasthemiram12 View Post
I have a 2014 Compass that came with the factory base radio with Sat and Bluetooth. I recently purchased the upgraded Mygig RBZ radio and installed it today.
It doesnt turn on and my lights in the speedo cluster went nuts while fladhing the headlights. It also wont idle for longer tgan 3 seconds.
Im guessing this is some sort of anti theft feature.
Anyone heard of this before?
Thanks in advance.
Sounds like you're missing a connection from your new stereo to the vehicle interface. On certain vehicles if you are missing a connection (Cam Buss, ground, antenna, etc.) Your car simply won't work... And since your compass didn't come stock with a GPS antenna, or use any parking brake features (DVD, Nav address input) that could be a problem. The interface connections could be pinned-out differently from model to model.

I know that isn't very helpful but since you are installing an OEM radio you'll probably have to check with the dealer so see where the problem is occurring.

I'd say loose that outdated stereo and buy an aftermarket stereo and a wiring harness that prevents nightmares like this. You could potentially damage you vehicle.
JerkMcJeep is offline  
post #7 of 7 Old 03-05-2016, 05:04 PM
Junior Member
 
Join Date: Mar 2016
Posts: 5
 
All MyGig radios integrate with the vehicles Controller Area Network (CANBus). It sounds like you may have a high-speed CANBus unit. This would explain why the radio works in your Dodge RAM as new RAMs use the high speed bus.
sailbad_d_sinner is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome