uConnect 4 8.4 Weird Behaviour - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 6 Old 06-02-2018, 06:23 PM Thread Starter
Member
 
Join Date: Jun 2018
Posts: 72
 
uConnect 4 8.4 Weird Behaviour

Hi
Picked up my 2018 Compass last week and very happy with it so far.

However, I have noticed a few odd things with my uConnect system which I wondered if anyone else had come across?

1. I turned off all the POIs and cameras in the NAV which was fine for a couple of days but the cameras have now come back on and I cannot turn them off
2. Whenever I am on the map view and am driving it zooms in every time I come to a roundabout. It didnít do this to begin with but now does it all the time and I cannot see how to turn it off
3. The climate control temperatures have reset themselves a couple of times from what I set them to back to what they were when I first got the car

Any thoughts?

Thanks
Rog
rriggs is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 06-05-2018, 03:55 PM
Senior Member
 
Join Date: Apr 2012
Posts: 380
 
Quote:
Originally Posted by rriggs View Post
Hi
Picked up my 2018 Compass last week and very happy with it so far.

However, I have noticed a few odd things with my uConnect system which I wondered if anyone else had come across?

1. I turned off all the POIs and cameras in the NAV which was fine for a couple of days but the cameras have now come back on and I cannot turn them off
2. Whenever I am on the map view and am driving it zooms in every time I come to a roundabout. It didnít do this to begin with but now does it all the time and I cannot see how to turn it off
3. The climate control temperatures have reset themselves a couple of times from what I set them to back to what they were when I first got the car

Any thoughts?

Thanks
Rog
Hi Rog,

I can understand why this would be frustrating. Are you planning on making your dealer aware of what you're experiencing? Send me a direct message as I'd be glad to get this escalated to a Case Specialist for further handling.

Jasmine
Jeep Social Care Specialist
JeepCares is online now  
post #3 of 6 Old 06-05-2018, 04:13 PM Thread Starter
Member
 
Join Date: Jun 2018
Posts: 72
 
Hi Jasmine

I cannot PM you as I do not have enough posts yet...

I did contact the dealer but they just offered very basic generic answers that didnít help.

Anything you can do to help would be appreciated

Thanks
Rog
rriggs is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 07-23-2018, 01:41 AM
Junior Member
 
Join Date: Jul 2018
Posts: 6
 
I have encountered the problem with the automatic climate control resetting to OFF, and losing my previous settings when I turn it on again. I haven't had those specific other problems but there are at least a half dozen other issues with the system. For example, the setting for the FCW sensitivity are not retained after shutoff (and I'm not convinced the system even works TBH), the instrument cluster display for the navigation doesn't clear after a completed turn, and the setting for "auto unlock on exit" simply does not work.

I've had it to the dealer but they said there is no update for it yet. They were talking to FCA engineering, who acknowledged the problems and said an update would be available in "about a month". That was three months ago. I've checked the UConnect website for an update as of the past week and there is still no update.
gforce2002 is offline  
post #5 of 6 Old 07-24-2018, 02:02 PM
Member
 
jasleth's Avatar
 
Join Date: Mar 2018
Posts: 68
 
Garage
sometimes it takes time

Keep in mind updates need to be made, tested, and then published for use - they may have run into other issues as they work to fix what they already know about. That said you should be able to keep in contact with your dealer and with the Jeep Cares team - hopefully they can help you.

Proud owners of a new to us certified pre-owned
2017 Jeep Compass 75th Anniversary Sport
jasleth is offline  
post #6 of 6 Old 08-23-2018, 05:36 PM Thread Starter
Member
 
Join Date: Jun 2018
Posts: 72
 
Really frustrated with the speed cameras now. Has anyone managed to hide them/turn them off?

When you zoom the map out you can’t see roads or names properly because the cameras cover everything. Come cities here are flooded with the cameras which makes the map unusable.

I have turned off all POIs and speed camera warnings but the map is still littered with camera symbols.

Any ideas?

Last edited by rriggs; 08-23-2018 at 05:43 PM.
rriggs is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome