Rear Upper Control Arm Issues - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 4 Old 06-17-2011, 10:17 PM Thread Starter
Junior Member
 
Join Date: Jun 2011
Posts: 16
 
Rear Upper Control Arm Issues

We are having to replace the rear upper control arms. Our mechanic is telling us he cannot get the chassis end bolts loose and the best way to remove them is with a torch. To avoid being without the car overnight...does anybody know what size the bolts are that would be best fit replacements?

Also....does anybody have an 2007 Compass TPMS that does not work that I could buy? Contact me at.....spoonsize2003(at)yahoo(dot)com.

Thanks Much.

Steve
Steve Durham is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 06-30-2011, 12:40 AM
Senior Member
 
Join Date: Jan 2011
Location: california
Posts: 150
 
Garage
WHY does your tpms not work? Did you replace a tire and rotate them?
Check your spare. If your spare has lost its air , pump it up and then remove your battery cable (-) for about ten minutes. Reconnect battery and recheck the tpms.
jeepney_driver is offline  
post #3 of 4 Old 09-04-2011, 05:38 PM Thread Starter
Junior Member
 
Join Date: Jun 2011
Posts: 16
 
As it happens, the TPMS in question had a slow air leak. Further inspection found the side of the stem had a hair line crack running lengthwise. I ended up buying a new one online for about $25, but if I could have gotten a used one I could have replaced just the stem.

Steve
Steve Durham is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 10-12-2017, 08:10 PM
JBL
Junior Member
 
Join Date: Oct 2017
Posts: 1
 
I have a 2007 Jeep Compass that after 3 reg flashes my right blinker starts hyper- flashing.The 4 ways work perfect but when I put the parking lights on the bulb goes out,but if the lights aren't on it will hyper-flash dimmly . I have replaced all the bulbs front and back ,checked and cleaned all grounds and I switched the socket from the front left side and it still does this.This all started happening after a branch broke my lense and I taped it waiting for new one,help please.
JBL is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome