Oil Pan nut - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 3 Old 05-07-2012, 08:38 PM Thread Starter
Junior Member
 
Join Date: Apr 2012
Posts: 18
 
Oil Pan nut

I just changed the oil and took off the 1/2" nut and used a pan to catch the oil, when I was finished draining, I looked at the nut and sifted thru the used oil for a copper washer or some sort of seal and found none. I looked at the nut, cleaned it and it looks like there is a rubber gasket seal built in. Is that the way they come. To be safe I am going to get a new one from the dealer for spare for future oil changes.
compassygp288 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 05-09-2012, 08:37 AM
Senior Member
 
ronjr8102's Avatar
 
Join Date: Aug 2011
Location: Worcester, MA
Posts: 148
 
Garage
I don't remember but sometimes there are rubber washers built in to the nut. Sometimes too the washer sticks to the pan.

2007 Jeep Compass 4x4 Limited (black)
2010 Hyundai Elantra GLS (blue)
ronjr8102 is offline  
post #3 of 3 Old 05-14-2012, 08:41 PM Thread Starter
Junior Member
 
Join Date: Apr 2012
Posts: 18
 
The rubber is built into the 1/2" nut. I bought a new one for $10 to use as a spare when the old nut doesnt seal anymore.
Thanks for responding.
compassygp288 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome