Engine Noise?? - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 9 Old 09-07-2013, 05:57 AM Thread Starter
Member
 
Join Date: Apr 2011
Location: SC
Posts: 44
 
Engine Noise??

My wife has a 2007 Compass limited. Yesterday she told me it was ticking. i get home and its running quite and just fine. Today she is pulling in from work and as she idled down the driveway it sounded like it was rattling. I pin pointed it to something that is running on the belt. I removed the belt and the sound is gone. I came in from work and it took 30 min to get the sound to come back. I took both idler pulleys off and theres a very small groove in each one, but they spin free and doesnt' seem worn out.

Has anyone else had this rattling problem? It will drive me nuts!! could it be these pulleys or the tensioner?

2007 Jeep Compass Limited...Bone Stock!!
numskull is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 09-07-2013, 09:30 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
Could be the ADP on the alternator. They were know to fail early on that year.

That job is a PIA though. Good luck there is a short video made here but only confirms how much you have to go through to get it out etc.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
post #3 of 9 Old 09-07-2013, 09:42 PM Thread Starter
Member
 
Join Date: Apr 2011
Location: SC
Posts: 44
 
Thanks,
I replaced the idler pulleys and the belt today....still makes the noise, Alt pullet has some wiggle to it. I figured Id replace the whole thing, but I gotta find out which one I have, 115 or 140 amp, before I go by it. Ive been searching and havent found anything yet, on how to tell.

2007 Jeep Compass Limited...Bone Stock!!
numskull is offline  
Sponsored Links
Advertisement
 
post #4 of 9 Old 09-07-2013, 10:30 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
I had the dealer check once on my build and it was not 140A. I don't know what configuration they would be putting that in. I have enough power options in my package including heated seats but not the bigger alternator though.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
post #5 of 9 Old 09-07-2013, 10:51 PM Thread Starter
Member
 
Join Date: Apr 2011
Location: SC
Posts: 44
 
I was able get my phone close enough to get a pic. I was able to get the numbers and googled it, and found that its a 115a. Then after looki g at the pic again, it has a number 115hs.....so i bought one off a 2012 wrecked jeep for 40.00 with warranty!!!

2007 Jeep Compass Limited...Bone Stock!!
numskull is offline  
post #6 of 9 Old 09-07-2013, 11:02 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
Well done, I used to see ones pulled out of wrecks on eBay cheap with low millage. The ADP is usually the first thing to go. Shaft bearing next.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
post #7 of 9 Old 09-07-2013, 11:28 PM Thread Starter
Member
 
Join Date: Apr 2011
Location: SC
Posts: 44
 
Yeah, my pulley wiggled when I felt of it, figured if i could get a Alt for 40. That would be a score!!

2007 Jeep Compass Limited...Bone Stock!!
numskull is offline  
post #8 of 9 Old 11-04-2013, 05:08 PM
Junior Member
 
LKicklight's Avatar
 
Join Date: Oct 2013
Location: dallas, georgia
Posts: 27
 
2012 Compass

Our 2012 Jeep Compass Limited has the 2.4 engine, when first started in the morning, engine cold, I can hear a clacking noise, probably lifters that continues until the engine has warmed. I am using the Royal Purple Synthetic 5w-30w, along with there filter. Can't imagine what else it could be. We have 35k on the odometer at this time and the engine runs just fine after its warmed to operating temps: Anyone else had this problem and does it get worse with age?
Attached Images
File Type: jpg jeepcompass#2.jpg (41.2 KB, 1 views)
LKicklight is offline  
post #9 of 9 Old 11-04-2013, 05:40 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
Lifters are a tapping noise. It should not make any noise in these engines. At 35k is nothing and I'd be really worried later on. Have you taken it to the dealer (any dealer), that's the first step if not.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome