New Compass almost didn't make it home... - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 15 Old 10-20-2015, 04:40 PM Thread Starter
Member
 
SPD KILS's Avatar
 
Join Date: Sep 2015
Posts: 39
 
New Compass almost didn't make it home...

Friday I was driving home from work when suddenly a loud "ding", then the service engine light came on and the traction control/stability light came on. The engine raced for a fraction of a second. This all happened while driving 30 MPH. It was a handful to drive while limping towards the Jeep dealer. It was low on power and fought itself driving down the road as if it was locked in 4x4 on concrete. Upon arrival at the Jeep dealer the service attendant connected a scanner and it said it was a battery problem. He then said call Monday and we will try to get it in next week. (not impressed) I told him I will take it home, disconnect the battery to clear the computer. He said, " DO NOT EVER DISCONNECT THE BATTERY!!! There are three computers that are extremely sensitive to voltage spikes". I then told him I really don't want to own a vehicle that is that fragile. Got home and discovered the dealer had installed a new battery two weeks before my purchase and they did not tighten the clamps. The battery tested okay so I reconnected and tightened the very cheap and weak battery terminal clamps. Everything has worked fine so far.

2015 Jeep Compass Latitude 4x4
980 miles, 26 MPG combined (light on the pedal)
SPD KILS is offline  
Sponsored Links
Advertisement
 
post #2 of 15 Old 10-20-2015, 05:06 PM
Super Moderator
 
Tyler-98-W68's Avatar
 
Join Date: Feb 2012
Posts: 530
 
Garage
I've disconnected my battery many times, haven't had any issues doing that.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2012 Red FDII Jeep Compass Limited
235/75/15 Wranger Territory AT
WK2 Headlight Swap
Magnaflow Muffler

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Full Interior LED's + Front/Rear Signal & Backup LEDS

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Tyler-98-W68 is offline  
post #3 of 15 Old 10-21-2015, 05:14 AM
Senior Member
 
LordReddawg's Avatar
 
Join Date: Mar 2014
Location: Alaska
Posts: 286
 
Garage
same here changed my battery ones (wife left lights on in cold weather and killed it completely) then took off again when installed trailer wire harness and then again when I installed my spot light set up you just have to know what ur doing not hung them up back wards or don't jump ur jeep with jump cables back wards I'm a mechanic in the military and mess with batteries all the time

Last edited by LordReddawg; 10-21-2015 at 05:17 AM.
LordReddawg is offline  
Sponsored Links
Advertisement
 
post #4 of 15 Old 10-22-2015, 12:41 AM Thread Starter
Member
 
SPD KILS's Avatar
 
Join Date: Sep 2015
Posts: 39
 
NOT FIXED YET! Same thing happened again driving home from work today. Limped to the dealer and they told me it would be two weeks before I could get it in. The same dealer owns all the Jeep dealers in town and they are all booked solid for two weeks. I found a dealer in another city that would take it right away. They also offered me a rental car unlike the dealer I purchased the Jeep from. Oh, and I discovered my second key is not a match. The dealer gave me a key to another Jeep.
SPD KILS is offline  
post #5 of 15 Old 10-22-2015, 04:53 PM
Senior Member
 
Join Date: Apr 2012
Posts: 386
 
Quote:
Originally Posted by SPD KILS View Post
NOT FIXED YET! Same thing happened again driving home from work today. Limped to the dealer and they told me it would be two weeks before I could get it in. The same dealer owns all the Jeep dealers in town and they are all booked solid for two weeks. I found a dealer in another city that would take it right away. They also offered me a rental car unlike the dealer I purchased the Jeep from. Oh, and I discovered my second key is not a match. The dealer gave me a key to another Jeep.
Hey SPD KILS,

TSB 18-070-14 may relate to your vehicle:

SUBJECT:
Flash: MIL Illumination, P219A, P050B And Cold Start Improvements
OVERVIEW:
This bulletin involves selectively erasing and reprogramming the Powertrain Control
Module (PCM) with new software.
MODELS:
2015 (MK) Jeep Compass/Patriot
NOTE: This bulletin applies to vehicles built on or before November 3, 2014 (MDH
1103XX).
SYMPTOM/CONDITION:
Some customers may see erroneous illuminated malfunction indicator lamps (MIL) and
have a hard start cold condition.
P219A Bank 1 Air Fuel Ratio Imbalance
P050B Cold Start Ignition Timing Performance

Let me know if you have any further questions.
JeepCares is online now  
post #6 of 15 Old 10-24-2015, 07:02 PM Thread Starter
Member
 
SPD KILS's Avatar
 
Join Date: Sep 2015
Posts: 39
 
I think it was built in November 2014. I need to check the exact date. Thanks
SPD KILS is offline  
post #7 of 15 Old 10-24-2015, 08:48 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
I don't use my vehicles to jump start others who's batteries are weak. There are too many sensitive components and the alternator is low powered on these as well. I have booster pack for that purpose should I need it myself. Far far safer and not surges or rectifier blowing boost loads for those who run their engine while boosting another vehicle. A very bad move which could blow your alternator or worst.

I wonder what is causing your problem on this new Compass.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
post #8 of 15 Old 10-25-2015, 12:55 AM Thread Starter
Member
 
SPD KILS's Avatar
 
Join Date: Sep 2015
Posts: 39
 
I get the feeling when they disconnect the battery it will clear the code like it did for me and not act up again for the dealer. They will return it saying its fixed. It will only break down again. I don't have much confidence in these Jeep/Chrysler dealers because of the way I've been treated. It looks like every time it breaks down it will be a two to three week wait to get it in for repair. I usually own Chevy or GMC and have never had to wait for warranty repairs. I like the Compass and I hope I don't have to dump it due to fear of poor dealer warranty service or the lemon law. I also don't know how long I can stand driving the 2015 Camaro rental car full of cat hair and bad odor.
SPD KILS is offline  
post #9 of 15 Old 10-25-2015, 10:15 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
Rental vehicles don't have pets in them. Tell them its affecting you allergies if needed. Better go back to the rental agency you used. Just like non smoking vehicles here.

Fill or rather add a signature so the details and location etc. All guess work in that regard in these posts.

As for delayed service either take it to another dealer and/or call customer service and complain about your warranty service and poor service on a repeated problem. If you return it several times with the same problem they may have to buy it back unfixed.

Normally its policy you get a similar vehicle in a rental not a car for an SUV etc.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
post #10 of 15 Old 10-26-2015, 01:35 AM Thread Starter
Member
 
SPD KILS's Avatar
 
Join Date: Sep 2015
Posts: 39
 
I purchased the Jeep in Omaha, Nebraska. I had to take it to a small town dealer in Blair Nebraska. The Jeep/Chrysler dealers in Omaha have become a monopoly. I believe our states lemon law says if they can't fix the same problem after three trips you can file. The dealer has an Enterprise rental office in their service bay. All they had was a Chrysler 200 and a Camaro.
All dealers were booked for two weeks. The out of town dealer said they were booked for three weeks but if I bring it in today they will squeeze it in the next 1 to 4 days. I said what? My choice it 3 weeks or 1 to 4 days??? I'll take 1 to four days. I will keep you posted.

2015 Jeep Compass Latitude 4x4
2.4, 6 spd auto, high altitude package


Elkhorn, Nebraska, USA

2014 GMC Sierra 1500 4x4 Z71
2009 Impala
1986 Corvette
SPD KILS is offline  
post #11 of 15 Old 10-26-2015, 04:12 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
Log the problem with Chrysler. Get a case number and they will escalate the issue with the dealer of your choice. Even send a specialist down for that appointment time. Otherwise your post will go without sympathy here. You have the time make the call and be clear and detailed on problem specifics for the log. Related work order would also help.

Good luck

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
post #12 of 15 Old 10-27-2015, 09:37 PM Thread Starter
Member
 
SPD KILS's Avatar
 
Join Date: Sep 2015
Posts: 39
 
Good point.
Well they said its a camshaft sensor and they hope to have one by tomorrow.
Kind of funny. I was in a company vehicle (2010 Ford Transit) in the middle of nowhere. Hundreds of miles from any large city when the camshaft sensor went out. I was able to find one in another state and have it delivered to NAPA in the next small town the following day. Repaired it in the parking lot. Its taking the Jeep dealer at least a week to do the same thing!

2015 Jeep Compass Latitude 4x4
2.4, 6 spd auto, high altitude package


Elkhorn, Nebraska, USA

2014 GMC Sierra 1500 4x4 Z71
2009 Impala
1986 Corvette
SPD KILS is offline  
post #13 of 15 Old 10-30-2015, 12:30 AM Thread Starter
Member
 
SPD KILS's Avatar
 
Join Date: Sep 2015
Posts: 39
 
Got the Jeep back and it lasted almost a day and 80 miles before it broke down again for the third time. Another slow 25 mile trip to the Jeep dealer.

2015 Jeep Compass Latitude 4x4
2.4, 6 spd auto, high altitude package


Elkhorn, Nebraska, USA

2014 GMC Sierra 1500 4x4 Z71
2009 Impala
1986 Corvette
SPD KILS is offline  
post #14 of 15 Old 10-31-2015, 09:45 PM Thread Starter
Member
 
SPD KILS's Avatar
 
Join Date: Sep 2015
Posts: 39
 
Got the Jeep back from the dealer again. Their test drive was 249 miles!!! Food and wrappers, mess in the interior. My opinion now... Jeep/Chrysler dealers suck!

2015 Jeep Compass Latitude 4x4
2.4, 6 spd auto, high altitude package


Elkhorn, Nebraska, USA

2014 GMC Sierra 1500 4x4 Z71
2009 Impala
1986 Corvette
SPD KILS is offline  
post #15 of 15 Old 11-01-2015, 09:49 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
Lol

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome