Recurring Automatic S&S Problems - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 1 Old 12-28-2017, 05:06 PM Thread Starter
Junior Member
 
Join Date: Dec 2017
Location: Westchester, NY
Posts: 1
 
Recurring Automatic S&S Problems

Hi All,

New to this website, but I've had some issues with my new Compass so I wanted to gauge if anyone else has experienced what I have. I have a 2017 Compass LA that I purchased new back in late June. As a couple of other threads have noted, the Automatic S&S feature is standard and is engaged every time the car starts. The first time I had an issue was back in July where I pulled up to a red light, the engine cut, and when the light turned green I went to start back up and the car didn't. On my dash, it told me that I needed to put the car in park and restart the engine with my foot on the break. Panicked, I tried to do that at the light, and as I switched to park, it told me to go back into drive. This sequence went over and over without the motor restarting. I also realized that my parking break was engaged, and I was unable to disengage it. Finally, cops came and somehow was able to restart it. Dealer had it for a couple of days, said it was a faulty starter and replaced it.

Second time this happened I was in the parking lot. Had just restarted my car after getting in it and after a couple of seconds of working normally it went through the whole sequence again. Being in a safer area I tried all different things, but was not able to get my car to start. I called a family member who came and also was unable to get the car to start normally. The tow truck came and he gets in and fiddles with it and is able to start it. At this point I would think I was being punked if I didn't have a family member also unable to get the car going. Dealer had the car for probably about two weeks and had the BCM (Body Control Module) replaced.

Third time this happened was about 3 months later at another red light. Fortunately the "shift to park, shift to drive" sequence only occurred for about a minute and I was able to get the car rebooted myself and drive off, but called for another return to the dealer. They currently still have the car and have not told me what they've been able to find.

Long story short, I wanted to see if anyone had similar issues to this with their Compass and if so, what was the issue? I love everything about my car with the exception of this, and unfortunately it is a large issue when it happens. Apologies for the long post!
kbs18 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome