Who's had warranty service? - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 10 Old 11-01-2006, 03:42 AM Thread Starter
 
Join Date: Sep 2006
Posts: 362
 
Who's had warranty service?

Here's a question. I've heard a few people talk of taking their Jeep to the shop.... but has any parts actually needed replacement?

From what I can tell, there have been a few very minor issues, but I haven't heard of anything being replaced or repaired as of yet. Post in here if you've had to have something replaced under warranty.

Edit: I'm going to make this sticky so more people see it.
Webmaster is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 11-01-2006, 07:31 PM
 
Join Date: Oct 2006
Posts: 172
 
So far so good on my side!!
flybynight_x1 is offline  
post #3 of 10 Old 03-14-2007, 10:37 PM
 
Join Date: Mar 2007
Posts: 31
 
when i first bought the compass i had issues with it not turning on most of the time...took it to the dealership and they replaced some wires that were burned up....good service overall..
Compa is offline  
Sponsored Links
Advertisement
 
post #4 of 10 Old 03-21-2007, 09:22 PM
 
Join Date: Mar 2007
Posts: 9
 
sensor drivers ..?!

We had the engine light come on just before the 5000km mark .... the dealer had a "no big deal" kind of attitude .. didn't actually replace anything ... said a sensor needed an update ....

.. made me glad I didn't go for an import and end up not being able to get full-on dealer service ..

I guess I do want the best performance/efficiency computers can give us ... a touch obnoxious that the kind of driver issues we have with our regular computers are now in cars ..
NWTCommuter is offline  
post #5 of 10 Old 06-17-2007, 05:50 PM
Bob
 
Join Date: Jun 2007
Posts: 3
 
Bad battery and bent hood support

The battery wouldn't hold a charge more that two days, dealer replaced it.
The hood support was bent and the clip that holds it in place was broke. I just received noticed the part are in and they'll fix it Monday.
Bob is offline  
post #6 of 10 Old 09-24-2007, 03:16 PM
 
Join Date: Aug 2007
Posts: 23
 
To date: Service engine light repeatedly comes on

O2 Censor
Manifold
Carbin Canistor
Gasket (not sure which one)
Rear O2 Censor


All the while I have been driving a rental car paid by the dealership. They continue to try to fix the issue. Hopefully it has been taken care of.

One word of advice.. When they try to duplicate the issue, make sure they duplicate your driving route not just the highway!
zippityjacks is offline  
post #7 of 10 Old 09-25-2007, 06:04 AM Thread Starter
 
Join Date: Sep 2006
Posts: 362
 
It's sensor BTW, not censor.
Webmaster is offline  
post #8 of 10 Old 09-25-2007, 02:23 PM
 
Join Date: Aug 2007
Posts: 23
 
No wonder its not working!
Thanks, spelling is not my strong point.
zippityjacks is offline  
post #9 of 10 Old 10-04-2007, 01:56 PM
 
Join Date: Oct 2007
Posts: 204
 
Quote:
Originally Posted by zippityjacks
No wonder its not working!
Thanks, spelling is not my strong point.
I rely on spell check...
rommel543 is offline  
post #10 of 10 Old 11-17-2007, 05:12 AM
 
Join Date: Dec 2006
Posts: 12
 
Warranty Parts replacement

I had my rear brakes hanging after hard braking. They replaced it with modified rotors, caliphers and pads around Aug 07
One drag on the whole thing was parts took a couple of weeks to get to the dealership.
Pointer is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome