2015 Jeep Compass My First yet disappointed - Jeep Compass Forum
 1Likes
  • 1 Post By Tyler-98-W68
 
LinkBack Thread Tools Search this Thread
post #1 of 9 Old 10-02-2015, 03:14 AM Thread Starter
cla
Junior Member
 
Join Date: Oct 2015
Posts: 3
 
2015 Jeep Compass My First yet disappointed

Hello everyone..

Found this forum through google..


Bought my Jeep June 2015, had it for 2 weeks.. the '4WD!' indicator pops up.. At 1st i thought i accidentally pulled the 4WD switch... so i pulled it to remove the indicator.. and walaaaa.... the indicator went off...

Two weeks later.. there it is the indicator on again.. sent the car to the agent service centre, and they reset it.. the indicator went off again... Was so happy and excited... brought the car home... the following week.. there it is.. and this time, the indicator stayed on... sent it back to agent for check up.. they told me that their is a faulty in the 4WD module system....

I was like.. What!!! a brand new car.. and not even a month... this is happening...

They ordered the parts and waited for nearly 2 months for it to arrive... Finally the parts arrived last tuesday (29.09.2015). Sent my baby for 4wd replacement.. Called them yesterday.. they said the module has been replaced but the indicator still on... Until now, they are still checking what is the problem... What a disappointment! my first time owning a Jeep.. and this is happening to me..

I hope they could solve this issue soon...

cla
cla is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 10-02-2015, 04:18 AM
Super Moderator
 
Tyler-98-W68's Avatar
 
Join Date: Feb 2012
Posts: 530
 
Garage
Where is the indicator showing up, if its a amber symbol "!4WD" then its a fault, if its in the display where the gears are displated that's normal and will come on when you pull up on the T-Handle.

Some vehicles have defects when they are new, nothing is perfect, I had one electrical issue 1 week after I bought my 2012, it took 3 weeks to fix, but I was given a rental and haven't had any issues since,.
BusterOz likes this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2012 Red FDII Jeep Compass Limited
235/75/15 Wranger Territory AT
WK2 Headlight Swap
Magnaflow Muffler

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Full Interior LED's + Front/Rear Signal & Backup LEDS

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Tyler-98-W68 is offline  
post #3 of 9 Old 10-04-2015, 04:56 AM
Junior Member
 
Join Date: Jun 2015
Posts: 19
 
I agree, all new cars have issues. I have had my sort of problems with my Jeep but going on 4,000 miles now with no issues.
Iceman is offline  
Sponsored Links
Advertisement
 
post #4 of 9 Old 10-05-2015, 10:26 PM
Member
 
BubbaKen's Avatar
 
Join Date: Sep 2014
Location: USA
Posts: 36
 
I know this is not your issue but I was surprised to see that pulling the 4wd switch when the vehicle is off (keys out of ignition) will toggle it on. I noticed it after cleaning that crumb catching area and wondered how it got switched on.

P.S. 28,000 miles in one year and (knock on wood) not issues yet!

2014 Granite FDI 2.4L 4x4 Jeep Compass Lattitude
BubbaKen is offline  
post #5 of 9 Old 10-06-2015, 08:37 AM
Senior Member
 
LordReddawg's Avatar
 
Join Date: Mar 2014
Location: Alaska
Posts: 286
 
Garage
ya that area gets dirty very easy and same here (knock on wood as well) 25K no problems
LordReddawg is offline  
post #6 of 9 Old 10-06-2015, 09:04 AM
Senior Member
 
gunner92's Avatar
 
Join Date: Sep 2014
Posts: 147
 
Sounds a bad batch to me, also happens on other car brands. Hope they will finally fix it up or give you an option for another model.
gunner92 is offline  
post #7 of 9 Old 10-11-2015, 02:54 AM Thread Starter
cla
Junior Member
 
Join Date: Oct 2015
Posts: 3
 
It's been a week.. Finally i got a call last wednesday... And they said there is a faulty in the indicator cluster.. I asked them how could that happened.. They couldnt give me any answer too.. Now they are ordering the parts and it will arrive in a week or so... At the meantime, i couldnt collect my car.. And they are not lending me any car.. I am crossing my fingers now.. And hoping that after replacing the indicator cluster.. There will not be any issues again..
cla is offline  
post #8 of 9 Old 10-11-2015, 10:24 AM
Member
 
BusterOz's Avatar
 
Join Date: Jun 2014
Location: SYDNEY AUSTRALIA
Posts: 80
 
Garage
If you go looking, things appear - just drive....
BusterOz is offline  
post #9 of 9 Old 10-16-2015, 05:17 AM Thread Starter
cla
Junior Member
 
Join Date: Oct 2015
Posts: 3
 
Just an update..

The instrument cluster has arrived.. And installed... The warning sign is still up... They are still checking the car..
cla is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome