Crankshaft position sensor - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 1 Old 06-01-2018, 03:15 PM Thread Starter
Caz
Junior Member
 
Join Date: Jun 2018
Posts: 1
 
Crankshaft position sensor

Hi All
I have a 2010 compass. Was making a store run for work the other day and the jeep just started running very rough. CEL came on an started flashing. I know enough to know this is bad. Luckily I live close and was able to limp it home. Long story short. Got codes for crankshaft position sensor and misfired. Replaced the sensor and she seems to be running smooth. However when I backed out of my parking spot it will not go into drive (reverse works fine). Are these issues related? Did I do something stupid? Please help....

Thanks
Caz
Caz is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome