Traction / ABS Light Randomly On - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 4 Old 08-16-2016, 03:29 PM Thread Starter
Junior Member
 
Join Date: Aug 2016
Posts: 2
 
Smile Traction / ABS Light Randomly On

Hello. I have a 2012 Compass (37,500 miles on it). Randomly the Traction Control and the ABS light come on. Sometimes it'll be when the car has been running for an hour+, and then it stays on for a day or so after, but then just as random as it comes on, they both go off. It'll stay off for a few days, weeks, months, and then its back on again. The car drives the same. I don't notice/feel a difference in the way its driving/handling. This is my first Jeep, so I'm not sure if its just the electrical, and not a big deal, or if this is something major, and I need to bring to the dealership. Any and all help would be greatly appreciated! Thanks a bunch!
kdavis1853 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 08-16-2016, 05:56 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
You would need the codes scanned to determine what maybe going on. Traction control activates automatic braking and transmission state, neither of which are good to be active all the time. This is typical occurrence if the computer believes you are entering a skid or loosing control.

History on the vehicle may have shed light on what might be causing it assuming the aforementioned conditions don't apply.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
post #3 of 4 Old 08-17-2016, 09:42 PM
Senior Member
 
Join Date: Apr 2012
Posts: 368
 
Quote:
Originally Posted by kdavis1853 View Post
Hello. I have a 2012 Compass (37,500 miles on it). Randomly the Traction Control and the ABS light come on. Sometimes it'll be when the car has been running for an hour+, and then it stays on for a day or so after, but then just as random as it comes on, they both go off. It'll stay off for a few days, weeks, months, and then its back on again. The car drives the same. I don't notice/feel a difference in the way its driving/handling. This is my first Jeep, so I'm not sure if its just the electrical, and not a big deal, or if this is something major, and I need to bring to the dealership. Any and all help would be greatly appreciated! Thanks a bunch!
Hi kdavis1853,

If you do end up going to the dealership and need any assistance, feel free to PM me and let me know!

Kori
Jeep Social Care Specialist
JeepCares is online now  
Sponsored Links
Advertisement
 
post #4 of 4 Old 09-20-2016, 09:00 PM
Member
 
Join Date: Sep 2016
Posts: 65
 
Garage
Chances are, a code scanner will point to a wheel speed sensor.

Clyde--True Blue Pearlcoat 2016 Compass Sport 2.4L 6-speed. Additions since brand new in September of 2016: 4X Alpine SPJ-691C3, Weathertech floor liner Front only, Scosche Magi-Mount, USB charging port added to glove box, USB charging ports added to rear passenger area, Hum, Curt 13081 class III receiver. More to come!!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Stringplucker is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome