Jeep Compass Forum - Reply to Topic
Thread: Idling Issue Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
06-27-2011 11:48 AM
tripplec the majority of fuel here in Canada contain 10% ethanol. This mixes with water and because of that I have not concerned byself with gas line antifreeze. I do bypass and stay away from gas stations I see being filled up with a tanker at them. They will stir up any settled water etc during their fillups.
What is 10%, well in 10 gallons of fuel 1 gallon will be ethanol. this is a real rip off since its hard on all but the newest engines and fuel economy and performance suffers with it. You are likely burning CORN ethanol. Like we don't have a food shortage in some areas we're diverting tons on good crops for this purpose.
06-27-2011 07:23 AM
jeepney_driver Sometimes the addition of fuel additives designed to remove water from the fuel helps. I have experienced the same problem in a honda minivan. Airplanes are always checked for water in the fuel. Also moving cold air thru the throttle plate causes some ice formation in very cold weather.
06-24-2011 03:00 PM
BryGuy888 thanks for the help guys, should be bringing it in this weekend. It has stopped idling weird the day after, so I'm not sure if it's too necessary.
06-20-2011 10:37 AM
thomas156 Try this update on the engine computer... it saved me...

http://www.wkjeeps.com/misc/Patriot/TSB/tsb_1803107.pdf
06-17-2011 05:45 PM
tripplec It seems like it may be trying to get into the preprogram slot based on sensor feedback and is over shooting either way. So you're not doing your own service. The dealer should have picked up on it if they're worth anything.

Has the spark plugs been replaced recently, if original thats a first and easly to do. Air filter would be next to check. Both easly to take care of and you don't need the threw the roof OEM air filter either. A couple of clips and out she comes. Check your work orders to see what was replaced. There may be codes thrown if bad as well.

Good luck.
06-14-2011 02:02 PM
BryGuy888
Idling Issue

I have come accross a few threads on here regarding idling issues, but they have unfortuately havent been able to answer the question I'm asking myself. I currently have a 2007 Jeep Compass Sport 4x4 2.4L CVT. While I'm parked my car usually idles at 600 constant but starting yesterday while on a normal route home I came to a park at a red light and my rpm was ranging back and forth going from 600 to 700 then making a vibration/purring effect that is rather noticable and semi loud outside the vehicle. I have had the on and off idle issue that lasted maybe a half day or so before but never this long. I last had my oil changed around 2500 miles ago and had my air filters and cabin filter changed around 4000 miles ago. All routine maintenance has been done since the day I purchased it from the dealer (35k miles) and now it sits at a few miles short of 51k. I'm from Rhode Island and i know in the winter my Jeep starts and maybe once a week or every other week idled a bit rough when it was very cold outside. Last week we had temperatures at around 85 to 95 and just this past weekend and including yesterday when the issue started we've had low temperatures of around 55 to 60. Could it be that I may be do for an earlier oil change? ECM TCB issue (common in 08's)? Change in weather? Any help would be greatly appreciated

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome