Jeep Compass Forum - Reply to Topic
Thread: Lose of Power (real hard) Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
01-11-2012 12:05 PM
wojeda
web to download manual

Jeep Compass 2007-2009 Service Repair Manual Download - Download Technical


here is where i downloaded the manual. 12us$. preatty good manual!!!
01-07-2012 03:45 PM
tripplec
Quote:
Originally Posted by wojeda View Post
yes, I did check your chart.
the dealer here told me that is not valid here in peru. here we have 50,000km or 2years of warranty. after that nothing is under warranty. Most of the dealers do that here in Peru. Some chinese car are bringing better warranties agreements, lets see if the big companies learn from that.

Thanks,
William
It was an example of variations in subsystem of the warranty. Like power train goes to 100,000km in Canada. Your owners manual would have warranty info and/or if there is a peru website for Jeeps. I don't know.
01-07-2012 03:27 PM
wojeda yes, I did check your chart.
the dealer here told me that is not valid here in peru. here we have 50,000km or 2years of warranty. after that nothing is under warranty. Most of the dealers do that here in Peru. Some chinese car are bringing better warranties agreements, lets see if the big companies learn from that.

Thanks,
William
01-07-2012 03:21 PM
tripplec
Quote:
Originally Posted by wojeda View Post
Hi ALL,
I picked up the truck from the shop.

Job's done was:
- clean catalytic converter
- weld the exhaust (the guy said due to high pressures it cracked).

I test the truck in the highway and i have the power back. Also im back with a 10.1L every 100km (this is about 36.7km/gal or 22.9mpg us) with A/C on instead of 21km/ga//13.1mpg.

Cause was according shop: FUEL WITH LOTS OF CARBON (CONTAMINATED).

No more fuel ups in the highway,... must fuel up in a well known fuel station. Here in Peru seems that are some mf that try to make money adding some crap in the fuel.

Costs:
260us$ for cleaning, includes man hours.

new catalytic filter, including exhaust: 1150 us$

regards,
william
Yes, its best to stick with name brand fuel stations. They also add the detergent to keep the engine and fuel system clean. SHELL gas here has a nitrogen additive they advertise which suppose to do an amazing job cleaning buildup.

Well its good you've got it back and running normal again. Did you see the chart I posted about warrant and emissions charts which were for the US.
01-06-2012 11:35 PM
wojeda Hi ALL,
I picked up the truck from the shop.

Job's done was:
- clean catalytic converter
- weld the exhaust (the guy said due to high pressures it cracked).

I test the truck in the highway and i have the power back. Also im back with a 10.1L every 100km (this is about 36.7km/gal or 22.9mpg us) with A/C on instead of 21km/ga//13.1mpg.

Cause was according shop: FUEL WITH LOTS OF CARBON (CONTAMINATED).

No more fuel ups in the highway,... must fuel up in a well known fuel station. Here in Peru seems that are some mf that try to make money adding some crap in the fuel.

Costs:
260us$ for cleaning, includes man hours.

new catalytic filter, including exhaust: 1150 us$

regards,
william
01-05-2012 06:51 PM
tripplec Well according to Chrysler there are NO field servicable parts in the CVT. I've been throught that big time already. Emissions sensors and controls are usually independant. You can check with customere service at Chrysler. You have nothing to loose and can authorize warranty repair on the item(s). If you don't call, well you pay for sure.

Added Image, various emission coverage for different categories. I don't know what it in each but they are extended times. This was for a 2008 but may differ in your country. I cannot select a different country on the Jeep website.
01-05-2012 05:57 PM
wojeda
Quote:
Originally Posted by tripplec View Post
Catalytic converter is part of the emissions system and usually have at least 5 years warranty on emission components. I would check with Chrysler customer service while they still have it in the dealership. Don't get taken. It shouldn't happen!!!
I AGREE.

BUT here in Peru, warranty is for 2 years or 50,000km, what happens first. I know that this sucks but it is what it is. Here in Peru jeep is like a fancy car, a regular compass is about us$30,000. 75 years edition 2011 cost us$40,000.

The guy in the dealership told me that they have change some cvt and some transmission parts in compass, as part of the warranty agreement. lucky they got the problem when truck was new... if not.... need to buy a new cvt or transmision parts (ball ends, and rods..).
01-05-2012 04:50 PM
tripplec Catalytic converter is part of the emissions system and usually have at least 5 years warranty on emission components. I would check with Chrysler customer service while they still have it in the dealership. Don't get taken. It shouldn't happen!!!
01-05-2012 04:09 PM
wojeda
good news

I got the truck into the dealership.

They call me in the morning with news. They found that the catalytic converter is clogged.......

They dont have the part (i google it, and cost about us$600 in US, here in Lima Peru for sure will go over us$1000). So they are "cleaning" the converter. This guy told me that there has been some cases with catalytic converters clogged, probably due to bad fuel. they cleaned and no more news about that, i thin it will work.

Once i have the truck back i will post the results.

Unfortunately here i coudnt find any catalytic cleaner product....

Will post you how much the cleaning solution will cost also.

regards,
William
12-30-2011 01:47 PM
tripplec
Quote:
Originally Posted by wojeda View Post
Yes, in neutral or parking the engine seems responsive. But goes justo to 3500 (i think this is blocked electronicly). I think also because there is no torque to the motor, this dont need too much gas to rev up, so we can not see the fuel pump limitation or filter clogged. am i right?
Yes I'd say they're limited from over reving with the transmission engaged as they are from exceeding the RED Line RPM to protect the engine.

It sound more an more like a CVT issue. Does it accellerate in reverse ok. I don't expect you to go for a drive backwards though LOL... short bursts or when knowone is around.

What the software/firmware ever updated on your Compass. This can only be done at the dealer. There have been a number of updates over the years. You may want to check by phone with the most reliable dealer in your area first and verify the cost of get the computers updated.
12-30-2011 01:28 PM
wojeda
Quote:
Originally Posted by tripplec View Post
I doubt the fuel cleaner will help with your situation, a waste of money. Yes, white plugs are an indication it running too hot as likely not enough gas injected into engine.


How does the engine run and rev in neutral? Does it sound responsive?
Yes, in neutral or parking the engine seems responsive. But goes justo to 3500 (i think this is blocked electronicly). I think also because there is no torque to the motor, this dont need too much gas to rev up, so we can not see the fuel pump limitation or filter clogged. am i right?
12-26-2011 04:07 PM
tripplec I doubt the fuel cleaner will help with your situation, a waste of money. Yes, white plugs are an indication it running too hot as likely not enough gas injected into engine.

Gas tanks used to have a sock as a filter around the intake in the gas tank but still have filter inline somewhere. You can call a dealer and ask for a gas filter for you vehicle and they'll have look it up. Get a price and ask where its located. If you're at the parts counter they can show you on the computer as well.

How does the engine run and rev in neutral? Does it sound responsive?
12-26-2011 03:39 PM
wojeda Here more feedback:
- Im going close to 3800rpm when pushing hard (1st, 2nd, 3rd, 4th gear). Againg the truck goes like slow to that rpms.

- When i got the spark plugs changed, the shop man told me that it wasnt so bad, and after two days using new ones, the man at the shop told me that it seems that very litte gas is getting in, bacause the splugs are like "white".

Im already adding a cleaning liquid every time i fuel the truck.
After new year i think im going to take the truck to the dealer if this dont gets better.

This truck dont have an inline fuel filter, thats a bad thing, you need to open the gas tank... which can be difficult (i havent seen a video or have a manual).

thanks for ur help. Im driving today 200km in the hiway, let see what happens.

regards,
William
12-24-2011 01:57 PM
tripplec I don't know when you replaced your spark plugs. You can pull two and see what the electrodes look like. If there is a lot of contamination on them (build up on the plug) you've been burning bad/dirty gas. Then replace them since its only 4 plugs and easy to do with a long extension to reach down to them.
12-24-2011 01:42 PM
tripplec I can't help a lot but if there is bad/dirty gas and its affecting performance. The fuel filter is the first line of defense. If its plugged pretty good then changing it would be the first step. I have no idea where it is on the Compass. It could be inline or even on top of the gas tank. Injectors shouldn't get plugged but could get a lot of build up from bad gas. You could try a good injector cleaner added to the gasoline.

A lot of things and make it real sluggish or powerless
- badly plugged air filter
- restriction in the fuel line (filter clogged)
- low gas pressure to injector rail (fuel pump and clogged filter can cause this)
- transmission issue ???

What RPM are you getting when trying to accellerate. Is it going above 2000RPM, 3000PRM ???
12-23-2011 08:33 PM
wojeda
Lose of Power (real hard)

My truck is loosing lots of power. I can not go speed up, but the truck is drinking fuel (11.8mpg instead of 20mpg before).
I changed refill full the gas tank twice(thinking in a bad fuel), but i still have the problem.
when i try to acelerate slowly, truck does good. i can reach 60mph acelerating slowly, buy if i push hard the pedal, the truck does not reach the final speed, it seem something is pulling backwards.
i try in manual position, when im in first and push hard same happens, it goes very slowly to the final velocity.
there is no light that says engine check.
Brakes seems ok, no hot weels or something, all liquid levels ok, air filter clean, no hot engine. I went to a shop and they changed all the spark plugs, but nothing happen.
Today in another shop, the guy told me that maybe is a damage fuel pump, or the inyectors are soo dirty and needs to be cleaned. I dont know what to do at this point, i think it is safe to drive like this because no engine check lignt.
just 10 days ago i fuel the tank in a gas station quite suspicious, maybe that fuel was dirty or maybe that was not premium fuel, i dont know what to do now. If somebody can give me a suggestion please believe me it helps.
If nothing happen to the end of the year, im planning to go to the dealer (probably they will told me to change the hole engine, all suspension, even the tires for thousands of dollars, they are good doing that).

The truck has 70,000km. 2008. Im looking after my warranty info, but probably the dealer will say that i didnt change the windshield water with them so the warranty is avoided (this happens in Peru with Jeep, incredible!!)
PLEASE ANY HELP IS WELCOME

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome