ESP/BAS Issue - Jeep Compass Forum
 1Likes
  • 1 Post By JeepCares
 
LinkBack Thread Tools Search this Thread
post #1 of 23 Old 10-27-2007, 03:26 AM Thread Starter
Junior Member
 
Join Date: Jun 2007
Posts: 15
 
ESP/BAS Issue

Hi,

Tonight I got in the Compass to take a quick run to the store, and I happened to notice that the ESP/BAS lights were both on. This has been the first time I drove it in like 3 weeks... or more... I asked my parents, and my Dad thought that it had to do with the ESP being turned off or something, which he though was "normal"...

Well, being mechanically inclined, and the fact that I do the maintainance on the vehicles, I know that those lights are NOT supposed to be lit.

However, here is the catchy part... according to my Dad, he said that it would come on and then go out... and then another time he would drive it and it would come on and then go out. So I have no clue as to what is possibly causing it.

I need to get a service manual for this thing...

Maybe someone can shed some light on to this for me...

Or should I let a dealer look at it?
manualf150 is offline  
Sponsored Links
Advertisement
 
post #2 of 23 Old 10-27-2007, 04:22 AM
 
Join Date: Sep 2006
Posts: 362
 
What's BAS? If the ESP light is on, perhaps you bumped the ESP button down by the shifter? Does it come on every time you turn the Jeep on?
Webmaster is offline  
post #3 of 23 Old 10-27-2007, 01:56 PM
 
Join Date: May 2007
Posts: 9
 
same problem

We have the same problem. We got our compass last winter, and the ESP/BAS light came on once in a while. I looked in the manual and it said if it doesn't go off after a few ignition turn offs and ons there is a manfunction with the system. Ours turns off everytime it happens, but we still took it to the dealer aleast 4 times for it and they say there is nothing wrong. The weird thing is it only happens in the cold weather. It did not do it at all through out the summer months. But yesterday it was pretty cold here and sure enough when I was coming to a stop at a red light it came on. I wish I could tell you what exactly is going on with it but I havent figured it out yet! I will definetly let you know if it gets straightened out... Other than a rattling noise behind the dash and the light problem I love our compass.
acros is offline  
Sponsored Links
Advertisement
 
post #4 of 23 Old 10-27-2007, 10:58 PM
Member
 
Join Date: Apr 2007
Location: Tampa, Florida
Posts: 70
 
Garage
This has happened to me several times. Sometimes it occurs after I've been idle for awhile, like sitting in a parking lot with the car on. It eventually turns off. I've called service about it, they said I would have to bring it in, but before I got there the light was off, next oil change I'll ask them about it.

Jeep Compass LIMITED 4x2 - Jeep Green
*Driver Package
*Security Package
*Boston Speaker Upgrade
*U-Connect Connectivity
*Sirius Sat. Radio
*Pin-Strip
*Wheel Locks
*Black Vent Visors
*LED Multi-Color Underglow
*Rallye Body Kit [Pending Installation]
AmercanEagleDude is offline  
post #5 of 23 Old 10-28-2007, 03:00 AM
 
Join Date: May 2007
Posts: 5
 
Had this problem with mine..... the ESP/BAS light would come on and the chime would ring, signifying an error code had been set. After several passes at the dealer they replaced a part in the steering column and installed a TSB (08-010-07) for the steering column sensor that's available to resolve this problem.

Can't say if my problem is the same as yours .... but they sound similar.
unibus is offline  
post #6 of 23 Old 10-28-2007, 04:06 AM
 
Join Date: Sep 2006
Posts: 362
 
Webmaster is offline  
post #7 of 23 Old 10-28-2007, 01:07 PM
Senior Member
 
i2canoe's Avatar
 
Join Date: Apr 2007
Location: Montreal, Canada
Posts: 656
 
Garage
Wouldn't have called it a problem, but yesterday the chime sounded and the BAS/ESP light came on while driving. It had been and still was raining very hard and temperature was plus 14 C.
It did not happen again when I later used the car.
-[OIIIIIIO]-

Loved
my 2007 Compass 5-Speed, Limited!

{BUT NOW SOOO IN LOVE WITH MY NEW CRUSH WRANGLER!}
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

-[OIIIIIIO]-

"No man should go through life without once experiencing healthy, even bored solitude in the wilderness, finding himself depending solely on himself and thereby learning his true and hidden strength."
~Jack Kerouac


“Everybody must believe in something. I believe I'll go canoeing.”
-Henry David Thoreau

i2canoe is offline  
post #8 of 23 Old 10-28-2007, 01:43 PM
 
Join Date: May 2007
Posts: 5
 
Quote:
Originally Posted by i2canoe
Wouldn't have called it a problem, but yesterday the chime sounded and the BAS/ESP light came on while driving. It had been and still was raining very hard and temperature was plus 14 C.
It did not happen again when I later used the car.
-[OIIIIIIO]-

It doesn't seem like much.... but once the light comes on and the chime rings the ESP/BAS systems are no longer functioning. The system does reset when the car is turned off and back on however.
unibus is offline  
post #9 of 23 Old 10-28-2007, 02:36 PM
Senior Member
 
i2canoe's Avatar
 
Join Date: Apr 2007
Location: Montreal, Canada
Posts: 656
 
Garage
Quote:
Originally Posted by unibus
It doesn't seem like much.... but once the light comes on and the chime rings the ESP/BAS systems are no longer functioning. The system does reset when the car is turned off and back on however.
: So under what conditions is this supposed to occure : -[OIIIIIIO]-

Loved
my 2007 Compass 5-Speed, Limited!

{BUT NOW SOOO IN LOVE WITH MY NEW CRUSH WRANGLER!}
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

-[OIIIIIIO]-

"No man should go through life without once experiencing healthy, even bored solitude in the wilderness, finding himself depending solely on himself and thereby learning his true and hidden strength."
~Jack Kerouac


“Everybody must believe in something. I believe I'll go canoeing.”
-Henry David Thoreau

i2canoe is offline  
post #10 of 23 Old 10-28-2007, 04:36 PM
 
Join Date: Oct 2007
Posts: 1
 
ESP/BAS Issue

I had this happen a few weeks ago. I took my compass to the dealership and they flashed the module per a tech service bulletin they had. The light has not come back on yet; although I have heard that this did not work for some people.
nyxranko is offline  
post #11 of 23 Old 10-29-2007, 01:43 AM
 
Join Date: May 2007
Posts: 5
 
: So under what conditions is this supposed to occure : -[OIIIIIIO]-[/quote]

Not sure I understand your question but.... It shouldn't occur at all. My compass would usually have this problem when I was turning a corner. Once the compass was turned off and back on the light woudl go out and all would be fine for a couple of min or sometimes a couple of weeks.
unibus is offline  
post #12 of 23 Old 10-29-2007, 04:45 AM
 
Join Date: Oct 2006
Posts: 62
 
I had this happen once. I was turning a corner when it happened but I wasn't going very fast, the corner wasn't a sharp turn (actually >90 degrees), it was a warm summer evening, and the road was completely dry. It hasn't happened since but I will add the TSB to my list. Thanks.
BreatheJeeply is offline  
post #13 of 23 Old 11-08-2007, 04:52 AM
 
Join Date: Nov 2006
Posts: 109
 
The last time I got lights on was because the nuts on my two front wheels were loose. I had service the day before and they did not tighten the nuts enough so they became loose a bit and it was enough for the whole system to detect it and show it by turning on those lights.

Make sure your wheels nuts are very well tighten, use the tightener that comes with the spare tire to tighten them if you don't have anything else, it wil also permit you to figure out how all the spare stuff works.

RedVortex
RedVortex is offline  
post #14 of 23 Old 01-13-2008, 06:09 AM Thread Starter
Junior Member
 
Join Date: Jun 2007
Posts: 15
 
Re: ESP/BAS Issue

Well, to give you guys an update.. it hasn't come back on. So I have no clue what caused it.

Also... what is the spec on tightening the lug nuts? I keep tightening them to 110 ft/lbs or 150 n/M...
manualf150 is offline  
post #15 of 23 Old 01-14-2008, 06:53 PM
Senior Member
 
Neely2005's Avatar
 
Join Date: Mar 2007
Location: Toronto, Ontario - CANADA
Posts: 360
 
Re:

Quote:
Originally Posted by unibus
: So under what conditions is this supposed to occure : -[OIIIIIIO]-
Not sure I understand your question but.... It shouldn't occur at all. My compass would usually have this problem when I was turning a corner. Once the compass was turned off and back on the light woudl go out and all would be fine for a couple of min or sometimes a couple of weeks.[/quote]

It's not supposed to come on and stay on. If the system activates due to the vehicle slipping or coming close to tipping etc. then the system will come on and the light will come on while the system is operating. Once the vehicle is back and operating safely then the light will go out.
I've only had the light come on once & that was when I wanted to test the system. I was making a turn on a snowy road and usually I brake but this time I didn't and sure enough the system came on and applied the Front Left Brake to straighten the car out. Pretty cool

2008 Jeep Compass Limited 4X4 (CVT)
Neely2005 is offline  
post #16 of 23 Old 01-18-2008, 12:51 AM
 
Join Date: May 2007
Posts: 5
 
Re: ESP/BAS Issue

You are correct that the ESP/BAS light will come on when the system activates to prevent loss of control of the vehicle. It will go back off when you are back under control.

What I was referring to was the ESP/BAS light activating for no reason and staying on until the vehicle is turned off and back on. This is accompanied by a chime signifying an error code being recorded by the computer. Once the light comes on in this fashion and stays on the system is no longer protecting you.
unibus is offline  
post #17 of 23 Old 01-27-2008, 05:59 AM
 
Join Date: Jan 2008
Posts: 1
 
Re: ESP/BAS Issue

I was curious if there were anymore answers regarding this question. I just bought my compass today, and around mid day I noticed the esp/bas light comes on and stays on while I drive (no flashing), and next to it is the traction control icon (car with squiggley lines) stays on as well (no flashing). The manual doesn't explain this very well and I dread thinking I was just sold a lemon.

Please help.
sjfb25 is offline  
post #18 of 23 Old 02-15-2008, 09:44 PM
 
Join Date: Feb 2008
Posts: 4
 
What da heck!? Friggin ESP BAS light

Hey guys what's up the ESP BAS light of death came on with the chime. It just happened to me like 30 minutes ago. I was making a right turn and all of sudden the chime went on and the ESP BAS light was on. I was just hoping that the light would go off once I got home. It was still on though. So I figure to turn of the engine then start it up to see if it would go away. I did that for like 2 or 3 times. It was still the same. So right now I'm gonna wait it out. Cause I'm going out again later. I'm hoping it will be back to normal again. This never happened before. I mean it flashed on one time then just turned off. But other than that it was ok. Just now it stayed on. What do you guys think I should do? Should I go to the dealer right away or should I wait it out a couple of days? Cause I don't want it to all of a sudden be a hole in my wallet ya know. Hehe. I post again soon to let you guys know if its still on. Thanks guys. : :!: :|
mikedee6282 is offline  
post #19 of 23 Old 02-19-2008, 02:07 PM
 
Join Date: Feb 2008
Posts: 4
 
Oh thank God!

Alright nevermind. I did try it again. I started the car up and it still had the ESP/BAS lights on and I was like what da hell!? But once I started driving it was gone. So I'm thinkin' it just likes to play games on me. hehe. Sigh of relief! :!:
mikedee6282 is offline  
post #20 of 23 Old 03-27-2008, 01:20 AM
Member
 
Join Date: Apr 2007
Location: Tampa, Florida
Posts: 70
 
Garage
Re: ESP/BAS Issue

So I went to the dealership today (one that actually took my issues seriously.) The ESP/BAS Issue was related to the Steering Angle Module going bad. They replaced it under warranty and I haven't had the issue since, I'm also no longer having issues when I break very quickly (it used to shudder).

Jeep Compass LIMITED 4x2 - Jeep Green
*Driver Package
*Security Package
*Boston Speaker Upgrade
*U-Connect Connectivity
*Sirius Sat. Radio
*Pin-Strip
*Wheel Locks
*Black Vent Visors
*LED Multi-Color Underglow
*Rallye Body Kit [Pending Installation]
AmercanEagleDude is offline  
post #21 of 23 Old 06-24-2015, 05:51 PM
Junior Member
 
Join Date: Jun 2015
Location: mid-Missouri
Posts: 13
 
Garage
So the ESP/BAS and the "swerving car" are two separate lights? Because I have the same problem, but they both come on at the same time. sometimes staying on for only a few seconds and sometimes staying on for several miles.

Last edited by jaketsnake; 09-19-2015 at 06:03 PM.
jaketsnake is offline  
post #22 of 23 Old 06-25-2015, 03:49 PM
Senior Member
 
JeepCares's Avatar
 
Join Date: Apr 2012
Posts: 394
 
Quote:
Originally Posted by jaketsnake View Post
So the ESP/BAS and the "swerving car" are two separate lights? Because I have the same problem, but they both come one at the same time. sometimes staying on for only a few seconds and sometimes staying on for several miles.
Hey jacketsnake,
To answer your question, the ESP/BAS indicator and Traction Control are two separate lights. You can find additional information in your Owner Manual, I’ve provided a link for an electronic version below. I would also recommend having your Jeep checked for any stored Diagnostic Trouble Codes. Let me know if this helps!

Jeep Owners | Download an Owners Manual 2004 - 2011 | Jeep
jaketsnake likes this.
JeepCares is online now  
post #23 of 23 Old 08-12-2019, 06:46 PM
Junior Member
 
Join Date: Aug 2019
Posts: 2
 
I just bought an 07 Compass. on Sunday i was driving and the BAS/ESP and traction control lights all came and the car wanted to only steer right when trying to drive. What is this problem?
ldressler is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome