Vibration/Shudder only when accelerating - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 2 Old 03-15-2019, 02:41 PM Thread Starter
Junior Member
 
Join Date: Jan 2019
Posts: 4
 
Vibration/Shudder only when accelerating

I have a 2010 Compass that is giving me and the local dealer a hard time. I need suggestions or resolutions based on similar symptoms.

2WD CVT 2.4

Symptom:
When accelerating from a stop, the car will shake like it has a tire out of balance or the tie rods are super loose.

- Steering does not shake
- K member, A-arms/ball joints are brand new.
- Struts swapped out twice
- anti sway bushings replaced, links replaced.
- Driver side CV axle replaced
- Passenger side CV axle replaced (half shaft and carrier bearing NOT changed)

All these factors did not resolve the issue, although the parts were in need of replacement.

The dealership has also checked my work and cannot pinpoint the issue. They also updated the firmware in the PCM/TCM to latest available (some bulletins did indicate a similar issue) just to rule that out.

Wheel bearings are OK per dealership and my inspection.
Tie rods and inner tie rods are OK, too. Rack seems fine as well.

The transmission seems to be OK, no whining, grinding, etc, and shifts normally. No codes, either.

Dodge thinks the issue is in the driveline, but can't pinpoint it. I was going to drop the tranny fluid and change filter, but Dodge says that fluid won't cause that type of vibration.


Any suggestions?
crang94 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 03-22-2019, 03:27 PM Thread Starter
Junior Member
 
Join Date: Jan 2019
Posts: 4
 
Further investigation and following evidence, the issue seems to be with ride height. Per spec, the height measured from level ground to the center of the lead A-Arm bolt should be 8.07". I am measuring 10.5."
I installed new struts (not best quality) and the ride height changed to 10"
There was an improvement.
THe new CV axles are either really bad quality or I really need to drop to 8.07"
I don't understand why the axles can't handle the angle.
crang94 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Similar Threads
Thread Thread Starter Forum Replies Last Post
2007 Compass Pulls to Left When Accelerating, With Solution! Bart Handling, Braking and Suspension Discussion 5 07-31-2019 02:16 PM
Engine light on after hard acceleration, now it's having difficulty accelerating victory42day Powertrain Discussions 3 01-29-2016 07:56 PM
Engine Jump While Accelerating BryGuy888 Repairs - Mechanical problems and questions 6 07-25-2011 09:41 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome