TIPM OMG here I go... - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 8 Old 02-05-2012, 06:06 PM Thread Starter
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
TIPM OMG here I go...

Well I've had plenty of trouble with my fog lights not coming on or a varying delay on coming on. Many times just turning them off and on triggers it correctly. However the dash indicator always comes on and is not indication of illumination out front. You can't run out while drive to see if they came on (at least I am not that athelitic). It has always boiled down to a fault in the TIPM which has been replace at least twice for that problem and was finally resolved a year ago. However, with my in dash temp not working properly it was replaced again (this is #4 or 5 at least now) to resolve decoding issues. I haven't used the fog lights much this winter and the last time it did not seem to light up the road any better. I checked today in found it would not come on despite over 6-10 varying combinations of on off but eventually did after a short drive going for gas. A hour later I when out and it wasn't working and on the 2nd on/off it came on after nearly 2 sec delay of pulling the switch.

The part is suppose to be under warranty for a year after changing. I will cross that bridge now and see. There is a lot of controls going through the complex module and in my opinion unnecessarily complex. Give the old relay fuse box of other vehicles and I can fix that myself. This is solid state for the most part and programmable. I must have at 10 service work order around this by now. No sooner I think I am getting ahead and eliminating problems what shouldn't happen happens.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 02-06-2012, 03:08 PM
Member
 
lucy2423's Avatar
 
Join Date: Aug 2011
Location: North Dakota, USA
Posts: 98
 
Is there any way that something else is making this part fail prematurely? That maybe it's not the part that's the problem, but something linked to it?

2011 Jeep Compass
Latitude 4x4
2.4L, CVT
lucy2423 is offline  
post #3 of 8 Old 02-06-2012, 03:27 PM Thread Starter
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
Quote:
Originally Posted by lucy2423 View Post
Is there any way that something else is making this part fail prematurely? That maybe it's not the part that's the problem, but something linked to it?
Everytime the dealer trouble shoots it and tests the signals. The document that there is an internal failure. The original and 2 replacements had this fault affecting the fog lights. Two were replaced to address the dash temp not function (did not display the current temperature or did not updated for 4 hrs or more, oh the dash display was also replace twice for that reason as well).

If there is something else this time it would be huge surprise having been down that road way too many times. The symptoms are the same. I doubt the plugs into the TIPM from the Compass's electrical buss is the issue since the see the signal to turn it on but the power circuit did not activate. The dash light is separate.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
Sponsored Links
Advertisement
 
post #4 of 8 Old 04-01-2012, 02:24 PM
Senior Member
 
zackman's Avatar
 
Join Date: Nov 2009
Posts: 222
 
Quote:
Originally Posted by tripplec View Post
Everytime the dealer trouble shoots it and tests the signals. The document that there is an internal failure. The original and 2 replacements had this fault affecting the fog lights. Two were replaced to address the dash temp not function (did not display the current temperature or did not updated for 4 hrs or more, oh the dash display was also replace twice for that reason as well).

If there is something else this time it would be huge surprise having been down that road way too many times. The symptoms are the same. I doubt the plugs into the TIPM from the Compass's electrical buss is the issue since the see the signal to turn it on but the power circuit did not activate. The dash light is separate.
this is the problem i have with my headlights! hopefully it will get fixed soon

2007 jeep compass
2WD 2,4L
190,000 km (Always in the shop)
Recently Overhauled every link/bushing in the front/rear
20% tint on windows
Lamin-X smoked tail lights
Painted all silver interior trim satin black.
I strongly Reccomend You Don't buy a Jeep Compass!!!!
zackman is offline  
post #5 of 8 Old 04-01-2012, 02:32 PM Thread Starter
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
Quote:
Originally Posted by zackman View Post
this is the problem i have with my headlights! hopefully it will get fixed soon
The problem came back with another TIPM and they gave up replacing them. They did replace the Multifunction Switch stalk (left side of the steering column) a few weeks ago. So far its been ok. The part was around $70 plus labour but the dealer covered it even though the warranty is over..

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
post #6 of 8 Old 04-03-2012, 01:41 PM
Super Moderator
 
Tyler-98-W68's Avatar
 
Join Date: Feb 2012
Posts: 530
 
Garage
Ask the dealership about the "cabin control node" CCN if any problems come up again, now I have a 2012 (so it may be different) and had a ton of issues with what seemed to be the TIPM however it was not and they eventually narrowed down to the cabin control node, and after replacing that all my problems went away.

PM me if you want the scoop on what happened to my compass.
Tyler-98-W68 is offline  
post #7 of 8 Old 04-03-2012, 03:18 PM Thread Starter
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
I have not heard of that unless its a 2012 specific item. Where is it located?

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
post #8 of 8 Old 04-06-2012, 10:49 AM
Administrator
 
Cherokee's Avatar
 
Join Date: Feb 2007
Location: USA
Posts: 1,362
 
That's a new one on me as well, more info Tyler?

- Cherokee





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My 2007 Jeep Compass Sport, Bright Silver Metallic, 26E, CVT II, Driver Convenience Group, Sunroof, Trailer Tow Prep Group, 4x2

1991 XJ Cherokee Sport 4X4 4.0 H/O I6
2008 Dodge Ram 1500 ST, SWB Reg Cab, Bright Silver Metallic, Trailer Tow Package

JEEP - Just Enjoy Everything, Period.....
Cherokee is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome