Starter motor continues cranking and seizes - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 4 Old 02-10-2014, 10:10 PM Thread Starter
Junior Member
 
Join Date: Aug 2013
Posts: 5
 
Starter motor continues cranking and seizes

Hi everyone.

Firstly, vehicle details, 2007 Compass Sport; 2.4 inline4, 5 speed manual, front wheel drive.

So, my issue is I'll be driving along normally and without warning this very loud squeeling sound starts under the hood. The first time it happened, I had no idea what was going on and thought it was just a belt or pulley.

As it turns out, it was actually the starter motor that was being forced to continuously turn over (as though it was starting the motor) and I suppose it simply burnt itself out. Massive amount of smoke under the hood.

I had it towed to the dealership and paid nearly $600 for a new starter and associated labour.

Second time this happened, was about 7 weeks after, exactly the same situation. I managed to get it off the road this time and turn the ignition off.

Even with the key removed from the ignition the starter motor continued to turn over until it burned itself out. This time the part and repair was covered under warranty.

The third time was this morning, about 7 weeks after the second time.

As soon as I heard it happening I pulled over to the shoulder of the highway and turned the motor off. Again, the starter motor continued cranking. I called the tow truck company and waited. After a few minutes, out of curiousity, I decided to try starting the motor and it turned over as usual and I drove myself to work. At lunch I drove around a few minutes and nothing happened. On my way home, it ran as usual.

What the hell is happening here?!

I absolutely hate to drive in a vehicle I cannot trust. I feel like pushing this thing into a lake.
ezzys07compass is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 02-11-2014, 01:49 AM
Junior Member
 
Join Date: Feb 2014
Posts: 1
 
I have the same issue

2007 Jeep Compass 2.4 5-speed manual 4WD/AWD

I've had the starter replaced three times. Just like you described, it was a squeal like a belt or something and if you manage to turn it off it will continue to turn the engine with the key out. I've considered running a hard wired battery switch just to kill it before the starter burns out.

If I ever figure it out, I'll post it here. And if you figure it out, please post back.

Last edited by Scrimshaw; 02-11-2014 at 01:52 AM.
Scrimshaw is offline  
post #3 of 4 Old 02-11-2014, 03:34 AM Thread Starter
Junior Member
 
Join Date: Aug 2013
Posts: 5
 
Quote:
Originally Posted by Scrimshaw View Post
2007 Jeep Compass 2.4 5-speed manual 4WD/AWD

I've had the starter replaced three times. Just like you described, it was a squeal like a belt or something and if you manage to turn it off it will continue to turn the engine with the key out. I've considered running a hard wired battery switch just to kill it before the starter burns out.

If I ever figure it out, I'll post it here. And if you figure it out, please post back.
Oh gladly!

This is just ridiculous. After I left it sitting on the highway for a few minutes it started up and drove normally. This evening I took mine out to see if I could get the same result. I drove the hell out of it with all manner of accessories running. Drove normally.

This can't be a mechanical issue with the starter motor. Must be electrical. I've been hearing it has to do with a faulty TIPM (total integration power module).

I'll consider replacing it, but it's expensive!

How do you hardwire a kill switch? I'd do that. I don't want yet another tow truck and lost time.
ezzys07compass is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 02-12-2014, 02:06 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
clearly the dealership address the resulting fault and did not investigate what caused it. I appears like the 2nd time as well. I'd inspect the harness under the hood if its rubbing somewhere and/or out of it secured position. Corrosion can cause weird things to happen as well as bad grounds. Its not the time of year to be doing a lot with wiring since its all stiff from the cold we're having.

I would expect it to happen more often if the TIPM was defective. They are expensive as I have been through a handful of them under warranty. Thankfully!!

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome