Turn signal warning light still activates even with new bulb - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 6 Old 04-12-2014, 09:03 PM Thread Starter
Junior Member
 
Join Date: Sep 2011
Posts: 2
 
Turn signal warning light still activates even with new bulb

Greetings,

I have an 07 Compass Limited. The warning that the front right signal was out started going off so I replaced the bulb and the warning wont go away. I thought maybe the new bulb was bad but I have tired 4 new bulbs.

The left side works, so I swapped the bulbs and the same problem happens so it something isolated to the right. I swapped the bulb housing from left to right and the problem always remains on the right.

The only thing i can figure is that there is a wire short somewhere on the right....ideas?
Snowb1sp19 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 04-13-2014, 02:44 AM
Super Moderator
 
Tyler-98-W68's Avatar
 
Join Date: Feb 2012
Posts: 530
 
Garage
Did you replace with a new halogen bulb of the same wattage as the old bulb. The MK TIPM (Computer) is very sensitive to difference voltages ect, however I've only heard this issue happening when using lower wattage LED bulbs.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2012 Red FDII Jeep Compass Limited
235/75/15 Wranger Territory AT
WK2 Headlight Swap
Magnaflow Muffler

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Full Interior LED's + Front/Rear Signal & Backup LEDS

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Tyler-98-W68 is offline  
post #3 of 6 Old 04-13-2014, 12:54 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
Every vehicle I've seen with signal failure indications (the dash light no longer flashes, just stays steady on). Implies only that side, so either the rear or front is the problem. If the elements coming on I'd check the rear for sure.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 09-19-2014, 07:10 AM
Junior Member
 
Join Date: Sep 2014
Posts: 5
 
Is the bulb a CAN BUS bulb ? That could cause fault if computer can't see the bulb.
White_Wing04 is offline  
post #5 of 6 Old 09-19-2014, 01:05 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
No to the CAN BUS, if you have the vehicle wired to a trailer as well it would get confused and required a extremely complex controller. 2007 and 2009 like mine should be the same and I have a trailer harness tapped into the lights wiring without negative affect via a controller to the trailer. Typically install for 10 years or more now since 3 light tail light became in use.

You have a Limited and if I am understanding the bulb out warning is alert inside (special feature/option it appears) but the bulb is fine. Every vehicle that used to have that ability had a photo sensor within the light housing to sense the light. I'd suspect the sensor if contamination got in or wire damaged problem in that area. If its just the one bulb especially.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
post #6 of 6 Old 09-19-2014, 07:53 PM
Super Moderator
 
Tyler-98-W68's Avatar
 
Join Date: Feb 2012
Posts: 530
 
Garage
Your TIPM may be defective based on what you have described.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2012 Red FDII Jeep Compass Limited
235/75/15 Wranger Territory AT
WK2 Headlight Swap
Magnaflow Muffler

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Full Interior LED's + Front/Rear Signal & Backup LEDS

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Tyler-98-W68 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome