when turning on heat, just getting warm air out of all vents. - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 1 Old 10-17-2016, 03:38 PM Thread Starter
Junior Member
 
Join Date: Oct 2016
Posts: 1
 
when turning on heat, just getting warm air out of all vents.

when I turn on the heat, i get slightly warm air blowing out all of the vents. They all seem to be the same temp. The air conditioner will get cold, but the heater just gets warm. I've had the coolant system flushed and 2 thermostats replaced. About the blend door, any tricks to getting at it with out full dash removal, or any way to significantly reduce disassembly to access it. I also saw a youtube vid on heater core replacement using sawzall under diver area and waterline/hose clamp deal. Seemed simple enough except if one of those lines fail under pressure and you get scalding hot coolant on your legs, that wouldn't be fun. But i guess you could fab a baffle to keep a leak contained from hitting the driver. is there anything else in the system that could be at fault that im not considering? thanks for any help/advice. I'm a professional motorcycle tech and a decent DIY'er with automobiles so I am attempting some of this myself when possible. Thanks again. Sorry if im in the wrong forum thread, not sure if this is electrically related or mechanical.
Nicholas Teta is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome