2010 Jeep Compass North Won't Start - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 2 Old 01-04-2017, 01:53 PM Thread Starter
Junior Member
 
Join Date: Jan 2017
Posts: 1
 
2010 Jeep Compass North Won't Start

I recently had a third party company install an Alpine stereo in my daughter's 2010 Jeep Compass. Worked good for a few months and then last week the stereo died. I could not get it to power up.

I took it back to the place where it was installed and my daughter picked the vehicle up yesterday with the stereo working again. She went directly from this place to a friend's house and when she came out a few hours later the vehicle would not start.

I went and checked it this morning thinking it needed a boost but the battery seems fine. When you turn the key to the "on" position, everything seems to power up normally (radio, all in dash lights come on). When you turn the key further to start the vehicle there is a complete loss of power. There is no clicking sound or anything. The power just completely shuts off on the vehicle. Before having this "fixed" the radio would stay on in the vehicle after you shut it off until you opened the door and that is no longer the case.

I just called the stereo dealer and he said "there is nothing I could have done to make the car not start". I told him this was bull**** but he's a moron and refuses to acknowledge it was his mistake.

Anyway, does anyone have any idea what he could have done to cause this? Have I provided enough information? Or is this just too complex to answer without actually looking at the wiring?

Any information would be helpful...

Thanks
Magic1965 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 01-04-2017, 03:49 PM
Senior Member
 
Join Date: Nov 2016
Posts: 272
 
The wiring definitely has to be looked at. It seems like they did do something with the power wires in order to get it to power up, but a lot of these "installers" will tap literally anything that lights up a test light which can really screw some things up. Things happens constantly with remote starters as well. Need to take that stereo out and see where all these wires are ran to.
NorthStar is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome