jeep just simply shuts right off when driving - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 7 Old 07-09-2018, 08:34 PM Thread Starter
Junior Member
 
Join Date: Jul 2018
Posts: 1
 
jeep just simply shuts right off when driving

4 times in 2 weeks my 2007 Jeep Compass just shut right down. No spitting and chugging and clunking. Just off! I think the first time I was just driving straight down the highway, NOT turning or hitting any potholes. But honestly I can't remember. The second I was driving out of a sort of bumpy business potholish driveway, 3rd, turning in reverse or maybe already shifted to drive (pulling out of parking spot) 4th don't remember. All times I turned it right back on and off I went. I saw this type of problem on a forum from back in 2010 and they thought the quick fix would be to turn the ESP off but now I'm seeing you can't ACTUALLY turn it off all the way. This is very dangerous though as it can shut off pulling out in traffic. When the mechanic put it on his computer tester thing NOTHING showed up.
Teri Jo La Chonce is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 07-10-2018, 01:47 AM
Junior Member
 
Join Date: Jul 2018
Posts: 1
 
Quote:
Originally Posted by Teri Jo La Chonce View Post
4 times in 2 weeks my 2007 Jeep Compass just shut right down. No spitting and chugging and clunking. Just off! I think the first time I was just driving straight down the highway, NOT turning or hitting any potholes. But honestly I can't remember. The second I was driving out of a sort of bumpy business potholish driveway, 3rd, turning in reverse or maybe already shifted to drive (pulling out of parking spot) 4th don't remember. All times I turned it right back on and off I went. I saw this type of problem on a forum from back in 2010 and they thought the quick fix would be to turn the ESP off but now I'm seeing you can't ACTUALLY turn it off all the way. This is very dangerous though as it can shut off pulling out in traffic. When the mechanic put it on his computer tester thing NOTHING showed up.
We have a 2018 Jeep Compass Limited with 9000k - We have had very similar issues. It began with the car not turning off even though we tried several times pressing the start/stop button. After about 1/2 hour the car shut off on it's own - later on it began to hum, but don't know how long that remained as it had stopped by morning. The dealership could not duplicate the issue, even though it had happened to us two days in a row. As well, all voice commands worked except the temperature set. They kept the car for about a week. The 'mother computer board' was replaced as it was corroded (the car only had @5000km on it and 5 months old). They told us ~ there was to be an update arriving shortly for the radio/navigation and that would fix the issue of the voice command, but the not turning off remains a mystery. FYI - they checked ALL the compass limiteds on the lot and they had the same voice command temperature set issue.....interesting.?!
The car now has a new issue ~ engine stops (turns off) while I'm driving, emergency brake comes on and the 'D' on the gear box and panel cluster flashes and a message to the effect of 'put the car in park to start'. This new issue happened once on 2 consecutive days, not on the 3rd and then 2ce on the 4th day. I videoed it on the 4th day and this time I caught the 'oil pressure low' flash on then off. I would have missed it had I not been videoing it (I was safe in a very quiet residential area with little to no traffic so videoing it was a good idea). I showed it to the dealer. I am having it towed in this week - the dealership asked I check the oil in the car (it has 9000km on it now and due for a change). WHAT A SURPRISE - oil was practically non-existent and just registering on the twisted base of the stick. No oil in my driveway, or garage where I park it regularly, or at work in my designated parking spot. I'm surprised the engine didn't seize. No message about oil except the 'flash' message I caught on video?
BTW - the update for the radio that will 'fix' the voice command for the temperature is still not available 2.5 months later.
Any thoughts or help would be great.........
Jarvis is offline  
post #3 of 7 Old 07-31-2018, 03:38 PM
Junior Member
 
Join Date: Dec 2010
Posts: 7
 
My Compass is a 2009 FWD base model. I was driving it on the highway last Monday and went to accelerate to pass (between 55-60mph) from the middle late to the left land and it completely lost power. Nothing shut off, but when I hit the gas pedal nothing happened. It went down to 45mph and picked back up, but would not go over 50mph. I ended up taking the back roads to an AutoZone. Their diags reported miss fires and an error on the camshaft positioning sensor. However, I took it to my brother-in-law's dealership and they couldn't get the same error codes or get the Jeep to stall out. Then this morning it did the same thing, but my Jeep completely stopped. I was able to start it right back up 30 seconds after the stall. Not sure what is going on, it has been fine. It currently has 126k miles. **Note-I did run out of gas July 20th.

Please, any help/assistance is appreciated. Take care.
oki3jp is offline  
Sponsored Links
Advertisement
 
post #4 of 7 Old 01-20-2019, 10:58 PM
Junior Member
 
Join Date: Jan 2019
Posts: 3
 
having a simmilar issue witg my 2015 compass. Driving cinditions up hill down hill in turns ect. it will shut down all power is working , rpm drops to 0 engine shut off, no power steering but picks back up 1-4 seconds later and runs good till next time, its happening 3-4 times a day in a 30 mile commute . It gives no codes and its about to get me killed or at very least in a bad accident. I wish somebody with knowledge woukd respond
huntinthetrack1 is offline  
post #5 of 7 Old 01-22-2019, 09:34 PM
Senior Member
 
Join Date: Apr 2012
Posts: 370
 
Quote:
Originally Posted by huntinthetrack1 View Post
having a simmilar issue witg my 2015 compass. Driving cinditions up hill down hill in turns ect. it will shut down all power is working , rpm drops to 0 engine shut off, no power steering but picks back up 1-4 seconds later and runs good till next time, its happening 3-4 times a day in a 30 mile commute . It gives no codes and its about to get me killed or at very least in a bad accident. I wish somebody with knowledge woukd respond
Hi huntinthetrack1,
We're very sorry that you are experiencing this. Please send us a private message if you plan to have your dealer look into this. We are happy to look into this a bit further for you.
Lydia
Jeep Social Care Specialist
JeepCares is online now  
post #6 of 7 Old 01-23-2019, 02:12 AM
Senior Member
 
Join Date: Aug 2018
Location: Two locations in NH: One near Concord, the other at the 45th.
Posts: 580
 
As noted above, the 2nd gen Compass will shut down without warning if the oil level is low. IMO there should be some sort of warning before this happens since it could be anywhere -- left lane of the interstate, on a lonely road, or in a busy intersection. The lack of warning is a safety issue that FCA ought to correct or NHTSA will probably force them into a recall. Sadly there will have to be enough tragedies before they will act. Best temp solution is to check the oil often. Tigers and sharks are predators, and this new "Tigershark" engine is an oilavore (I made that word up, but its an apt description). These engines can really suck up the oil. I doubt mine could go 9,000 miles without running out, though its oil consumption seems to have dropped after the 20,000 mile mark. For comparison, my 10 year old Patriot with ten times those miles didn't use as much oil as my new Compass does. They don't make them like they used to, even 10 years ago.
Jasmine is offline  
post #7 of 7 Old 02-23-2019, 08:26 PM
Junior Member
 
Join Date: Jan 2019
Posts: 3
 
Well after several trips to the dealer and several thousand dollars later (thank goodness for warranty) turns out the throttle body was bad, they found another issue during that repair so being at the dealership i traded and bought a new 18 compass trailhawk and boy am I in love... Just hope this one is not a lemon...
huntinthetrack1 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome