2015 Compass 2.4L Battery Issue - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 1 Old 10-16-2018, 11:32 PM Thread Starter
Junior Member
 
Join Date: Oct 2018
Posts: 1
 
2015 Compass 2.4L Battery Issue

Hello,
I'm looking for some advice/help/a starting point for the following issue that I've been having. First off, back in late August, my girlfriend's Compass wouldn't start one morning. The lights would come on when the door opened, radio came on etc, but just wouldn't start. Jumped in with a jump box and took it to Advance to have battery tested. Their 1st test said that everything was fine, battery had a charge, alternator and starter were both good as well. Next morning, same issue, lights on, wouldn't turn over, jumped it again and took it back to advance. Their test the 2nd time indicated that it was a bad/old battery.

We replaced the battery and have had no problems until yesterday morning. She went to go to work and it wouldn't start, same thing as in August(lights on, radio on). When I checked it about 5 hours later, it was completely dead, no lights no radio. I tried to jump it with the jump box, wouldn't turn over, tried jumping it with my vehicle, nothing. So I pulled the battery and took it back to Advance where we bought it.

They put their tester on it again, the battery was so dead that their machine would test the battery, but wouldn't print out the results( they ended up having to attach it to another battery so that it would print.) They said they would need to charge it for 3-4 hours so that they could test it again to determine if it was a bad battery in order for them to be able to exchange it for a new one. I went to pick it up earlier this afternoon and they tested it when I got there. The battery tested fine, correct amount of volts, cca's etc. I took the battery home, reinstalled it in the jeep and it started immediately with no issue.

Any and all advice is appreciated, again I'm just looking for some help in maybe figuring out what's causing the battery to be drained(lights aren't being left on overnight or anything like that) when the alternator is supposedly fine. Thanks in advance!
Devils1819 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome