Compass wont start - Jeep Compass Forum
 1Likes
  • 1 Post By tripplec
 
LinkBack Thread Tools Search this Thread
post #1 of 19 Old 06-28-2011, 07:10 AM Thread Starter
Senior Member
 
Shecky's Avatar
 
Join Date: May 2010
Location: Spruce Grove, Alberta
Posts: 315
 
Garage
Compass wont start

My compass is sick, looks like ecu, or pcm as they call it now. replacement is $311 canadian which is better than i was expecting. probably gonna tow it into the dealership in the next few days.

Also it may be covered under the "gold plan" warranty i have till 100k. im not worried to bring it to the dealership as i know half the staff there including the service manager. its the sales staff at my dealership that are morons.

ill keep everyone posted.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Beep Beep I'm a JEEP!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
(O[][][][]O)
Shecky is offline  
Sponsored Links
Advertisement
 
post #2 of 19 Old 06-28-2011, 10:49 AM
Senior Member
 
i2canoe's Avatar
 
Join Date: Apr 2007
Location: Montreal, Canada
Posts: 656
 
Garage
Your Gold plan should work.
I had a NO-Start issue past winter.
The alarm module had failed and although the alarm worked, the car was not startable.
I was under 50k-km then but since, I had a sunroof drain blockage and the dealer had to pull the seats, consul, carpets and underpadding to dry out the car. I am over 50k-km and without me mentioning the warrantee (I forgot I had gold plan or what it covers) the work was done and covered.
Good luck.

Loved
my 2007 Compass 5-Speed, Limited!

{BUT NOW SOOO IN LOVE WITH MY NEW CRUSH WRANGLER!}
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

-[OIIIIIIO]-

"No man should go through life without once experiencing healthy, even bored solitude in the wilderness, finding himself depending solely on himself and thereby learning his true and hidden strength."
~Jack Kerouac


“Everybody must believe in something. I believe I'll go canoeing.”
-Henry David Thoreau

i2canoe is offline  
post #3 of 19 Old 06-28-2011, 04:54 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
Its rare for a PCM to fail. People have blown them sometimes with a reverse boost or other stupid actions. But they're normally quite robust. Just checked, no year posted on you Compass.

Hmmm
Jmarcb likes this.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
Sponsored Links
Advertisement
 
post #4 of 19 Old 06-29-2011, 01:34 PM Thread Starter
Senior Member
 
Shecky's Avatar
 
Join Date: May 2010
Location: Spruce Grove, Alberta
Posts: 315
 
Garage
i expect every part to fail eventually, i guess im a "glass half empty" kind of guy. mine is an 07 with 73,000km on it.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Beep Beep I'm a JEEP!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
(O[][][][]O)
Shecky is offline  
post #5 of 19 Old 06-30-2011, 06:46 AM
Administrator
 
Cherokee's Avatar
 
Join Date: Feb 2007
Location: USA
Posts: 1,362
 
That sucks! Sure hope it's covered and you don't have to shell that out of your pocket!

- Cherokee





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My 2007 Jeep Compass Sport, Bright Silver Metallic, 26E, CVT II, Driver Convenience Group, Sunroof, Trailer Tow Prep Group, 4x2

1991 XJ Cherokee Sport 4X4 4.0 H/O I6
2008 Dodge Ram 1500 ST, SWB Reg Cab, Bright Silver Metallic, Trailer Tow Package

JEEP - Just Enjoy Everything, Period.....
Cherokee is offline  
post #6 of 19 Old 07-01-2011, 08:03 PM Thread Starter
Senior Member
 
Shecky's Avatar
 
Join Date: May 2010
Location: Spruce Grove, Alberta
Posts: 315
 
Garage
Compass is Working now. turns out it was the PCM, but only a reset was needed. i put it all back together this morning, no start. pulled out the hail mary PCM reset before i called a tow truck and Vroom Vroom!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Beep Beep I'm a JEEP!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
(O[][][][]O)
Shecky is offline  
post #7 of 19 Old 07-02-2011, 01:11 AM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
Battery disconnect for 30 min would not reset it?

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
post #8 of 19 Old 07-02-2011, 01:01 PM Thread Starter
Senior Member
 
Shecky's Avatar
 
Join Date: May 2010
Location: Spruce Grove, Alberta
Posts: 315
 
Garage
when i did my trouble shooting i had it disconnected for about an hour and it didnt reset. so it takes somewhere between an hour and 2 days for it to reset lol


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Beep Beep I'm a JEEP!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
(O[][][][]O)
Shecky is offline  
post #9 of 19 Old 07-03-2011, 04:18 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
Quote:
Originally Posted by Shecky View Post
when i did my trouble shooting i had it disconnected for about an hour and it didnt reset. so it takes somewhere between an hour and 2 days for it to reset lol
Thats very interesting. It could be useful info down the road. I wonder if the pedal reset for relearning would have reset that for you as well.

It would have been a real bummer if the Steelership just reset it and gave it back with big bill!!! I wonder if there were any code as to what triggered it.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
post #10 of 19 Old 07-03-2011, 09:56 PM Thread Starter
Senior Member
 
Shecky's Avatar
 
Join Date: May 2010
Location: Spruce Grove, Alberta
Posts: 315
 
Garage
The pedal reset did not work, the dealership isn't a worry for
Me I'm friends with the service manager, so I wasn't worried about getting hustled.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Beep Beep I'm a JEEP!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
(O[][][][]O)
Shecky is offline  
post #11 of 19 Old 10-26-2011, 09:39 PM
Junior Member
 
Join Date: Oct 2011
Location: Bahrain
Posts: 4
 
Garage
Post Engine won't start

My Jeep Compass 2007 won't start.
Just now when I want start the engine, sound like battery problem. I open the boot, check the battery, the cable joint at the battery losses.
Then, I tighten the screw at battery connector.
When the key insert into the ignition, the display appear 'ScrewLosses', 'Turn Engine Off'.
Can anyone share your expertise regarding this problem.
Regards, Salleh
Salleh Jeep is offline  
post #12 of 19 Old 10-27-2011, 09:03 AM
Junior Member
 
Join Date: Oct 2011
Location: Bahrain
Posts: 4
 
Garage
Quote:
Originally Posted by Salleh Jeep View Post
My Jeep Compass 2007 won't start.
Just now when I want start the engine, sound like battery problem. I open the boot, check the battery, the cable joint at the battery losses.
Then, I tighten the screw at battery connector.
When the key insert into the ignition, the display appear 'ScrewLosses', 'Turn Engine Off'.
Can anyone share your expertise regarding this problem.
Regards, Salleh
Updated regarding the above matter (Jeep Compass wont start).
Just replace a new battery, the engine can be start and can be drive.
Now the only problem is on the EVIC information. Still appear 'TurEnOff' then, 'SchLosses'.
Maybe I play around with EVIC button & settings.
Salleh Jeep is offline  
post #13 of 19 Old 01-30-2013, 07:50 PM
Junior Member
 
Join Date: Aug 2011
Posts: 7
 
PCM fail

Quote:
Originally Posted by tripplec View Post
Its rare for a PCM to fail. People have blown them sometimes with a reverse boost or other stupid actions. But they're normally quite robust. Just checked, no year posted on you Compass.

Hmmm
our PCM failed last night for no apparent reasons. we drove it to a store, then it wouldn't start, got it towed to dealer and this morning they called me to say PCM is dead.

will get new one tomorrow morning.

so glad we bought the extended platinum warranty 160k 6 years.

so far, we are currently at approximately 4000$ of repair on this jeep.

2009 North 4X4 loaded with tow package.

fixed so far:
both front bearing (under 60k)
both front struts (which screwed up my brand new tires)
one ball joint front
both strut mounts on the back
main window control unit.
some emission valve.
rear ball joint (or whatever it's called)
tranny fluid somehow went low on us under 100k, had to tow and was not covered cost 500$ to fix.
Engine light always on since 60k approx, they can't seem to fix, gas cap message comes on and they can't seem to fix.

car now have 150K on it.

my recommendation, DO NOT BUY A COMPASS
Jmarcb is offline  
post #14 of 19 Old 04-14-2013, 04:25 PM
Junior Member
 
Join Date: Apr 2013
Posts: 3
 
Garage
2006 Jeep Compass Won't Start

Hello, just received a call from my daughter who is 2 states away at college. Her Jeep Compass wouldn't start. Lights worked, clutch was in all the way, foot on the brake. Then when she tried again while on the phone with me it started. The lights didn't dim when she attempted to start the engine. Looking for troubleshooting path I can pass along to her.

Many thanks
College Dad is offline  
post #15 of 19 Old 04-14-2013, 04:49 PM
Junior Member
 
Join Date: Apr 2013
Posts: 3
 
Garage
Update on 2006 Jeep Compass Starting Problem

Just received another message from my daughter. The problem continues to be intermittent - 5-6 attempts to get the vehicle to start. When it finally starts several warning lights are on -- ignition module, oil pressure and a couple others she couldn't remember. but the car ran fine once started, lights worked no problem.

Thoughts?
College Dad is offline  
post #16 of 19 Old 04-14-2013, 07:23 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
Insufficienct info.
Can't start means what.

Does it always turn over for example and is it normal cranking or not. The battery needs to be verified as good and holding a good charge. Saying its a Jeep compass is not entirely helpful either. It could be brand new or one driven to its death bed or somewhere inbetween. I doubt she can verify and battery connections are solid but again no info to work with.

Just guessing at this point.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
post #17 of 19 Old 04-14-2013, 08:06 PM
Junior Member
 
Join Date: Apr 2013
Posts: 3
 
Garage
Thank you for the reply -- it is a 2006 Jeep Compass. The engine won't turn over. Supposedly the lights don't dim when attempting to crank the engine. It is a manual transmission. Is there an interlock switch on manuals? She claims that she had her foot on the brake and the clutch all the way to the floor.
College Dad is offline  
post #18 of 19 Old 04-14-2013, 09:39 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
Wow, not many of them sold I don't think very early ones. Must have been better than the 2007 which had so much trouble.

If the battery is good and as you say looking at the interior lights that don't dim. Its most likely a bad starter/solenoid given the year and all it could be heavy corrosion on key cable connections as well. Only a good electrical mechanic will know to check it out properly. A lot of garages will want to just change the starter and then if it don't work (you've spent all that money) check other stuff. The cable connections on the started could be corroded which they would clean and or self correct when the new starter is installed needlessly.

There is nothing you can do you her given the distance apart.

All manual transmission have had Neutral switchs. She can wriggle the gear shift around in neutral and see if it will crank. Its possible the switch is bad but not as likely as the starter.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by tripplec; 04-14-2013 at 09:41 PM.
tripplec is offline  
post #19 of 19 Old 10-18-2013, 02:32 PM
Junior Member
 
Join Date: Oct 2013
Posts: 1
 
Hi

Hi guys, i´m fron Chile and i´m new at this forum. i´ve been reading some of your posts and this is the most similar i´ve found about my problem.
i have 2 Jeep Compass, one of them is having electrical problems at the start...well it doesn´t, unless i discconect the negative wire from the battery for a few seconds. the car is under 30 k km, and i´m having this problem very often. no one knows what the problem could be, abd i thought that maybe you´ve listened to something similar.

thank for any recomendation you could give

greetings
MAJC is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome