Turn signal activated interior light or wiper. Now my jeep doesn’t start. - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 1 Old 10-07-2019, 06:04 PM Thread Starter
Junior Member
 
jmaynez's Avatar
 
Join Date: Oct 2019
Posts: 2
 
Turn signal activated interior light or wiper. Now my jeep doesn’t start.

A few months ago, my Jeep Compass 2008 started flashing the interior light when I used the turn signal. It wasn’t all the time, but it occurred on daily basis. I replaced the turn signal switch, but the issue was still there. In the last couple of weeks, the turn signal started activating the wipers as well. Then I started having issues starting the car, but I tried a few minutes later and I was able to start it. The dashboard started blinking once while driving. I think it has some kind of short circuit, because now the battery is going dead when I don’t use the jeep for a day, I test the battery and the alternator and they are fine. I started checking the wires where the turn signal switch is including the wiper switch and everything looks ok. I am wondering if I need to replace the SCCM (Steering Column Control Module) or the WCM (Wireless control Module) or both. I have the idea that WCM can only be replaced at the dealership since it needs to be programmed. I’m trying to avoid this since it will cost me a small fortune.

Last night, I unplugged the battery, hoping some electronic components will reset and perhaps the issue to be resolved. However, this morning I connected the battery again and I wasn’t able to start my jeep. Do you have any ideas on what should I check? Any suggestion will be highly appreciated.

UPDATE:
I found the issue with my jeep not starting. It was a battery cable that for some reason it has an additional connector that it was loose. The jeep is running again. I think this also explains the blinking of the dashboard since it was loosing connectivity while the car was moving. The issue with the turn signal activating the wiper and interior light is still there.

Last edited by jmaynez; 10-08-2019 at 04:07 PM. Reason: I resolved part one of the problems posted
jmaynez is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome