2007 Compass turns over but won't start. Fuel pump or? - Jeep Compass Forum
 1Likes
  • 1 Post By RuffRhyno
 
LinkBack Thread Tools Search this Thread
post #1 of 4 Old 03-31-2013, 04:15 PM Thread Starter
Junior Member
 
Join Date: Mar 2013
Posts: 2
 
2007 Compass turns over but won't start. Fuel pump or?

My girl has a 2007 Jeep Compass. The other morning we tried starting it and it would only crank, it wouldn't fire up. So I spent all day trying to figure out the problem. Checked the plugs, air filter, fuses, no issues. I disconnected the fuel line and cranked the engine, interestingly there was no fuel being delivered through the line. I checked for any codes, nothing showed up on my scanner.

I found previous threads of people reporting the PCM goes bad. Or the crank sensor. This is where it gets weird. I tried one last time to give the fuel tank a couple decent kicks underneath, than I sprayed starter fluid into the intake tubing while someone tried the ignition again. This time it started up and ran fine. For a few days.

Fast forward a week and the same issue this morning. Car would crank but not fire. This time, starter fluid was able to start the motor but not keep it running. I just ordered a fuel pump, but I would hate to waste $$ on a part that won't solve the issue. Anyone have suggestions?
RuffRhyno is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 04-01-2013, 07:17 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
I don't have a wiring schematic but typically when the key is turned the fuel pump fires up and pumps for a few seconds building fuel pressure. If its working check and see if it does turn on such that you hear it. then when its not responding you'll know. I would look for the pump relay which may be intermittent or faulty contacts.

A lot of primary circuits are in the TIPM (unit with fuses above the battery) and have solid state programmable circuits within.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
post #3 of 4 Old 04-04-2013, 11:28 AM Thread Starter
Junior Member
 
Join Date: Mar 2013
Posts: 2
 
I changed the pump yesterday. All seems well. Hopefully that lasts.
wojeda likes this.
RuffRhyno is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 04-04-2013, 11:25 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
Well done if it was in the gas tank that a job and a half getting it out I've heard.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome