problems with my '08 compass - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 12 Old 10-27-2009, 01:45 PM Thread Starter
Junior Member
 
Join Date: Oct 2009
Posts: 5
 
problems with my '08 compass

I just bought my 08 compass NEW from a dealer back in July. Things were ok until a few weeks ago, when the engine light started coming on. At first, the light would come on for a few engine cycles & then would go off. Then it started staying on steadily. Eventually, it got to the point where the engine wouldn't turn off when I turned it off & removed the key. The engine would run for aproximately 30 to 45 seconds & then shut itself down, but a clicking sound would continue, even to the point of going on overnight. I've taken it to the dealer twice & although it will be ok for a few days, it will start doing it again. Yesterday, it started again & my son had to pull the battery cable loose in order to get the compass to quit clicking, lest it run the battery down. Has anyone ever experienced this problem & if so, what fixed it? Sadly, it's not just me having this problem, but a lady with an '08 patriot is also having the same problem, but her vehicle is out of warranty, whereas mine is not. I feel like the dealer really wants to fix this problem, as their service department manager seems very sincere & has gone out of his way to take care of me (he got me a rent car & the dealership took care of the bill). But, the service dept. is stumped. They've called Chrysler about it & they haven't come up with a solution either. Any ideas would be appreciated. Thanks.
Xtina is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 10-27-2009, 02:20 PM
Senior Member
 
CompassLimited's Avatar
 
Join Date: Jul 2009
Location: Brentwood, TN
Posts: 348
 
Faulty fuel pump or a short going to it.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Jeep is a way of life, not just transportation.
CompassLimited is offline  
post #3 of 12 Old 10-27-2009, 02:26 PM
Super Moderator
 
Feel for life's Avatar
 
Join Date: Feb 2009
Location: Montreal area.....
Posts: 849
 
X first welcome to the forum..........
I'm surprise for that lady she has a '08 and no warranty.........I doubt It !!!!!

I have no idea about your issue............and thank god thaey will pick up the tab........let us know about the conclusion and good luck!

Life is short, Break the rules,
Forgive quickly, Love truly,
Laugh uncontrollably...
Never regret anything that made you smile!
Have a wonderful day!

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Feel for life is offline  
Sponsored Links
Advertisement
 
post #4 of 12 Old 10-28-2009, 03:36 AM Thread Starter
Junior Member
 
Join Date: Oct 2009
Posts: 5
 
Compass Limited: thank you for the input. I will tell the service dept. when I take it in & maybe they can do something with that information.

Feel for life: Thanks for the welcome. I was perplexed by the lady with the Patriot being out of warranty too. But then I considered that we both live in a rural area & that it's pretty common for some of us to rack up the miles pretty quick on our vehicles, then it seemed possible. She still has the extended warranty, but after hauling her Patriot to the dealer 4 times so far, she's getting pretty frustrated. I just know that if I can get my car fixed, then I can help her get her car fixed. She's real close to throwing in the towel & going Lemon law.

As for me, I will keep y'all posted on what happens. I really REALLY like my little Compass. I previously had an Explorer & while I liked it, I had issues with the gas mileage & it was getting pretty old. So I bought this little Compass & it so suits my needs. I live in what was formerly a cow pasture & this Compass gets through my rutted drive way very well - even better than the Explorer. The smaller size does well in town & is easy to park. I really just want to fix this problem so I can enjoy this little Jeep to it's fullest.
Xtina is offline  
post #5 of 12 Old 10-28-2009, 08:48 AM
 
Join Date: Sep 2009
Posts: 39
 
this used to happen with my holden calais, the problem was a busted radiator
Compassed is offline  
post #6 of 12 Old 10-31-2009, 02:20 AM
Senior Member
 
Jeepster2's Avatar
 
Join Date: May 2009
Posts: 250
 
I hope that you get the problem fixed Xtina, and let us know when you find out what it is. Welcome to the forum!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Jeepster2 is offline  
post #7 of 12 Old 01-17-2010, 05:23 PM Thread Starter
Junior Member
 
Join Date: Oct 2009
Posts: 5
 
Update on Compass electrical problem

I thought I'd post here again & give y'all an update on my Compass.

After going to the shop for the 6th time, the manager at the service dept. called the hotshot Chrysler mechanic & the district manager & they came to the conclusion that my Compass had a leak somewhere. The service techs then started going through the wiring in the engine compartment to examine it & sure enough, they found some connectors that were rusted & appeared to have gotten wet. So, they removed the interior covers on the front roof supports & sprayed the outside with a water hose & sure enough, a stream of water was running down from a leak located on the driver's side of the windshield, down the roof support & right onto the connectors in the engine compartment. They then sent the Compass to the body shop & had the windshield re-sealed & the Compass has been running like a top now for longer than a month (previously, it couldn't seem to make it any longer than about 10-12 days). However, when a storm blew through here a couple of weeks ago, I got into the Compass & found water dripping from the map lights onto the shifter. So, it seems that my leak problems haven't gone away entirely. At any rate, I suspect this new leak is associated with the sunroof, because I've run across several postings on the internet where Compass & Patriot owners have had problems with the sunroof leaking & have been unable to get the leaks to stop, despite repeated visits to the service dept.

So...time will tell.

I'm due to take the Compass back to the service dept. whenever they can get me a rental car. Under normal conditions, I probably wouldn't have bought a vehicle with a sunroof, because my father would have reminded me that they have a habit of leaking in general. But, my father passed away in February & wasn't around to remind me of that fact, so I screwed up & forgot his counsel on these sorts of things. I'm hopeful though that the dealer can fix this leak & if not, at least it won't be so bad that it leaks onto the electronics & causes the Compass to mess up on me
Xtina is offline  
post #8 of 12 Old 01-17-2010, 07:31 PM
Super Moderator
 
Feel for life's Avatar
 
Join Date: Feb 2009
Location: Montreal area.....
Posts: 849
 
good luck and again keep us posted..........

Life is short, Break the rules,
Forgive quickly, Love truly,
Laugh uncontrollably...
Never regret anything that made you smile!
Have a wonderful day!

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Feel for life is offline  
post #9 of 12 Old 01-18-2010, 02:32 AM
Senior Member
 
Lunch Box's Avatar
 
Join Date: Sep 2009
Location: Maryland
Posts: 169
 
Wow, sorry to hear you've been having this streak of problems with your jeep. Did you get it new or used?

Run from me if you want to live.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2008 Jeep Compass Limited 4x4 (4x4 all the way baby!)
Lunch Box is offline  
post #10 of 12 Old 01-18-2010, 01:22 PM
Senior Member
 
i2canoe's Avatar
 
Join Date: Apr 2007
Location: Montreal, Canada
Posts: 656
 
Garage
Manufacturer installed sunroofs should not leak!
Aftermarket installations are sure to leak, but not when they come from the factory.
Sometimes a drain hose maybe pinched during assembly process causing a backup to leak into the cab, go back to the dealer again and again until they get it right.
i2canoe is offline  
post #11 of 12 Old 01-18-2010, 02:35 PM
Super Moderator
 
Feel for life's Avatar
 
Join Date: Feb 2009
Location: Montreal area.....
Posts: 849
 
I agree with I2...............bring it back until they find the source...............

Life is short, Break the rules,
Forgive quickly, Love truly,
Laugh uncontrollably...
Never regret anything that made you smile!
Have a wonderful day!

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Feel for life is offline  
post #12 of 12 Old 12-15-2014, 11:22 PM
Junior Member
 
Join Date: Dec 2014
Posts: 5
 
Quote:
Originally Posted by Xtina View Post
I just bought my 08 compass NEW from a dealer back in July. Things were ok until a few weeks ago, when the engine light started coming on. At first, the light would come on for a few engine cycles & then would go off. Then it started staying on steadily. Eventually, it got to the point where the engine wouldn't turn off when I turned it off & removed the key. The engine would run for aproximately 30 to 45 seconds & then shut itself down, but a clicking sound would continue, even to the point of going on overnight. I've taken it to the dealer twice & although it will be ok for a few days, it will start doing it again. Yesterday, it started again & my son had to pull the battery cable loose in order to get the compass to quit clicking, lest it run the battery down. Has anyone ever experienced this problem & if so, what fixed it? Sadly, it's not just me having this problem, but a lady with an '08 patriot is also having the same problem, but her vehicle is out of warranty, whereas mine is not. I feel like the dealer really wants to fix this problem, as their service department manager seems very sincere & has gone out of his way to take care of me (he got me a rent car & the dealership took care of the bill). But, the service dept. is stumped. They've called Chrysler about it & they haven't come up with a solution either. Any ideas would be appreciated. Thanks.
The problem is with the wiring located just inside the driver door close to the floor. Remove the triangle panel where you hood release is and pull back the panel running along the drivers seat. Under this is a bunch of wires about 1 inch diameter. Look for a rusty spot, it should be wrapped in black fibre tape not electrical tape. There are 5 red wires that join there and they are corroded at this point and probably broken. With the dampest in the area they were grounding out.
Hogan73 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome