Weird sound when turning left - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 5 Old 09-16-2013, 04:10 AM Thread Starter
Junior Member
 
Join Date: Sep 2013
Posts: 3
 
Weird sound when turning left

Hi,

I am glad to find out this forum, guys I am having the following issue, maybe some of you have had similar situations.

When I turn to the left (no a close left, just a left like in an intersection), I hear a sound coming from the front front-left part of the car, like a "compression" sound, not a metal, or hit sound, it sounds like ... compression.

It only happens when turning left, right doesn't have any issue.
Mine is a compass 2012.

Any idea of what it could be the reason, I haven't taken the car to the dealership yet, but I would like to have an idea of what it could be the reason, or what to check to make sure.

Thanks,


Marco
ocramas is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 09-16-2013, 05:51 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
A strut possible. Get someone to listen and try rocking it when parked on each side and see if the sound can be generated. If the Strut cylinder is wet for oil then its shot anyway.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
post #3 of 5 Old 09-17-2013, 02:39 PM Thread Starter
Junior Member
 
Join Date: Sep 2013
Posts: 3
 
Hi tripplec,

Thanks for the replay.

Look, not that kind of sound.

Let's say that.... when you turn left completely (there is a little sound sometimes, like.. a transmission sound) , that is the sound that I hear when I turn ...45 degrees or so. (only to the left)
ocramas is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 09-17-2013, 07:08 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
Just take it to the dealer, any dealer and let them find the problem. Its their job no yours to issolate it. As long as you can demonstrate the issue then its on their plate to figure it out. Whatever, struts, CV joint etc is causing it.

If it does not do it when you go in then typically they won't ever look which ticks me off and not check for something likely that might be wrong.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by tripplec; 09-23-2013 at 07:07 PM.
tripplec is offline  
post #5 of 5 Old 09-17-2013, 09:17 PM Thread Starter
Junior Member
 
Join Date: Sep 2013
Posts: 3
 
I will take it on weekend! will update then!

Thanks,
ocramas is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome