Nothing but problems - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 2 Old 12-07-2013, 09:12 PM Thread Starter
Junior Member
 
Join Date: Dec 2013
Posts: 1
 
Thumbs down Nothing but problems

I have had my 2013 Jeep Compass for almost 6 months but have had nothing but problems.

The first problem (high pitched whistling noise coming from engine department) occurred on only the second day I had the car. Dealership tried to fix it twice then on the the third try they ended up calling in a special mechanic from the dealership; they had my car for 3 weeks. Mind you, they fixed/replaced several things, all of which I can't remember off the top of my head but I'm sure my mechanic husband could.

The second problem started last week, whenever I'd turn the steering wheel left I'd hear a noise coming from the engine area. Took the car in and they said it was because my power steering fluid was low.

The third problem occurred the other day as well but it went away so I didn't think anything of it, however, upon starting the car today at the dealership I heard a loud noise coming from the engine area. I called the service writer out and had him check it out. Needless to say, I left the car there for repair and drove home in the loaner which is an avenger and I actually like driving that car!

I'm so frustrated! I called the Chrysler Group LLC Customer care line to see what my options are. The lady was very nice and called the dealership to ensure my vehicle was properly repaired. Their # 877-426-5337. I sincerely hope I do not have more problems but based on the vehicle's history it's not looking promising.
lbd317537 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 12-07-2013, 10:04 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
Calling customer care at this stage was the right move. If not earlier. Said to say you could be into a number of gremlins popping up as I had. Many took 3-7 visits or attempts to fix. Some they would not fix saying it was normal. LOL

Further if the fluid was low. Why, must be a leak in the rack and pinion and that's a costly part.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome