Bad wear on rear tires - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 2 Old 03-08-2014, 02:33 PM Thread Starter
Junior Member
 
Join Date: Dec 2013
Posts: 26
 
Bad wear on rear tires

I replaced both upper control arms in the back, they started vibrating and had play in them when I jacked the car up, Now my tires are wearing out really bad in the back and u can even tell by looking at the car that the rear tires lean inword , Any way to adjust that? I'm confused what I did wrong, all I did was replaced a oem part with a oem part , shouldn't have this issue


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Jhoppy16 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 03-12-2014, 03:04 AM
Member
 
CarlosHRNYC's Avatar
 
Join Date: Dec 2010
Location: New York, NY
Posts: 30
 
Here's a silly question... Did you get an alignment after all that?

2007 Jeep Compass Sport 4WD - Black
4 Cyl, 2.4L CVT
195,000/mi -
215/65R17 - Continental ProContact ECOPlus

Replaced entire front end suspension at 190,000mi (control arms, inner/outer tie rods, bushings, etc.) (did it myself)

new Monroe struts at 160,000/mi (did it myself)
Ball Joints 2x-both sides - various mileage (did it myself)
CarlosHRNYC is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome