Advice anyone? - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 9 Old 04-25-2014, 02:54 PM Thread Starter
Junior Member
 
Join Date: Apr 2014
Posts: 2
 
Advice anyone?

I have a 2008 Jeep Compass. This past week it has not started on it's own. I got it boosted twice now, and once started it runs fine. Although it goes dead again the next morning.
The engine malfunction light as well as the ETC warning light now stay on once I try to start the vehicle and it won't start.
Is this an easy fix such as replacing the battery, or does it sound more complicated?
Joe99 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 04-25-2014, 11:05 PM
Super Moderator
 
Tyler-98-W68's Avatar
 
Join Date: Feb 2012
Posts: 530
 
Garage
I would try swapping in a battery, as that sounds like what the issue could be, do you have access to a battery you could try before buying one?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2012 Red FDII Jeep Compass Limited
235/75/15 Wranger Territory AT
WK2 Headlight Swap
Magnaflow Muffler

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Full Interior LED's + Front/Rear Signal & Backup LEDS

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Tyler-98-W68 is offline  
post #3 of 9 Old 04-26-2014, 11:25 AM
Member
 
Join Date: May 2013
Location: Oregon, USA
Posts: 52
 
Garage
Yep, it might be a bad battery or alternator.

To test, check the voltage on the battery with a multimeter while the engine is on. It should read around 14.7 volts, which would mean good alternator but bad battery in your case. If it's around 11 or 12 volts, then the alternator is bad.

2014 Jeep Compass Limited 4x4
DEF1ANT is offline  
Sponsored Links
Advertisement
 
post #4 of 9 Old 04-26-2014, 05:01 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
Quote:
Originally Posted by DEF1ANT View Post
Yep, it might be a bad battery or alternator.

To test, check the voltage on the battery with a multimeter while the engine is on. It should read around 14.7 volts, which would mean good alternator but bad battery in your case. If it's around 11 or 12 volts, then the alternator is bad.
Do this first as you're throwing parts at it although at the 4th year and more your battery is on borrowed time. Meter it as indicated. When off it should be around 13VDC running depending on the charge level 14V or higher but at 14.7VDC it could start over charging and gassing. Usually 14.5V is optimal especially when cold weather hits you need almost a .5VDC more and why some vehicles charge higher in the cold than summer.

You could have something draining the battery. If you do replace the battery you still should check the voltage you get when its running to verify your alternator is working as it should. Note: New batteries are not fully charged and it takes hours of driving to top them off.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
post #5 of 9 Old 11-06-2014, 08:13 AM Thread Starter
Junior Member
 
Join Date: Apr 2014
Posts: 2
 
Unhappy still having problems

Battery was replaced to a brand spanking new one..something is still draining it. The engine light comes on as well. How would I know if this is an electrical problem or the alternator? I'm not in the best know how for cars.
Also, if car is started, is there any possibility of it slowing down and stopping while I am driving from point A to point B? Sorry for asking so many questions, but the garages are very busy right now and it might be a bit before I can get it in.
Joe99 is offline  
post #6 of 9 Old 11-06-2014, 11:14 AM
Member
 
BusterOz's Avatar
 
Join Date: Jun 2014
Location: SYDNEY AUSTRALIA
Posts: 80
 
Garage
You could try pulling some fuses to identify source of drain - try radio as amp may be stuck on?
BusterOz is offline  
post #7 of 9 Old 11-06-2014, 11:48 AM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
See my post #4, have you checked it with it running. If the voltage is not around 14vdc running and below 13.5vdc then the vehicle will stop when its below 11vdc due to lack of power in the battery (dead). Normally an idiot light would be on for an alternator problem but again its an idiot light not a voltmeter.

Something is on accidentally or faulty draining it when sitting. Only you or a mechanic can look over the vehicle for that problem.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
post #8 of 9 Old 11-07-2014, 09:09 AM
Member
 
BusterOz's Avatar
 
Join Date: Jun 2014
Location: SYDNEY AUSTRALIA
Posts: 80
 
Garage
There will always be some battery drain when stopped and locked up as electronics is always on - alarm, remote door controller etc.

Too much drain will flatten the battery, but it would have to be a significant current draw.

Isolation(pull fuses) is a quick way to track down the source of drain.

Take her to an Auto Eclectrican
BusterOz is offline  
post #9 of 9 Old 04-13-2015, 01:33 AM
Senior Member
 
Join Date: Jan 2011
Location: california
Posts: 150
 
Garage
Did you install any after market electrical or electronic stuff? Just asking,
jeepney_driver is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome