Keyless entry problem - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 9 Old 05-19-2010, 12:13 AM Thread Starter
Junior Member
 
Join Date: Feb 2010
Posts: 3
 
Keyless entry problem

When I shut the engine down and open the door, the chime starts and stops only when I close the door. The remote does not work at all. It is similar to what happens when the key is left in ignition.
I took it to Jeep service, and they could not find what was wrong though they were willing to keep it for a day, check it manually and charge me $1000 for it.
I took it to another shop that had a computer to get a second opinion, but they could not find what was wrong either.
Any advice?
Dragon23 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 05-19-2010, 06:16 PM
Super Moderator
 
Feel for life's Avatar
 
Join Date: Feb 2009
Location: Montreal area.....
Posts: 849
 
First welcome to the forum, glad you found us........and as for your question :

Tell the first dealer to go take a hike........to charge $1000 for what ??? this one should br classified as a Stealership..............tell us more about the year, model...etc

Life is short, Break the rules,
Forgive quickly, Love truly,
Laugh uncontrollably...
Never regret anything that made you smile!
Have a wonderful day!

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Feel for life is offline  
post #3 of 9 Old 05-26-2010, 08:31 AM
Administrator
 
Cherokee's Avatar
 
Join Date: Feb 2007
Location: USA
Posts: 1,362
 
Welcome to the forum! Honestly, that has me puzzled.....so, engine off, key out of the ignition you open the door, step out, close the door and then the chime? I read your post a couple times, but seems something is crossed somewhere, as it works, only opposite from what it is supposed to.....and your key fob doesn't work, either?

- Cherokee





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My 2007 Jeep Compass Sport, Bright Silver Metallic, 26E, CVT II, Driver Convenience Group, Sunroof, Trailer Tow Prep Group, 4x2

1991 XJ Cherokee Sport 4X4 4.0 H/O I6
2008 Dodge Ram 1500 ST, SWB Reg Cab, Bright Silver Metallic, Trailer Tow Package

JEEP - Just Enjoy Everything, Period.....
Cherokee is offline  
Sponsored Links
Advertisement
 
post #4 of 9 Old 05-27-2010, 08:41 PM Thread Starter
Junior Member
 
Join Date: Feb 2010
Posts: 3
 
Thank you guys!
My Jeep Compass is 2007 year (January 2007), Sport model. I have 93000 km on it (58000 miles). Except for regular maintenance never had any problems with it. Tires started making some noise after 50000 km (31000 miles), but since they are great for Canadian winter drive I do not mind it.
The first and only real issue I had was this computer /sensor problem. To clarify: I shut the engine, take the key out of ignition, and open driver's door and the chiming starts. I can use power locks, but not remote. The alarm works fine.
Conclusion: everything works fine except for the remote!
Dragon23 is offline  
post #5 of 9 Old 03-01-2011, 06:32 PM
Junior Member
 
Join Date: Mar 2011
Posts: 2
 
Hi there Dragon,

I am having the same problems with my keyless entry.
I have a 2009 Jeep Compass Sport (also bought in Canada - Quebec)

Mine is still under warranty, and I have moved to the US. I just picked my car up from the dealership here, and they had it for a week - and could NOT figure out what was wrong with it. They told me to take it back up to Canada, and see if the dealership that I bought it from could figure out what was wrong. I am still under warranty (luckily) but even if you paid to fix it, it looks like even the manufacturing engineers are stumped.

Did you get to resolve this issue yet? If you did would you mind telling me in details what they had to fix??

Thanks
mm44 is offline  
post #6 of 9 Old 03-01-2011, 06:34 PM
Junior Member
 
Join Date: Mar 2011
Posts: 2
 
Also Dragon - did you have any leaking problems??

My car was leaking water and then the computer shot the bed.

yay Jeep.
mm44 is offline  
post #7 of 9 Old 03-02-2011, 01:11 AM Thread Starter
Junior Member
 
Join Date: Feb 2010
Posts: 3
 
No luck yet!

Hello MM44,
I did not resolve my key-less entry problem yet and chiming is driving me nuts. I did try two more services, but they could not do anything about it.
On the other hand, I really like my Compass and everything except afore mentioned works fine. It is great in winter and mileage is good, too.
My opinion is that you should push Jeep service to manually take out and replace all of the relevant modules until they find the faulty one. That is what they started doing for me, but since my warranty expired I did not feel like paying $$$ just so they can tell me what is wrong. I read somewhere that it might be necessary to replace complete alarm and key-less entry unit
I had no leaks on my Compass.
Good luck and do not let Jeep off the hook - they have to fix it for you while you are under warranty.
Dragon23 is offline  
post #8 of 9 Old 03-02-2011, 09:43 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
My guess its the TPIM. Everything seams to got through it or is controlled by it via info from the PCM. They're not cheap from what I hear. I've had two new ones installed so far and that make it the 3rd the car has seen. They're troublesome.

If its under warranty then why haven't they replaced what controls it. EG TPIM and/or what ever and see if it goes away. Warranty is North American. Next thing they'll tell you its normal and not do anything either. That the line I get half the time.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
post #9 of 9 Old 09-05-2011, 02:13 AM
Junior Member
 
Join Date: Sep 2011
Posts: 1
 
I have the same problem with my 2008 Compass. When I shut the engine off, remove the key and open the door, the chime starts and stops only when I close the door. The remote does not work at all nor does the lock console switch (as is it still thinks the key is in) until something 'times out' about 60 seconds. Then the lock switch on the console works. Key fob does not work. This is intermittent problem. Although lately it doesn't work most of the time.

Last edited by CJJ612; 11-14-2011 at 12:53 AM. Reason: Update
CJJ612 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome