Esp bas / 4wd! / esp - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 8 Old 01-03-2011, 02:06 AM Thread Starter
Junior Member
 
Join Date: Jan 2011
Posts: 4
 
Esp bas / 4wd! / esp

Hello ,

My 08 jeep compass started showing those 3 lights
ESP BAS , 4WD! ESP (car slipping sign)

I drive it up north canada , very cold & lots of snow .
sometimes when I drive , I feel like the the driver front tire isn't spinning.

any suggestions ? or could be ice stuck somewhere or malfunction system.
ibeta is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 01-03-2011, 04:53 AM
Senior Member
 
jeepguy2010's Avatar
 
Join Date: Oct 2010
Location: PA
Posts: 193
 
ESP is your Electronic Stability Program, BAS is Brake Asist, and when the "4WD!" comes on it means there is a malfuntion in your 4wd system.

2010 Jeep Compass Latitude 4x4, Natural Green Pearl
Winner of COTM November 2011
Winner of COTM March 2012
jeepguy2010 is offline  
post #3 of 8 Old 01-03-2011, 01:08 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
4WD = failure? I know it comes when I manually turn it on with the lever. I believe if flickers when it kicks in automatically on demand (when a slip is detected and indicating on the dash).

What surface you driving on and how to get them all lighted up. Do the go on then off when you start the car (this is normal cycle of the lights and circuits by the way).

If you're cruising on snow and not doing something like tromping the gas there should not be any on.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
Sponsored Links
Advertisement
 
post #4 of 8 Old 01-04-2011, 12:51 PM Thread Starter
Junior Member
 
Join Date: Jan 2011
Posts: 4
 
Quote:
Originally Posted by jeepguy2010 View Post
ESP is your Electronic Stability Program, BAS is Brake Asist, and when the "4WD!" comes on it means there is a malfuntion in your 4wd system.
So when the three signs come out on same time it means malfunction in AWD! or just the word itself AWD! meant for malfunction.


because those 3 sign come out on same time as soon as I turn the vehicle on.
ibeta is offline  
post #5 of 8 Old 01-04-2011, 12:54 PM Thread Starter
Junior Member
 
Join Date: Jan 2011
Posts: 4
 
Quote:
Originally Posted by tripplec View Post
4WD = failure? I know it comes when I manually turn it on with the lever. I believe if flickers when it kicks in automatically on demand (when a slip is detected and indicating on the dash).

What surface you driving on and how to get them all lighted up. Do the go on then off when you start the car (this is normal cycle of the lights and circuits by the way).

If you're cruising on snow and not doing something like tromping the gas there should not be any on.

I drive on snow surface , they are always ON (3 of them) either on parking or driving , sometimes one of them turns off and on for a second.


and no im not tromping on snow , just driving on snowy road within the city limit (traffic light)


P.S i did turn off and on and still no luck (it has been a week and I turned off on the vehicle few times )
ibeta is offline  
post #6 of 8 Old 01-04-2011, 01:13 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
ok, I only notice the "!" in the iBeta reply. Must have been tired, my mistake on that. There must be another indicator for 4WD on as well. Seems you'll have to get it looked at. If you're not hearing any unusual noise or drivability issues. You may be only getting 2WD traction. There is likely no damage being done since it has to be an electrically engages system with the level of sensitivity it has to slippage to engaged time. I hope its not a TIPM issue they tend to cost a few bucks. If so run to Chrysler why such an early failure on a part time 4WD vehicle.

Good luck

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
post #7 of 8 Old 01-04-2011, 01:22 PM Thread Starter
Junior Member
 
Join Date: Jan 2011
Posts: 4
 
Yeah big time issue with those electronic AWD , I would rather to get the old school 4x4 manual stick. I think there must be a solid snow stuck somewhere in the engage system , because i remember parking on a thick pile of snow where the tires were spinning without reaching the ground. I will possibly wash the car and remove any snow before I take it to Jeep dealer.



Thanks for your time Tripplec and you too jeenpguy2010

Last edited by ibeta; 01-04-2011 at 01:28 PM.
ibeta is offline  
post #8 of 8 Old 01-04-2011, 01:32 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
Quote:
Originally Posted by ibeta View Post
Yeah big time issue with those electronic AWD , I would rather to get the old school 4x4 manual stick. I think there must be a solid snow stuck somewhere in the engage system , because i remember parking on a thick pile of snow where the tires were spinning without reaching the ground. I will possibly wash the car and remove any snow before I take it to Jeep dealer.



Thanks for your time Tripplec and you too jeenpguy2010
Well, yeah the circumstances leading to the problem are a great insight into the problem. Look for one of the car washes that do the under body wash with rust inhibitors (I think Shell does) that way you're getting a good spray underneath. Parking in an indoor garage might help thaw it out depending on the temperature.

Those washes are 3-4$ more but coffee money if you take it to the dealer.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome