Camshaft Position Sensor - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 15 Old 01-24-2011, 10:09 PM Thread Starter
Junior Member
 
Join Date: Jan 2011
Posts: 6
 
Camshaft Position Sensor

Hello,

Was wondering if anyone had replaced the camshaft position sensor on a 2007 Compass 2.0L??? I am getting code P000A bank 1 camshaft slow response on the OBII readout. I need to know the sensor's location so I can change it out. I have a diagram of the 2.4L but it is very vague/unclear. It's very cold right now in MD and I don't want to fooling around under the hood looking all over the engine bay for the location of this sensor. From what I have read, it is simple part to replace. I just can't find a good diagram of the 2.0L motor anywhere.

Thanks-
jamapp is offline  
Sponsored Links
Advertisement
 
post #2 of 15 Old 02-09-2011, 11:17 PM
Junior Member
 
Join Date: Jul 2010
Posts: 12
 
jamapp, where you able to locate the camshaft position sensor on your jeep? if so could you maybe send a photo showing its location? I thinks I may need to be replacing mine too.
cytoyo is offline  
post #3 of 15 Old 02-09-2011, 11:41 PM Thread Starter
Junior Member
 
Join Date: Jan 2011
Posts: 6
 
Located sensor and swapped out 2 weekends ago. CEL came back on shortly thereafter w/ same P000A code. Spark plugs replaced and oil/filter changed out this past weekend. Jeep runs a lot better on roads/highways. Jeep is parked in a garage daily and seems to have trouble w/ a smooth start/crank in the afternoon. It cranks before turning over. Battery was also tested a few weeks back and is good. If CEL comes back on, it will have to go in for further diagnostic tests as I am out of answers...
jamapp is offline  
Sponsored Links
Advertisement
 
post #4 of 15 Old 02-09-2011, 11:42 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
Some of the part sources sites may have photo's and info as to its location.
Good luck!

I though the one thing that was solid was the World Engine they use. I hope this is a one off problem. Some other vehicles have their sensors on the back (tranny end) of block.
Attached Images
File Type: jpg jeep.jpg (19.7 KB, 85 views)

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by tripplec; 02-09-2011 at 11:55 PM. Reason: found information on sensor. Attached image
tripplec is offline  
post #5 of 15 Old 02-09-2011, 11:50 PM Thread Starter
Junior Member
 
Join Date: Jan 2011
Posts: 6
 
Just passed 45,000 miles and it only had the 3/36 Warranty. Got it in February 2007 before the Lifetime Warranty came out in July. Hopefully, the new plugs and fresh oil do the job.
jamapp is offline  
post #6 of 15 Old 02-10-2011, 12:13 AM
Junior Member
 
Join Date: Jul 2010
Posts: 12
 
Im with you on that jamapp hope that Jeep stays running strong with no problems.
tripplec, thanks for the attachment, a bit fuzzy but I think I was able to determine the camshaft sensor on the passenger side back of the cylinder head. Not with my Jeep right now but I will definatlely take a look at it tomorrow.
cytoyo is offline  
post #7 of 15 Old 02-10-2011, 12:23 AM Thread Starter
Junior Member
 
Join Date: Jan 2011
Posts: 6
 
That diagram shows 2 camshaft position sensor locations 1/1 and 1/2. I replaced the 1/1 on the driver's side. If my CEL comes back on, the 1/2 may be have to be replaced but honestly I don;t know know at this point.
jamapp is offline  
post #8 of 15 Old 02-10-2011, 12:30 AM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
That was the quality of it as it was when I found it. yeah fussy but at the back side of the engine near each end it appears. I thought it better than no image for you.

Good luck.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
post #9 of 15 Old 02-10-2011, 12:46 AM Thread Starter
Junior Member
 
Join Date: Jan 2011
Posts: 6
 
The picture is great-it is what I used to do the job. In fact, it's the only one I located on the web. Also, it was identified as the 2.4L, not that it really matters that much. Hopefully, others will benefit from it.
jamapp is offline  
post #10 of 15 Old 10-10-2011, 04:15 AM
Junior Member
 
Join Date: Oct 2011
Posts: 5
 
Sensor-Camshaft 1/1 Position

Component ID: 293
Component : SENSOR-CAMSHAFT 1/1 POSITION
Connector:
Name : SENSOR-CAMSHAFT 1/1 POSITION
Color : BLACK
# of pins : 3
Qualifier : (GAS)

Pin Description Circuit
1 5 VOLT SUPPLY K857 20BR/LG
2 SENSOR GROUND K900 20DB/DG
3 CMP 1/1 SIGNAL K44 20DB
Component Location - 14

Last edited by altfour; 10-10-2011 at 04:24 AM.
altfour is offline  
post #11 of 15 Old 10-10-2011, 04:28 AM
Junior Member
 
Join Date: Oct 2011
Posts: 5
 
Sensor-Camshaft 1/2 Position

Component ID: 294
Component : SENSOR-CAMSHAFT 1/2 POSITION
Connector:
Name : SENSOR-CAMSHAFT 1/2 POSITION
Color : BLACK
# of pins : 3
Qualifier : (GAS)

Pin Description Circuit
1 5 VOLT SUPPLY F855 20PK/YL
2 SENSOR GROUND K915 20BR/WT
3 CMP 1/2 SIGNAL K441 20DB/BR
Component Location - 16

Component Location - 17
altfour is offline  
post #12 of 15 Old 10-10-2011, 04:52 AM
Junior Member
 
Join Date: Oct 2011
Posts: 5
 
FONT CAMSHAFT SENSOR REMOVAL:

1. Remove the air cleaner hose to throttle body, disconnect the inlet air temperature sensor electrical connector.
2. Disconnect negative battery cable.
3. Disconnect electrical connector from camshaft position sensor.
4. Remove camshaft position sensor mounting screws.

REAR CAMSHAFT POSITION SENSOR REMOVAL:

1. Disconnect negative battery cable.
2. Disconnect electrical connector at sensor.
3. Remove nut retaining heat shield.
4. Pull heat shield out to uncover sensor.
5. Remove mounting bolt.
6. Remove sensor.

FRONT CAMSHAFT POSITION SENSOR INSTALLATION:

1. Lubricate O-Ring.
2. Install camshaft position sensor utilizing twisting motion. Make sure sensor is fully seated. Do not drive sensor into the bore with screw. This can cause sensor to be incorrectly seated causing engine to fail. Tighten sensor mounting screws to 9 Nm (79.5 in. lbs.) .
3. Carefully attach electrical connector to camshaft position sensor. Installation at an angle may damage the sensor pins.
4. Install the negative battery cable.
5. Install the air cleaner to throttle body hose, connect the inlet air temperature sensor electrical connector.

REAR CAMSHAFT POSITION SENSOR INSTALLATION:

1.Lubricate sensor O-ring.
2. Install sensor utilizing twisting motion. Make sure sensor is fully seated. Do not drive sensor into the bore with screw. This can cause sensor to be incorrectly seated causing engine to fail.
3. Install mounting bolt and tighten to 9 Nm (79.5 in. lbs.) .
4. Carefully attach electrical connector to camshaft position sensor. Fill for positive lock (click). Installation at angle may damage the sensor pins.
5. Install heat shield onto mounting stud.
6. Install heat shield retaining nut and tighten.
7. Connect the electrical connector.
8. Connect negative battery cable.

Last edited by altfour; 10-10-2011 at 05:05 AM.
altfour is offline  
post #13 of 15 Old 11-18-2012, 04:56 PM
Member
 
Join Date: Apr 2011
Location: SC
Posts: 44
 
Is the install instructions the same for Bank 2 sensor?

2007 Jeep Compass Limited...Bone Stock!!
numskull is offline  
post #14 of 15 Old 06-10-2014, 12:48 AM
Junior Member
 
Join Date: Jun 2014
Posts: 4
 
diagram is wrong, but did help find the first one, Thanks

Quote:
Originally Posted by tripplec View Post
Some of the part sources sites may have photo's and info as to its location.
Good luck!

I though the one thing that was solid was the World Engine they use. I hope this is a one off problem. Some other vehicles have their sensors on the back (tranny end) of block.
OK the diagram I found on here was wrong, but did help find first one, there are two camshaft sensors, if your standing in front of the motor they are both located on the drivers side valve covers at 12 and 6 oclock, on the corners. They each have 3 wires comimg out of them. the one on the back side of the motor is pretty easy to see but the one in front is coverd by air cleaner duct work.
I still don't know which is bank intake (A) bank 1 so im changing both.
Still would like any in ut if anyone has any thanks

Last edited by jeff327327; 06-10-2014 at 12:59 AM. Reason: more info
jeff327327 is offline  
post #15 of 15 Old 06-10-2014, 12:51 AM
Junior Member
 
Join Date: Jun 2014
Posts: 4
 
bank 1? bank 2?

Quote:
Originally Posted by numskull View Post
Is the install instructions the same for Bank 2 sensor?
Do you know which is bank 1 and bank 2?
jeff327327 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome