Grinding noise when turning - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 5 Old 08-08-2015, 07:53 PM Thread Starter
Junior Member
 
Join Date: Dec 2014
Posts: 4
 
Grinding noise when turning

I replaced a leaking power steering hose and now I get a grinding noise and the vehicle judders when I turn at low revs. I've tried replacing the power steering pump but that didn't work. Anyone got any ideas?
pete1390 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 08-14-2015, 04:10 PM
Senior Member
 
Join Date: Apr 2012
Posts: 378
 
Quote:
Originally Posted by pete1390 View Post
I replaced a leaking power steering hose and now I get a grinding noise and the vehicle judders when I turn at low revs. I've tried replacing the power steering pump but that didn't work. Anyone got any ideas?

Hey pete1390,

Unfortunately I couldn’t find any TSBs that relate to your issue. Could you please provide some more vehicle information, so I can research this issue further?

Thank you for reaching out.
JeepCares is online now  
post #3 of 5 Old 08-14-2015, 10:15 PM
Senior Member
 
LordReddawg's Avatar
 
Join Date: Mar 2014
Location: Alaska
Posts: 286
 
Garage
Now here's a question did it do this before u changed the pump if it didn't then the pump might be bad it's rare for a new one to go bad but it has happened also check and make sure u have enoff power sterring fluid after u change it
LordReddawg is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 08-20-2015, 03:58 PM Thread Starter
Junior Member
 
Join Date: Dec 2014
Posts: 4
 
Thanks for the replies, it's a 2010 compass. The way it happened was:
The steering started making a noise, I checked the level which was low and topped it up.
The noise stopped immediately.
Then the steering started making a noise, I checked the level which was low and topped it up.
The noise stopped immediately.
I took it to a mate who said a hose was leaking, we swapped to hose for an after market one and now the steering makes a noise all the time at low revs.
The fact that the noise happens only at low revs made me think that the pump could have been damaged when the level was low.
Changing the pump has had a minimal effect, the noise is slightly different now, if anything it is more when the engine is warm.
pete1390 is offline  
post #5 of 5 Old 08-22-2015, 03:55 AM
Junior Member
 
dhruvgpatel's Avatar
 
Join Date: Aug 2015
Location: Toronto, Ontario, Canada
Posts: 5
 
Garage
dhruvgpatel is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome