Wheel speed sensor - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 8 Old 11-05-2015, 07:49 PM Thread Starter
Member
 
Join Date: Jan 2015
Posts: 33
 
Garage
Wheel speed sensor

I have a 2008 Compass, 2.4L 4WD.

I have a code C1044 - Right rear tone, which lights up the abs, 4wd, traction control and BAS lights. I had the vehicle on a lift and I thought someone here said you could just unbolt the sensor from the rear but all I can see is the connector. Do I need to remove the axle?

Also, I'm going to check the rings to see if they are dirty but may need to just replace the sensor and/or the wheel bearing assembly.

Question: With the code and lights activated, I know I can't engage 4WD but does that mean that I don't have AWD either? I only have FWD?
Sdsjeep2008 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 11-18-2015, 04:25 PM Thread Starter
Member
 
Join Date: Jan 2015
Posts: 33
 
Garage
Update

Quote:
Originally Posted by Sdsjeep2008 View Post
I have a 2008 Compass, 2.4L 4WD.

I have a code C1044 - Right rear tone, which lights up the abs, 4wd, traction control and BAS lights. I had the vehicle on a lift and I thought someone here said you could just unbolt the sensor from the rear but all I can see is the connector. Do I need to remove the axle?

Also, I'm going to check the rings to see if they are dirty but may need to just replace the sensor and/or the wheel bearing assembly.

Question: With the code and lights activated, I know I can't engage 4WD but does that mean that I don't have AWD either? I only have FWD?
UPDATE: the problem turned out to be the metal ring on the back of the wheel bearing that holds the sensor in place rusted and the sensor was just flopping around in there.

Replaced the wheel bearing (Moog $69) and it's fine.

Bad news was that my caliper bolts would not budge even using a torch and they had to be cut off and my caliper replaced. Same thing with the axle ($200 from a dealership).

At the same time, I had my mechanic (not at dealership) replace a rusty oil pan and a right outer tie rod end.

The left rear looks just as bad and will most likely need same work done soon. I can't believe how a 2008 vehicle with only 80,000 miles on it can have this much rust. The body and floor pans are in excellent condition though.

On a positive note, the rear brake pads are still the original and have lots of life left on them.

I had my front crossmember replaced under warranty last spring and the rear subframe will also be replaced under warranty once it's been condemed, which I believe won't be long. I do thank Jeep for honoring that 2007 warranty for me (it was built in 2007).
Sdsjeep2008 is offline  
post #3 of 8 Old 11-19-2015, 12:55 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
I am wondering if your rear calipers are even working. I am on my 3rd set at least. LOL
These calipers can hang up and not move (seems to be due to cheap materials used, My mechanic swapped it for me & said he'd seen a lot on recent Chrysler vehicles) and already replace one of them.

On another note I noticed my oil pan rusting which I cleaned up and rust paint sprayed it. The steel used for the pan is very poor quality for it to rust like that. Someone is going to blow their engine when a hole blows through and the oil goes out while driving.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by tripplec; 11-19-2015 at 12:58 PM.
tripplec is offline  
Sponsored Links
Advertisement
 
post #4 of 8 Old 11-20-2015, 05:39 PM Thread Starter
Member
 
Join Date: Jan 2015
Posts: 33
 
Garage
Quote:
Originally Posted by tripplec View Post
I am wondering if your rear calipers are even working. I am on my 3rd set at least. LOL
These calipers can hang up and not move (seems to be due to cheap materials used, My mechanic swapped it for me & said he'd seen a lot on recent Chrysler vehicles) and already replace one of them.

On another note I noticed my oil pan rusting which I cleaned up and rust paint sprayed it. The steel used for the pan is very poor quality for it to rust like that. Someone is going to blow their engine when a hole blows through and the oil goes out while driving.
Well, I know that at least one of the rear calipers is working now. I replaced the oil pan with a decent one from Advance Auto for less than $50. I had brushed the bottom of the oil pan down with a wire brush a couple months ago while changing my oil and had sprayed some rust neutralizer on it but I decided to just replace the oil pan since my buddy had the Jeep on the lift to do some other work (outer tie rod end, Wheel bearing, Caliper, Axle).

Total cost for parts and labor for the Oil pan, Synthetic Oil and Filter, Outer tie rod end, Moog wheel bearing, caliper and new axle was approximately $700.00 and $300.00 of that was for six hours of labor so I didn't do too bad.

It would have cost me ALOT more if I had all that work done at a dealership!
Sdsjeep2008 is offline  
post #5 of 8 Old 03-31-2016, 01:22 AM
Member
 
Join Date: May 2013
Posts: 38
 
Quote:
Originally Posted by Sdsjeep2008 View Post
UPDATE: the problem turned out to be the metal ring on the back of the wheel bearing that holds the sensor in place rusted and the sensor was just flopping around in there.

Replaced the wheel bearing (Moog $69) and it's fine.

Bad news was that my caliper bolts would not budge even using a torch and they had to be cut off and my caliper replaced. Same thing with the axle ($200 from a dealership).

At the same time, I had my mechanic (not at dealership) replace a rusty oil pan and a right outer tie rod end.

The left rear looks just as bad and will most likely need same work done soon. I can't believe how a 2008 vehicle with only 80,000 miles on it can have this much rust. The body and floor pans are in excellent condition though.

On a positive note, the rear brake pads are still the original and have lots of life left on them.

I had my front crossmember replaced under warranty last spring and the rear subframe will also be replaced under warranty once it's been condemed, which I believe won't be long. I do thank Jeep for honoring that 2007 warranty for me (it was built in 2007).

could you not get a new ring/strap from the dealer ??
I have same issue 4x4 2007 POS

2007 Compass Sport 4x4
byteme is offline  
post #6 of 8 Old 04-04-2016, 12:10 PM Thread Starter
Member
 
Join Date: Jan 2015
Posts: 33
 
Garage
Quote:
Originally Posted by byteme View Post
could you not get a new ring/strap from the dealer ??
I have same issue 4x4 2007 POS
I didn't try that. I've read on the forums that you had to replace the entire bearing. Since you would have to remove the wheel bearing anyway, I would just replace the bearing while you're there. Wasn't very expensive for the bearing itself since I bought it at an auto parts store.
Sdsjeep2008 is offline  
post #7 of 8 Old 04-07-2016, 06:12 AM
Member
 
Join Date: May 2013
Posts: 38
 
Talking

Quote:
Originally Posted by Sdsjeep2008 View Post
I didn't try that. I've read on the forums that you had to replace the entire bearing. Since you would have to remove the wheel bearing anyway, I would just replace the bearing while you're there. Wasn't very expensive for the bearing itself since I bought it at an auto parts store.
yeah no ring available and like previously mentioned huge difference in price up here in Canada I may try to mcgiver it just to dump this thing but will have to replace the very very loud alt sounds like a diesel with no oil

2007 Compass Sport 4x4
byteme is offline  
post #8 of 8 Old 04-07-2016, 01:24 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
I am going to have to look at the rear of my bearing to see this. I have rear brakes to do this spring once I have some good weather as well as warm temperature. Sensors rusting off is a real pain. I had this rust sprayed once at a place call Krown but they don't get everywhere. I have my own cans of rust spray I'll attack those areas later as well.

I doubt these show up in any of the line drawing manuals but I'll have to research that as well. Its bad enough the front and rear cross frame is weak and rusts, now this as well.

Did the Engineers not realize we live and exist in a contentment where rusting is a year round fact affecting our vehicles. Its a safety component and should be a recall pushed out to repair them ALL !!

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by tripplec; 04-07-2016 at 01:26 PM.
tripplec is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome