Brake noise at cold start - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 1 Old 05-11-2011, 12:58 PM Thread Starter
Junior Member
 
Join Date: Aug 2009
Posts: 8
 
Brake noise at cold start

I have an issue with what I believe is my brakes making noise I thought this because when I hit them with some force the noise would go away and would not come back unless the compass sat for a while.

I initally thought it was my rear brakes. They where in rough shape so I replaced the rotors and pads. I tooks for a test spin and still got the noise.

I took the fronts off and checked them out. They are only about 6 months old with 10k miles on them. The Rotors and pads both look fine.

I would call the noise I hear a grinding noise but not a constant grind...if that makes any sense.

Also the brakes do not vibrate when I hit them soft or hard and they do not make any noise when they are used either.

Any help would be greatly appreciated.
-Bill

Last edited by wkmaylish2; 05-11-2011 at 01:03 PM.
wkmaylish2 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome