Rear Defroster Rear Wiper Not Working - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 2 Old 01-07-2016, 01:44 AM Thread Starter
Junior Member
 
Join Date: Aug 2015
Posts: 2
 
Garage
Rear Defroster Rear Wiper Not Working

Hi there, first time posting in the forum but not the first time using all the great information contained in it.

On my way home tonight my rear wiper didn't work as well as the rear window defroster. They both worked fine this morning.

Also on a side note, the back interior light doesn't stay on when the back hatch is open. It goes off almost immediately. This has only been happening for a few days now.

Anybody have any ideas what went wrong.

Do the wiper and defroster work off of the same fuse? I looked in my manual and didn't see a fuse listed for either on of them.

Thanks for any help anybody can give me.


Jamie
2007 Jeep Compass
Goulais is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 01-10-2016, 07:47 AM Thread Starter
Junior Member
 
Join Date: Aug 2015
Posts: 2
 
Garage
Well installing a new wiper motor didn't fix my problem. It turns out I have 3 broken wires inside the rubber boot where the wiring harness goes from the main body of the car into the lift gate. I have now spliced them back together for a temporary fix and everything is working as it should. I am going to buy a new wiring harness now since the other wires didn't look all that good to me.

I guess this is the weak point due to the gate opening and closing and the wires bending in this area.

If anybody has any experience in changing this harness out I would welcome any insight you might have. Also any wiring diagrams would be helpful as well, like where does the end plug into and how do I get to it.

Also, if anybody knows how to remove the wiring harness from the clips in the lift gate, or what they are called or a part number so I can buy some new ones that would be great, since they don't look like they are reusable.

I guess this is now an electrical problem so mods feel free to move it to the electrical part of the forum.

I will post some pictures and give a step by step instructions on how I do this once I do it in case anybody else has this issue and needs to get it done.


J
Goulais is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome