Check engine light on, problems with acceleration - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 6 Old 01-22-2016, 09:46 PM Thread Starter
Junior Member
 
Join Date: Jan 2016
Posts: 8
 
Check engine light on, problems with acceleration

So, today I was driving on the highway minding my own business, cranking the tunes, feeling good. Next thing I know some idiot was about to merge right into me so I gunned it in order to get ahead and away from said idiot. I didnt realize that I accelerated that hard (like I said I was cranking the tunes, didnt hear anything) but looked at rpm's and there I was at 4000. I'm usually really mindful at being easy accelerating to keep from having any tranny problems. Well right after, my engine light went on, has remained on since. I have noticed a slight difference in the shifting since then. Stopped at auto zone and their scanner came up with nothing. I know that the only way to really figure this out is to have a thorough diagnostic scan done by my mechanic but I wanted to hear any feedback that any of you on here might have. This is my first time joining a forum so I am totally new to this. Just figured it would help to hear from other jeep compass owners who have more knowledge than me. Thanks everyone!
victory42day is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 01-23-2016, 12:38 AM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
Well it certainly helps with "I wanted to hear any feedback that any of you on here might have." when we know what you're driving and background millage etc.

Type it all in and/or create a detailed signature so you won't have to do it each time.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
post #3 of 6 Old 01-23-2016, 01:54 AM Thread Starter
Junior Member
 
Join Date: Jan 2016
Posts: 8
 
2007 jeep compass. 85,820 miles. haven't had any tranny issues other than a new throttle control sensor. Front end and rear end suspension issues but have had LOTS of work to fix all of that. Just freaking out a bit because I seriously have spent over $5000 worth of repairs/maintenance in past year. Just got it back last week from all the rear end work. Eek. Ty sooo much for responding
victory42day is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 01-23-2016, 02:08 AM Thread Starter
Junior Member
 
Join Date: Jan 2016
Posts: 8
 
last week rear end work: rear toe links, lower control arms, upper lateral arms. alignment done, had serious negative camber on drivers side rear tire. got new rear tires because all mis-alignment caused them to wear out faster
victory42day is offline  
post #5 of 6 Old 01-23-2016, 01:18 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
Well, you tried so I suspect it will clear itself as there are no codes unless the codes are very vehicle specific to other subsystems.

However, if you really look a my signature a full reference is there for anyone.
- approx millage
- Engine
- Power Trains 2WD or 4WD
- Transmission

You can go to Quicklinks above on the bar and edit (to enter a signature).

4000RPM is not over reving for one and the computer will not allow it to destroy itself.

You could have blasted carbon from the combustion changer out or an O2 sensor went out of range (which should have set a code). Gas quality and brands do make a difference in the long term stick to a Tier One gas for the next several fill ups!!

Since you location is also missing.

Station such as SHELL, PETRO CANADA, ESSO are the only Tier One grades in Canada which excel in cleaning and being clean. USA has equivalent and more stations. Mobil One and Exxon I believe are among but you can google for Tier one stations chains.

Sometime running a tank of Their Premium on a highway drive clean quicker. I WOULD NOT resort to a fuel additive which can do more harm.

Good luck, wait and see if there are other symptoms.

NOTE: Premium grades not only are higher octane but have more cleaning agents typcially. At least Shell and Petro Canada claim that also no Ethanol is in the gas.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by tripplec; 01-23-2016 at 01:45 PM. Reason: Added last note.
tripplec is offline  
post #6 of 6 Old 01-23-2016, 03:09 PM Thread Starter
Junior Member
 
Join Date: Jan 2016
Posts: 8
 
codes P00647, P0032, P2010

went to diff store and their scan did show codes. Gave me codes and breif description of what it means but I'm still clueless. What do you think? You seem to know quite a bit. Also it seems to be having difficulty shifting out of 3rd gear unless I let off of the gas. I'm reading up alot about the o2 sensor and maybe this is why.

Last edited by victory42day; 01-23-2016 at 03:11 PM.
victory42day is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome