2010 jeep compass no heat coming out of vents? - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 5 Old 12-19-2016, 08:47 PM Thread Starter
Junior Member
 
Join Date: Dec 2016
Posts: 4
 
2010 jeep compass no heat coming out of vents?

It's my mom's BF's vehicle so I am quite unfamiliar with it. I work on older vehicles lol.

Anyways, a few weeks ago the inlet pipe that runs from the tstat housing to the water pump was corroded and leaking. Shop replaced it along with the other 2 water pump gaskets. Mom's BF then complains that his heat wasn't hot. I figure it was air pockets from not being properly bled. I also read about the bleed holes on the t stat's on the compass so I figured maybe if he drove it long enough, the air would work itself out.

It's been about 2 weeks now and his heat is still crappy. I went to his house today, took radiator cap off. I had him sit in the driver's seat giving it revs while I stood outside next to driver's door. I kept checking the vent closest to driver's side front window for warmth. That vent seems to get pretty warm. All the hoses felt hot including both heater core hoses. So after about 20 minutes I put radiator cap on. I went and sat in passenger seat and discovered the vents in the middle and the one on passenger side nearest window felt luke warm and the vent closes to driver's window is considerably warmer. He gave it short revs and the vents still blew out luke warm except the one closest to driver's window which feels warm. The temp gauge was at half way the whole time.


The shop removed the t-stat housing to replacing the inlet pipe. Could they have put the t'stats back in backwards? Could it be a vacuum issue? Issues with the control box? Could it be the blend doors? I did put some aluma seal in the radiator when the inlet pipe was pissing coolant so I doubt it blocked anything. Would there be any reason for that one vent to blow warm air compared to the others blowing luke warm air? Where do I start? He really has no money until after Christmas.
tom5170 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 12-20-2016, 01:04 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
I know on my 09 the blend control knob must be in the detent position and NOT between at all for proper air flow. Its a manual control system I have and not climate control which is quite different in every vehicle as you have servo's to deal with. If the inlet and outlet hot water pipes to the core are hot then its up to the air flow from what should be expected. Core should not be block it it. These world engines have to T-Stats and for sure in the 2.4L builds. If only one was changed the shop should have done both to keep things optimized.

Many DIY are told also certain parts should be OEM. T-Stats is one of them, as are critical sensor as CPS for proper operation.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by tripplec; 12-20-2016 at 01:10 PM.
tripplec is offline  
post #3 of 5 Old 12-20-2016, 11:01 PM Thread Starter
Junior Member
 
Join Date: Dec 2016
Posts: 4
 
They replaced the almost-sqaure looking gasket on the t-stat housing because it was shrunken. They never replaced the t-stat's. I am almost certain he had good heat before the inlet tube sprung a leak. Seems like after this was fixed then his heat started blowing cold. I tried bleeding it with radiator cap off, still luke warm air after it idles. Only thing I can think of next is to drive it up on ramps get the front end up and try rebleeding it with radiator cap off. Radiator cap is brand new too. Both heater core hoses are equally hot. Like I said I am almost certain it was blowing hot air before this because I was running it while finding the leak and felt hot air blow out the vents..

His controls are 3 round dials. The middle one controls cold and hot. What do you mean by detent? Can I troubleshoot this after I try rebleeding on ramps? I know when he moves the fan speed dial to the high, the blower motor shuts off...

It doesn't run hot on the gauge and it doesn't run cool. Gauge seems to flucuate normally when the t-stat opens, the gauge drops a little.

Last edited by tom5170; 12-20-2016 at 11:04 PM.
tom5170 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 12-21-2016, 12:04 AM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
Detent


As the knob arrow come to the Down flow mark, bi-level, defrost there is click felt in the knob as its turned. These are their respective detent position. Its not a variable position knob and it should not be in between. Air flow will be affect as well as likely where it directed to. Hot air flowing out through the core is of course directed according to these position markings. Therefore if there is insufficient air its one problem and cold but plentiful air is another.

Burping the engine on a steep upward slope may help. I don't know. Since the repair was paid for contacting the shop as to why the trouble may reveal what might be wrong.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
post #5 of 5 Old 12-21-2016, 12:19 AM Thread Starter
Junior Member
 
Join Date: Dec 2016
Posts: 4
 
The directions of the air changes normally. Works in all the positions. It's just the air coming out of the vents is lukewarm on the passenger side vent and the middle vent. Driver's side vent on far left blows warmer air.
tom5170 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome