buzzing sound when turning key, very difficult to start - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 18 Old 04-08-2017, 07:40 PM Thread Starter
Member
 
Join Date: Dec 2016
Location: ENGLAND, UK
Posts: 38
 
buzzing sound when turning key, very difficult to start

hi team...got a 2011 compass limited..she has been going as sweet as a nut since i bought her in November 16...however, the last couple days she has been playing up.
when i turn the key to position 2, the dashboard lights all work fine, with no fault lights..however...at the same time, there is a buzzing sound in the "near-side", area of the car, and the car moves from side to side when it is being cranked, like someone is gently rocking it..the buzzing goes on for about a minute, then stops....the car will start, but i have to turn her over for about 20 seconds and she splutters into life.
i dont want to do this too often, in case i damage the ignition etc...also..when i put the lights on, the dashboard display instantly dims, and returns to normal when i turn the lights off.
i have checked the battery. it is putting out 12.3V, so is fine,(by my limited mechanical knowledge).

i took out a 2 year warranty on the car when i bought it, just as well huh.

any help/advice would be much appreciated, to give me an idea of what is wrong, maybe i could sort it myself, maybe.

cheers guys
powerbow1415 is offline  
Sponsored Links
Advertisement
 
post #2 of 18 Old 04-09-2017, 09:14 PM Thread Starter
Member
 
Join Date: Dec 2016
Location: ENGLAND, UK
Posts: 38
 
hi again team..UPDATE..i have sorted the light-dimming issue...its just this buzzing and starting issue to solve..i am going to book the car into my local jeep garage ASAP when they open tomorrow.
i have absolutely no idea what it is...it sounds like it is coming from the nearside, but sound can be deceptive, as you know....i just checked the car again...the sound is still there, but it starts fine now, but ticks over a little erratically.
i had the hood open, to check any noise in the engine...that buzzing sound seems to be coming from the "back-right" side, as you look at the engine, but inside the car it sounds like it is coming from a different place..noise distortion..it must be coming only from the engine.
i can drive the car, but i know that as soon as i turn the car off, having driven it a distance, i will have probs' starting it again.

in conclusion...it starts from cold, but not from warm/hot...hope i have given enough current info to help identify the problem.

cheers guys
powerbow1415 is offline  
post #3 of 18 Old 04-10-2017, 03:08 PM
Senior Member
 
Join Date: Nov 2016
Posts: 272
 
I'm banking on some sort of relay that gets tripped up when it gets warm... this is very interesting..
NorthStar is offline  
Sponsored Links
Advertisement
 
post #4 of 18 Old 04-10-2017, 03:47 PM Thread Starter
Member
 
Join Date: Dec 2016
Location: ENGLAND, UK
Posts: 38
 
hi NorthStar....relay..its worth looking at my friend...i could nip out and have a look now..just gotta locate what relay may be the cause.
powerbow1415 is offline  
post #5 of 18 Old 04-10-2017, 04:39 PM Thread Starter
Member
 
Join Date: Dec 2016
Location: ENGLAND, UK
Posts: 38
 
i have just checked all the mini fuses and cartridge ones, and they are all fine...maybe a loose wire to the fuse box?, does that sound plausible?. if it is the fuses..i dont know whether the car has the "cubed",relays..i have never seen any on the car. and the owners manual says nothing about them
powerbow1415 is offline  
post #6 of 18 Old 04-11-2017, 03:22 PM
Senior Member
 
Join Date: Nov 2016
Posts: 272
 
This may help as I think the 09 was the same as the 11s ?

NorthStar is offline  
post #7 of 18 Old 04-11-2017, 04:05 PM Thread Starter
Member
 
Join Date: Dec 2016
Location: ENGLAND, UK
Posts: 38
 
thanks for that my friend..i will look at it in more detail later.....i was just thinking on the problem again, and i thought that maybe its an ignition switch problem, or something ignition related?.
powerbow1415 is offline  
post #8 of 18 Old 04-12-2017, 04:44 PM
Senior Member
 
Join Date: Nov 2016
Posts: 162
 
Have your brought the Compass into local jeep garage yet? No idea why you'd have problems starting when it's warm, maybe the compression is too low?
wheelin is offline  
post #9 of 18 Old 04-12-2017, 05:05 PM Thread Starter
Member
 
Join Date: Dec 2016
Location: ENGLAND, UK
Posts: 38
 
hi wheelin...nice to chat with you my friend....she is booked in for 08.30 tomorrow morning 13th...got a jeep specialist garage just 5 mins drive from me. how cool is that!?.
compression?...could be...if it is, it does not sound like a big expensive job to me, but then, i am to car mechanic.
powerbow1415 is offline  
post #10 of 18 Old 04-13-2017, 05:52 PM Thread Starter
Member
 
Join Date: Dec 2016
Location: ENGLAND, UK
Posts: 38
 
hi team....just got the car back.....and there is a petrol attendant who has a lot to answer for...for the first time,(and the last),i used an attended petrol station for my last fill up..BIG MISTAKE!.
i asked for half a tank of diesel, and the idiot put petrol in!!!!!...so the buzzing sound and the difficulty starting from warm/hot, was the low pressure fuel pump!..my mechanic said that the pump should be ok, as the car eventually starts, and runs.

what i was advised to do is fill up regular, to dilute and work out the petrol. makes sense.
powerbow1415 is offline  
post #11 of 18 Old 04-14-2017, 07:35 PM
Member
 
hotvak123's Avatar
 
Join Date: Mar 2017
Location: Plattsburgh New York
Posts: 50
 
Garage
your saying that it's a diesel engine and he put in gasoline instead ?
that's not good for the engine, and if so the tank should be drained ,and system flushed with diesel. running a diesel engine with gas in it can be catastrophic.

2016 Jeep Compass Latitude
2.4L with 6 speed Automatic Transmission
----------------------------------------------
2000 Jeep Cherokee with Snoway plow
4.0L with Auto Transmission
----------------------------------------------
1970 Opel Gt
1.9L with Standard Transmission
hotvak123 is offline  
post #12 of 18 Old 04-17-2017, 09:38 AM Thread Starter
Member
 
Join Date: Dec 2016
Location: ENGLAND, UK
Posts: 38
 
hi hotvak123.....i agree my friend....filling up with diesel regular?, though it makes sense, sort of, i dont feel comfortable with it. so i have just got the tank fully drained and flushed out, diesel additive put in with 5 litres of diesel added by the fuel drainage company i used...then i filled up with fresh diesel...she feels like she is running a lot better now. had no laboured starting issues since.
i am still getting the pump noise, BUT, from past experience of cars i have owned, when you activate the ignition, one can hear the pump starting up...it does not sound like " buzzing", anymore. it sounds more "smooth".
my previous car was a rover 75 tourer and you could hear the pump start up when you unlocked the doors..lasted for about 30 seconds, as does the pump noise on my jeep.
i am assuming that the fuel pump does the same on jeeps?. or will stop in time?.

any thoughts guys?.
powerbow1415 is offline  
post #13 of 18 Old 04-18-2017, 02:10 AM
Member
 
hotvak123's Avatar
 
Join Date: Mar 2017
Location: Plattsburgh New York
Posts: 50
 
Garage
a pain in the rear to say the least. , it could save you a lot of headaches.
if you haven't seen this check it out.


2016 Jeep Compass Latitude
2.4L with 6 speed Automatic Transmission
----------------------------------------------
2000 Jeep Cherokee with Snoway plow
4.0L with Auto Transmission
----------------------------------------------
1970 Opel Gt
1.9L with Standard Transmission
hotvak123 is offline  
post #14 of 18 Old 04-18-2017, 03:30 PM Thread Starter
Member
 
Join Date: Dec 2016
Location: ENGLAND, UK
Posts: 38
 
thanks for that my friend...if i wasn't paranoid about it before, i am now....cheers matey. lol......well whats done is done i guess. it is running fine now fingers crossed.
powerbow1415 is offline  
post #15 of 18 Old 04-18-2017, 11:09 PM
Member
 
hotvak123's Avatar
 
Join Date: Mar 2017
Location: Plattsburgh New York
Posts: 50
 
Garage
You should be fine but I would of put the gas station on notice, and document everything from that point on, just in case you need to sue there ass for repairs..

2016 Jeep Compass Latitude
2.4L with 6 speed Automatic Transmission
----------------------------------------------
2000 Jeep Cherokee with Snoway plow
4.0L with Auto Transmission
----------------------------------------------
1970 Opel Gt
1.9L with Standard Transmission
hotvak123 is offline  
post #16 of 18 Old 04-18-2017, 11:46 PM Thread Starter
Member
 
Join Date: Dec 2016
Location: ENGLAND, UK
Posts: 38
 
i have put a complaint in..they apologised profusely and said they would look into it..we will see huh.

cheers buddy
powerbow1415 is offline  
post #17 of 18 Old 04-19-2017, 04:26 PM
Senior Member
 
Join Date: Nov 2016
Posts: 162
 
Luckily you found the problem. Wrong fuel seems to be harder to spot in a diesel than petrol engine. Last time my mom put diesel where she shouldn't the car just stopped running completely.
wheelin is offline  
post #18 of 18 Old 04-20-2017, 08:10 AM Thread Starter
Member
 
Join Date: Dec 2016
Location: ENGLAND, UK
Posts: 38
 
yeah, i know how your mom feels wheelin... some vehicles react different to others huh...a friend of mine had that problem too...her car just conked out because she put petrol in a diesel.....i think the age of the car is also a factor...her car was 14 years old, with over 150.000 miles, so parts where a little worn...my jeep is less than 6 year old, with 47.000 on the clock.

maybe its age and/or age of parts.
powerbow1415 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome