2010 Compass Suddenly Slows then won't go over 20 MPH - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 4 Old 08-19-2017, 05:27 PM Thread Starter
Junior Member
 
Join Date: Aug 2017
Posts: 2
 
2010 Compass Suddenly Slows then won't go over 20 MPH

I was driving about 45 MPH when suddenly it felt like the car downshifted to low gear the engine light and ASB lights came on and with the gas petal to the floor it would not go over 20 MPH with the engine RPM's at 4500. I was able to get home left the car overnight got in the next morning started the car ABS light was off Engine still on put in gear drove normal no problems. Went to my mechanic checked the codes found nothing all was good. Drove the car that day several miles no problems then after about 50/75 miles the same thing happened again. Only difference this time I was able to get the car going up to about 60 MPH but it was bucking and shaking and the RPM's were way out of line 4000 with the speed I was doing. Looking for some thoughts before I go to see my mechanic Monday.
Kittles1## is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 08-19-2017, 11:32 PM
Senior Member
 
REVIGOR's Avatar
 
Join Date: Jan 2017
Location: Laredo, Texas
Posts: 105
 
There's a recall for some models of the Jeep Compass due to stalling.
REVIGOR is online now  
post #3 of 4 Old 08-20-2017, 02:10 PM
Senior Member
 
zoner99's Avatar
 
Join Date: Oct 2016
Location: Ontario, Canada
Posts: 212
 
Quote:
Originally Posted by Kittles1## View Post
I was driving about 45 MPH when suddenly it felt like the car downshifted to low gear the engine light and ASB lights came on and with the gas petal to the floor it would not go over 20 MPH with the engine RPM's at 4500. I was able to get home left the car overnight got in the next morning started the car ABS light was off Engine still on put in gear drove normal no problems. Went to my mechanic checked the codes found nothing all was good. Drove the car that day several miles no problems then after about 50/75 miles the same thing happened again. Only difference this time I was able to get the car going up to about 60 MPH but it was bucking and shaking and the RPM's were way out of line 4000 with the speed I was doing. Looking for some thoughts before I go to see my mechanic Monday.
Yeah that's classic. SOP on any FCA vehicle if this happens should be to pull over as soon as safely possible, shut off the ignition, wait a moment and restart. Usually that will restore normal operation at least temporarily. One occurrence may be random but if it happens twice you can assume it will keep happening. What happens is that a sensor goes 'bad' ie the control logic sees a completely wrong number from that sensor, but, it doesn't necessarily stay 'bad' long enough to register as a failed sensor and create an error code. (again I'm not a mechanic, I'm just speaking from my own observations and tinkering over the years).
The '4000 rpm at 60 mph' sound like it was in 'limp home' mode. That means the logic determined that something was wrong and went to default settings, including holding the trans in a low gear. The idea is that you are supposed to be able to drive somewhere for service rather than needing a tow truck. Also you as the driver are supposed to be smart enough to recognize that something ain't right and slow down, just sayin'.
My bet is, which ever sensor it is, the sensor itself is probably ok but is dirty or has a bad connection. Replacing the sensor will fix the problem but only because it is clean and has a good connection.
zoner99 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 08-20-2017, 03:00 PM Thread Starter
Junior Member
 
Join Date: Aug 2017
Posts: 2
 
Thanks for your detailed message I appreciate that.
Kittles1## is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome