Compass 2007 weird issue - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 3 Old 12-18-2017, 09:30 PM Thread Starter
Junior Member
 
Join Date: Dec 2017
Posts: 4
 
Compass 2007 weird issue

Hi!I have a Jeep Compass 2007 MT 2.4.I have recently changed tires dimension to 215/55/17" from 215/60/17". However after that I have noticed that in slow speed and especially in sharp turns(left and right) the car brakes without a reason and it seems that the car is on 4wd mode.I have contacted the dealership and the have told me that this happens because of tires dimension change.I have replaced the tires and used again the 215/60/17" but the issue still exists.
Any ideas?There is no check engine light indication.Just the car brakes in sharp turns,even when I use the reverse.The 4wd seems to have stuck in slow speed.
Could be a bad ABS sensor?
I forgot to mention that the dealership have told me to make the ESP comes on in order the Powertrain Control Module to "identify' the new tires dimension.Didn't work.
Any suggestions!
Thanks!
fk1978 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 12-19-2017, 09:58 AM
Senior Member
 
zoner99's Avatar
 
Join Date: Oct 2016
Location: Ontario, Canada
Posts: 210
 
I suggest you should double check each tire and confirm that all four are the same size, and that tire pressures are all within a couple of pounds of each other. If those are correct then yes an ABS senors could be at fault but it is odd that it started after a tire change. I'd visually inspect the sensors before going any further.
zoner99 is offline  
post #3 of 3 Old 12-19-2017, 02:52 PM Thread Starter
Junior Member
 
Join Date: Dec 2017
Posts: 4
 
Quote:
Originally Posted by zoner99 View Post
I suggest you should double check each tire and confirm that all four are the same size, and that tire pressures are all within a couple of pounds of each other. If those are correct then yes an ABS senors could be at fault but it is odd that it started after a tire change. I'd visually inspect the sensors before going any further.
The tires size and tires pressure are the ideal.
To be more specific the dealership said the the 215/55/17" tires that I have used "confused' the vehicle's PCM and it didn't recognize the new tires dimension.However I have returned to the 215/60/17" and the issue is still here.As an advice they told me to activate the ABS-ESP system in order to '"read" the new tires.But didn't fix the problem.
Any more ideas please!
fk1978 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome