Oil filter sending unit ? - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 2 Old 07-29-2018, 08:43 PM Thread Starter
Junior Member
 
Join Date: Jul 2018
Posts: 4
 
Oil filter sending unit ?

Mechanic just replaced my sending unit on my 2007 jeep compass sport bc light comes on and then car wont move when press on gas...seems to happen after filling up with gas... would replacing this help fix this problem?????
Talobx65$ is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 07-30-2018, 03:02 PM
Senior Member
 
Join Date: Oct 2017
Posts: 711
 
Whyyyyyy would you start yet another thread on this? We already have multiple threads from you trying to discuss your Jeep's issues. Don't start any more new ones for the same issue. If you want help delete this thread and go put your new information on the original thread some of us have already replied to.
arudlang is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome