2007 2.4L, random hesitation and idle hunt - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 12 Old 07-19-2011, 01:57 PM Thread Starter
Junior Member
 
Join Date: Sep 2010
Posts: 3
 
2007 2.4L, random hesitation and idle hunt

Hello,

I'm pretty new here, helping a friend with their 2007 Compass 2.4 w/ just over 100k miles.

The truck has been hesitating lately. It feels like a slight hiccup in acceleration. Also, it occasionally hunts for idle, usually starting around 1,110RPM, an settling down to ~600RPM after about a minute.

We started with a simple tune-up. Spark plugs and the pre-cat o2 sensor, but this didn't alleviate the issue.

Does anyone have any experience with these symptoms? I'm currently leaning towards a dying fuel pump, or possibly a vacuum leak.

Could someone point me towards a vacuum diagram or a service manual for this vehicle?

Thanks!
cobbs is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 09-03-2011, 11:11 PM
Junior Member
 
Join Date: Sep 2011
Location: Jacksonville
Posts: 5
 
Garage
im having the same problem... and I was thinking about the fuel pump as well... im hoping to find answers the same question.
jeepchik07 is offline  
post #3 of 12 Old 09-05-2011, 01:42 PM
Junior Member
 
Join Date: Sep 2011
Location: tx
Posts: 6
 
Garage
I had the same problem but I would notice it when it would downshift, so I changed the automatic transmission fluid and its filter and didn't notice it again. But a couple weeks later it started up again so I changed the spark plugs and after two days of driving I haven't noticed it, but if it does it again I'm changing the fuel pump.
mrcarrerista is offline  
Sponsored Links
Advertisement
 
post #4 of 12 Old 10-20-2011, 02:08 PM
Junior Member
 
Join Date: Oct 2011
Location: outside Jacksonville, NC
Posts: 5
 
I have a similar problem and the MIL is on now..... Did you ever find out what the problem was??
luckynlove is offline  
post #5 of 12 Old 10-22-2011, 03:50 PM
Member
 
Jose's Avatar
 
Join Date: May 2011
Location: Montreal
Posts: 52
 
Garage
same problem here.. and I'm at 98 000km lol I think I should do a good check of the engine before I hit the 100 000

Jeep Compass 2008 Manuel
16x8 Unique Series 42, +12 offset with Goodyear UltraGrip Ice 235/60/16
DynoMAX custom dual-exit catback
Mopar spoiler and tail light guard
Jose is offline  
post #6 of 12 Old 10-30-2011, 05:11 AM
Junior Member
 
Join Date: Oct 2011
Location: outside Jacksonville, NC
Posts: 5
 
Mine was doing the same thing, I did have the fuel pump replaced after one day the car just wouldn't start... I had it replaced yesterday and tonight same problem and it won't start...We had the hiccups in acceleration and we also had occasional rough start ups. Car seemed fine all last night and today and to be honest I am pissed at this point.
luckynlove is offline  
post #7 of 12 Old 05-10-2014, 02:00 AM
Junior Member
 
Join Date: May 2014
Posts: 5
 
same year model jeep as OP, 2007 2.4L 4x4... same hesitation. started at 150k miles. the car will buck with moderate acceleration about 4-5 times before reaching top speed.

This car was bought used and has not been maintained. We replaced the fluid in the CVT and spark plugs are getting replaced tomorrow.

anyone ever figure out what was causing the hesitation during acceleration??
AntFJ is offline  
post #8 of 12 Old 05-10-2014, 01:05 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
First thing is check for CODES. There are so many things that might cause that other than a basic tune-up if not previously done. EG Plugs (copper and not platinum types), good gas, air filter, throttle body cleaning. Although the oil has no effect on this but if regular oil changes have not be done it may aggravate the condition of the engine and/or be sludged up now.

If there aren't any codes and the tune-up is done. Checking the fuel pressure may be the next step. If the pressure is dropping below spec's the engine will not perform properly under various circumstances. Pulling the tank could be a challenge though as I was told when the dealer replace mine under warranty. This are not built for easy servicing.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by tripplec; 05-10-2014 at 01:08 PM.
tripplec is offline  
post #9 of 12 Old 05-10-2014, 06:50 PM
Junior Member
 
Join Date: May 2014
Posts: 5
 
Tripplec thanks for the advice - I rebuild old land cruisers so this computer car world is new to me. Will the car give codes without an engine light?

No hesitation after some maintenance today. The engine was 1.5 quarts of oil low and the spark plugs were pretty bad. Platinum, gaps ranging from .030 to .055. I replaced them with copper and gapped them to .040

I also used my ohm meter on the coils. They are all 0.8 ohms. Couldn't find a factory spec but it matched the reading I got from a brand new coil at autozone

Last edited by AntFJ; 05-10-2014 at 07:05 PM.
AntFJ is offline  
post #10 of 12 Old 05-10-2014, 07:45 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
For codes you need an ODBC reader EG Scangauge ( ScanGauge - Trip Computer + Digitial Gauges + ScanTools) or other type many auto parts stores sell. Autozone may do the readings as a service with their unit. Just ask them. In Canada I don't anyone who does so I have my own unit.

1.5 quarts low, you're bad, oh Really Bad BAD. Poor engine must be grinding its balls, oh I mean bearings. LOL

That's the way to end up broken down in knowhere on day neglecting it like that.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
post #11 of 12 Old 05-10-2014, 07:58 PM
Junior Member
 
Join Date: May 2014
Posts: 5
 
you didn't answer my question:

will the computer give codes without an engine light?

EDIT: google tells me no. This car was having the problems with no engine light. You can't pull codes without an engine light.

thanks for the lecture on oil levels though. I thought engines could run without it.

Last edited by AntFJ; 05-10-2014 at 08:02 PM.
AntFJ is offline  
post #12 of 12 Old 05-10-2014, 08:09 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
Quote:
Originally Posted by AntFJ View Post
you didn't answer my question:

will the computer give codes without an engine light?

EDIT: google tells me no. This car was having the problems with no engine light. You can't pull codes without an engine light.

thanks for the lecture on oil levels though. I thought engines could run without it.
The ODBC reader can retrieve codes whether the engine light is on or not. That light comes on for a specific group of faults mostly emissions related.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome