Engine Jump While Accelerating - Jeep Compass Forum
 1Likes
  • 1 Post By BryGuy888
 
LinkBack Thread Tools Search this Thread
post #1 of 7 Old 07-22-2011, 01:53 PM Thread Starter
Junior Member
 
Join Date: Jun 2011
Location: Rhode Island
Posts: 13
 
Garage
Engine Jump While Accelerating

Hey guys, back again

The past few days I've noticed my Jeep has been acting a bit funny. What happens is when I go to accelerate from coasting a bit and press my gas pedal my car "jumps/jitters", it's hard to explain. The car simply jults forward. When i'm letting off the gas, I feel like the gears take over and slow down my car because I cant coast as long as before, almost like it's dropping gears itself.

I've been trying to read up on it and the only 3 things i can think of is fuel filter, drivetrain, or transmission. I have a 2.4L/CVT if that matters. :P. I'll be taking it to the dealer sometime this week so they can take a look. I wasnt sure if temperature would be a deal but since it started it's been 95+ outside.

Has anyone else had this issue?

Thanks
BryGuy888 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 07-22-2011, 02:06 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
I have had shuddering coming to slow stops and also if pulling away at a crawl for a long time. CVT issue and I bet its you CVT as well.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
post #3 of 7 Old 07-22-2011, 02:19 PM Thread Starter
Junior Member
 
Join Date: Jun 2011
Location: Rhode Island
Posts: 13
 
Garage
This is at all times, even when i'm going 40mph, if i coast and press the gas i get the jump/jerk feeling. I think I may try to do the fuel filter to see if that could be the issue, or I may just wait to see what the dealer says since it's still under warranty.
Just Me likes this.
BryGuy888 is offline  
Sponsored Links
Advertisement
 
post #4 of 7 Old 07-22-2011, 09:45 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
Quote:
Originally Posted by BryGuy888 View Post
This is at all times, even when i'm going 40mph, if i coast and press the gas i get the jump/jerk feeling. I think I may try to do the fuel filter to see if that could be the issue, or I may just wait to see what the dealer says since it's still under warranty.
Leave it for the dealer. Its not fuel filter issue.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
post #5 of 7 Old 07-25-2011, 05:11 PM Thread Starter
Junior Member
 
Join Date: Jun 2011
Location: Rhode Island
Posts: 13
 
Garage
I called my dealer, and I have an appt. tomorrow morning (i ran over a bolt the other day and blew a tire, thank god for a 5year/unlimited mile road hazard warranty). My good friend at the service desk believes it could be the ECM and that it needs to be updated (explained that it could be the result of previous rough idling to). I'll update everyone asap.
BryGuy888 is offline  
post #6 of 7 Old 07-25-2011, 05:30 PM
Senior Member
 
tripplec's Avatar
 
Join Date: Mar 2010
Location: Belleville, ON, Canada
Posts: 1,897
 
Quote:
Originally Posted by BryGuy888 View Post
I called my dealer, and I have an appt. tomorrow morning (i ran over a bolt the other day and blew a tire, thank god for a 5year/unlimited mile road hazard warranty). My good friend at the service desk believes it could be the ECM and that it needs to be updated (explained that it could be the result of previous rough idling to). I'll update everyone asap.
I doubt an update would fix it if its that noticeable now. They should have updated it when it was in last or before you got it which ever is most recent.
What year is this and miles on it?

Good luck, they'll fix it since its under warranty but whats causing it will likely show up when the put the computer on is and analyse the engine etc.

Jeep Compass 2009
4x4, 2.4L, CVT
North Edition
heated seats, TPMS
General Altimax RT43 P225/65R17
Yellow Fog Lamps
CLASS III Curtis Hitch
SOLD @ 153,000km Oct. 2018 THE END !!
Belleville, Ontario, Canada

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tripplec is offline  
post #7 of 7 Old 07-25-2011, 09:41 PM Thread Starter
Junior Member
 
Join Date: Jun 2011
Location: Rhode Island
Posts: 13
 
Garage
07' 4X4 Sport - 52k miles
BryGuy888 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome