"Check TPM system" error - Jeep Compass Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 5 Old 02-15-2017, 01:07 PM Thread Starter
Member
 
asakaze's Avatar
 
Join Date: Mar 2015
Posts: 86
 
"Check TPM system" error

I've got that message on the dashboard just a week ago after car was parked, not driven for a few days. I've check tire pressure with manual gauge, inflated them a bit, checked spare tire too but the warning message still appears on each start of vehicle.

Any advice on how to clear it? Dashboard tpms info seem accurate.
Is there any user's friendly relearning procedure?

~Small Jeep with Big-Benz heart~
2014 Compass CRD 2.2 Limited, Tuned & Debadged
MB DOHC 16v I4 twin-turbo
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
@
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
@
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
235/55R17 @
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
8Jx17 ET35;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
@
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Last edited by asakaze; 02-15-2017 at 01:12 PM.
asakaze is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 03-01-2017, 05:25 PM Thread Starter
Member
 
asakaze's Avatar
 
Join Date: Mar 2015
Posts: 86
 
I'm going to try to disconnect the battery, right after the emissions test this week.
No one with this issue yet? Tyres are OK, pressure read ok, it's just stupid EVIC stuck with the warning... Hopefully will clear it with disconnect.

There's no way anything on off-road vehicle can break just by sitting in a garage, even on -20C.

~Small Jeep with Big-Benz heart~
2014 Compass CRD 2.2 Limited, Tuned & Debadged
MB DOHC 16v I4 twin-turbo
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
@
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
@
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
235/55R17 @
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
8Jx17 ET35;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
@
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

asakaze is offline  
post #3 of 5 Old 09-07-2017, 06:36 PM Thread Starter
Member
 
asakaze's Avatar
 
Join Date: Mar 2015
Posts: 86
 
Wow finally after a few months, I'm closer but still very PUZZLED on how to solve this!??
Took a chance today in service on regular oil/filters change, to add to mechanics with TPM/RKE Analyzer to check the message, it returned C0151D as I thought sensors lost their place in WCM/WIN module. And they were too busy doing recall S61, ANOTHER module. So, they say it would took them another 3 hours to check the triggers, sensors, etc.. And these are summer stock wheels with stock sensors, issue appeared with winter wheel set, non-moving, freezing cold... So, I was thinking to manually reprogram sensors IDs into WMC/WIN but... should I do it with winter or summer set? Winter set has also OEM Schrader TPMS and they worked two winters no probs.

And electronics-wise, this is my second US branded car with the same "bugs" in circuits. The previous LaCrosse Buick was doing a show, random full-down windows and trunk opening, sky roof with AI etc

So why the FCA guys need another 3 hours just to reprogram? What's the problem with these modules? Where they are made? How to contact the manufacturer, to suggest some fixes... (I do fix things, especially electric powered)

They are reading OK, all pressure accurate just the error text won't be gone..
These threads helped me to understand:
TPMS Mystery - Jeep Wrangler Forum
TPMS problem - JeepForum.com

I post the results of forcing transmission with sensor IDs to the module.


Diag Trouble Codes (DTCs):
B2199-16-BATTERY VOLTAGE - CIRCUIT VOLTAGE BELOW THRESHOLD
B2199-17-BATTERY VOLTAGE - CIRCUIT VOLTAGE ABOVE THRESHOLD
B21DD-84-SYSTEM VOLTAGE - SIGNAL BELOW ALLOWABLE RANGE
B21DD-85-SYSTEM VOLTAGE - SIGNAL ABOVE ALLOWABLE RANGE
C0077-00-LOW TIRE PRESSURE
C1501-96-TIRE PRESSURE SENSOR 1 - INTERNAL COMPONENT FAILURE
C1502-96-TIRE PRESSURE SENSOR 2 - INTERNAL COMPONENT FAILURE
C1503-96-TIRE PRESSURE SENSOR 3 - INTERNAL COMPONENT FAILURE
C1504-96-TIRE PRESSURE SENSOR 4 - INTERNAL COMPONENT FAILURE
C151C-00-TIRE PRESSURE SENSORS MISSING
C151D-00-TIRE PRESSURE SENSOR LOCATION UNDETERMINED
C1580-00-LEFT/RIGHT SIDE TIRE PRESSURE SENSOR LOCATION UNDETERMINED
C1581-00-FRONT/REAR TIRE PRESSURE SENSOR LOCATION UNDETERMINED
C1597-00-TPM SYSTEM DEACTIVATED-WINTER MODE
C2209-00-TIRE PRESSURE MONITOR INTERNAL
U0001-00-CAN C BUS
U0100-00-LOST COMMUNICATION WITH ECM/PCM
U0121-00-LOST COMMUNICATION WITH ANTI-LOCK BRAKE SYSTEM (ABS) CONTROL MODULE
U0141-00-LOST COMMUNICATION WITH IPM (FCM/TIPM)

~Small Jeep with Big-Benz heart~
2014 Compass CRD 2.2 Limited, Tuned & Debadged
MB DOHC 16v I4 twin-turbo
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
@
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
@
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
235/55R17 @
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
8Jx17 ET35;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
@
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

asakaze is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 09-08-2017, 09:21 AM Thread Starter
Member
 
asakaze's Avatar
 
Join Date: Mar 2015
Posts: 86
 
Also WMC module part# would help, it could be cheaper to replace the module than to search for starscan tool and writing down IDs. It's down to module anyways..

Should be this one:
http://www.factorychryslerparts.com/...6053034AE.html

~Small Jeep with Big-Benz heart~
2014 Compass CRD 2.2 Limited, Tuned & Debadged
MB DOHC 16v I4 twin-turbo
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
@
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
@
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
235/55R17 @
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
8Jx17 ET35;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
@
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Last edited by asakaze; 09-08-2017 at 09:42 AM.
asakaze is offline  
post #5 of 5 Old 03-20-2019, 08:28 AM Thread Starter
Member
 
asakaze's Avatar
 
Join Date: Mar 2015
Posts: 86
 
Bumping my own (still unsolved) thread after a while.

Really guys, is there any diagnostic tool that can precisely say which one of those 3 TPMS transponders mounted in wheel housings (two in the front, and one in the rear), which one is the faulty one??

I have the replacement part for some long time now but I hate even the idea of disassembling all 3 of wheel housing in random order..


~Small Jeep with Big-Benz heart~
2014 Compass CRD 2.2 Limited, Tuned & Debadged
MB DOHC 16v I4 twin-turbo
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
@
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
@
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
235/55R17 @
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
8Jx17 ET35;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
@
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

asakaze is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Compass Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome