My Jeep Compass Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Has anyone experienced this? I was driving to work today in my 07 Compass with 150K on it. Other than the high miles, its in great shape. After I got on the expressway, I started to hear a high pitch whistle. I sounded like it was coming from the passenger side rear tire but it sounded more like my window was not all the way up. So, I put the back window down and then back up. The noise did not stop but I just dismissed it as wind. That is exactly what it sounded like and I am not sure if it is related to the problem. Anyway, I went 5mi down the road and everything died. The dash lit up first and I think that every possible light on the dash lit up. I saw lights that I had never even seen before! The engine quit. I rolled to the side of the road and called a tow truck. Nothing worked. It did not crank. It did not make a noise. the only thing that worked was AUX (windows, radio, etc.).
Every seen anything like this before?
Thanks,
Mark
 

·
Registered
Joined
·
436 Posts
Has anyone experienced this? I was driving to work today in my 07 Compass with 150K on it. Other than the high miles, its in great shape. After I got on the expressway, I started to hear a high pitch whistle. I sounded like it was coming from the passenger side rear tire but it sounded more like my window was not all the way up. So, I put the back window down and then back up. The noise did not stop but I just dismissed it as wind. That is exactly what it sounded like and I am not sure if it is related to the problem. Anyway, I went 5mi down the road and everything died. The dash lit up first and I think that every possible light on the dash lit up. I saw lights that I had never even seen before! The engine quit. I rolled to the side of the road and called a tow truck. Nothing worked. It did not crank. It did not make a noise. the only thing that worked was AUX (windows, radio, etc.).
Every seen anything like this before?
Thanks,
Mark
Hey Mark,
Did you experience any poor idling when starting the vehicle? You mentioned that the vehicle was towed, did your dealer have a chance to inspect the issue?
 

·
Registered
Joined
·
205 Posts
Tell us more about the problem. Has it been repaired. If so what did they find to be the cause of this problem and how did they fix it. The information will help a lot of members with regards to preventing the problem from happening. Thanks
 

·
Registered
Joined
·
71 Posts
What the OP is describing almost exclusively points towards a failed alternator

Most likely the alternator has been failing to charge the battery well or at all and and for the last +- 30 mins he was probly driving on battery power alone. dash lights always come on one by one or all at once just before the car dies completely.

he probly didnt have enough power to turn the engine over but still had enough juice to power the radio for a bit as he said

That being said most of our compasses require replacement of the ADP (Alternator Decoupler Pulley) long before the alternator is bad but its usually easier to just replace the whole alternator with ADP than doing it seperate.
 
1 - 5 of 5 Posts
Top