My Jeep Compass Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Notice 2 deep scratches on the trunk of the car where the liftgate closes at the bottom. Also checked on another compass my friend has and he has the samething.
might wanna check it on yours as well...it's around 1 feet on both sides of the locking latch thing.
not sure what's causing it as my car is still at the shop (will fill you in)..but they are atleast having someone touch up the paint and dent and look at the hinge as a possible cause.

2nd...my engine light is back on, brought it in for the 3rd time in 1 week. Finally found the cause...the manifold is leaking which is causing me to have really bad mileage on the car as well. (Car is around 3months old with only 2700km on it). So if anyone is having this problem as well...have them check the manifold and not just reset the light like they did with mine.
 

·
Registered
Joined
·
14 Posts
I purchased my new 07 Compass Limited last week and it has been in the shop twice, this time staying over night for a few days. Basically just cruising on the interstate the engine light comes on. Brought it to the dealer and they stated it was a stored code inside, he released the fault and I went on my way. Three hundred miles later I'm back in, this time they are stating its a wiring harness in some control module. Also I only have 600 miles on this vehicle and my gas mileage is absolutely horrible, like 200 miles to a full tank. There has to be something seriously wrong with this vehicle. I noticed the comments about the manifold, did that solve your gas mileage issue? What were you getting prior to the repair. Any ideas? Im begging!!

Big Pimpin
 

·
Registered
Joined
·
18 Posts
Discussion Starter #4
It's been a few day, the engine light is still off so maybe the manafold thing did the trick.

As for the mileage, I was getting around 9-10L/100km right after I got the car back. It's back up to 11-13L/100km though.

The mileage should be horrible at the beginning, it should be better (I hope) down the road.
 

·
Registered
Joined
·
14 Posts
Hey Darth,

Thanks for the reply, I'm curious did you ever find out what fault codes you were receiving? Did you mechanic ever tell you? I can tell you I am very concerned with this vehicle as of now, we have a Lemon Law and my Compass will fall under that if it fails once more with the same code. I will let you know what happens out of this. Thanks again for the quick reply!

Biggens
 

·
Registered
Joined
·
18 Posts
Discussion Starter #6
No I haven't had a change to talk to them. I pickup my car just as they close. I need to bring it back sometime next week so they can bring it to the body shop and fix the dent.
 

·
Registered
Joined
·
109 Posts
Could your scratches or whatever they are might have been caused by someone trying to close the tailgate while having the tailgate speakers deployed down (if you have this option installed) by any chance ?

It think the marks it would leave might just fit the description of the position you mentioned...

Also, call me crazy but I've been testing a theory that I came up with a few months ago regarding driving with 4x4 mode locked on and the effect it has on the gas mileage.

I'm getting close to 20,000km on my odo and when I first got my Compass, I tried running with and without the 4x4 mode locked on to see it there was a difference and I noticed a little but not the way I thought, I was doing better mileage in 4x4 mode. I thought this might have been because I was driving in winter and that being in 4x4 mode would help by having better acceleration, less slippage bla bla bla...

Anyway, I decided to wait till summer (and a few more km on the odo) to test this theory again.

Well, I did 2 full tanks now in 4x4 mode.

Now, I usually do about (maximum) 400 km on one tank, and it is very empty in the end because I'm filling over 51 liters (max capacity according to user's manual is 51.1 liters) when I try that, and this is pretty much every time I fill up.

By the way, I figured that you can fit about (maximum) 4 liters more that the maximum tank capacity if you take your time and shake (swing) the truck by the roof rails to let the air out, and people do look at me with a strange look when I do that but that's another story. :)

Now, back to the results. With my 2 tanks, in 4x4 mode, I was able to reach 470 kilometers on the first and 480 on the second and there was a little less than 2 liters left in the tank when I filled up.

I did a little bit more highway driving than usual but not that much. I'm on my third tank now and still in 4x4 mode. I'll let you know the results.

RedVortex
 

·
Registered
Joined
·
18 Posts
Discussion Starter #8
thanks for the post. I'm taking the car in today to have them fix the dents and take a look at what's causing it. No i did not get the rear folddown speaker option.

i've gotten down to as low 7.9L/100km highway..but average aroun 8.5-9.

Average around 11.9 local driving....this is about a week after I've gotten the car back after they fixed the leaking manafold.
 

·
Registered
Joined
·
14 Posts
Here is the latest, They cannot fix the engine light they have had the car for a week and that is the response I got. Chrysler states they will have to replace the entire wiring harness and computer in the vehicle. Can you say lemon law!! Beginning stages starting 0800am tommorrow. I really like the look of the compass but I am very disturbed with the issues I am having. And to be honest the local dealer has been wonderful its the engineers at Jeep that I am not so happy with. Will fill everyone in later.

Balls Deep
 

·
Registered
Joined
·
362 Posts
So can you just tell them to trade it off on another Compass before invoking the law? Tell them you want a straight across trade and nothing less? There's no lemon laws here so I'm not up on how that works.
 

·
Registered
Joined
·
14 Posts
So I just got home from my meeting with the owner of the dealer. They stated they will trade my car in and give me approx 3/4 of the purchase value. Can you believe that I just bought this thing 2 weeks ago and its been in the shop for 1.5 weeks. I brought the car in with 545 miles and now there is 1000miles on it. I requested a conference call with the Engineer who is handling the case within Starline(Technical Support) they stated they wont talk to the end user. So actually here is my story I have 1 more visit and then the lemon law will start. Trust me this has gone on long enough. They are going to replace a wiring harness hopefully today and we need to see if this fixes the issue. I will keep you all posted.
 

·
Registered
Joined
·
360 Posts
unitinbypass said:
So I just got home from my meeting with the owner of the dealer. They stated they will trade my car in and give me approx 3/4 of the purchase value. Can you believe that I just bought this thing 2 weeks ago and its been in the shop for 1.5 weeks. I brought the car in with 545 miles and now there is 1000miles on it. I requested a conference call with the Engineer who is handling the case within Starline(Technical Support) they stated they wont talk to the end user. So actually here is my story I have 1 more visit and then the lemon law will start. Trust me this has gone on long enough. They are going to replace a wiring harness hopefully today and we need to see if this fixes the issue. I will keep you all posted.
Wow that sucks! Oh the engineer doesn't speak to the end user - must be nice! Great customer support from the engineering department!
 

·
Registered
Joined
·
14 Posts
OK sit down everybody!! Here is the word>> They are going to replace the entire transmission. They say that will fix the CEL coming on with code P0741. Wow 545miles and needing a new transmission. Well I hope this will be the end. I can be honest I miss the little car. I just had U Connect installed and I love it, also I have the BA Sound System. I will fill you in when I get it back, they say some time late next week. How long will it take to replace a transmission in a 07 CompassCVT?

Unitinbypass
 

·
Registered
Joined
·
80 Posts
unitinbypass said:
OK sit down everybody!! Here is the word>> They are going to replace the entire transmission. They say that will fix the CEL coming on with code P0741. Wow 545miles and needing a new transmission. Well I hope this will be the end. I can be honest I miss the little car. I just had U Connect installed and I love it, also I have the BA Sound System. I will fill you in when I get it back, they say some time late next week. How long will it take to replace a transmission in a 07 CompassCVT?

Unitinbypass
I'd bet they've never had the opportunity to replace a Compass transmission before!!!

I'm really sorry that you've had such a rough start with your Compass ... but I suppose you just happen to be the "somebody" who got the rotten apple off the assembly line. It doesn't really matter how detailed the assembly inspections might be, and what car model or make, we're dealing with human beings and mistakes/errors are made.

I would recommend contacting Jeep/Chrysler and letting them know the full details of your experience with your Compass ... don't rely on your dealer to pass the information along.
 

·
Registered
Joined
·
23 Posts
Hello, I seem to have something in common here. I have had my Compass about 10 days. It has now been in the shop 3 times. Same light, same issue. They told me first it was a bad oxygen sensor and then told me the sensor was slow but just needed to be updated. Now it is backc on! I was wondering if either of you had an update on your issue with the light coming on before I meet with the service manager tomorrow?
 

·
Registered
Joined
·
14 Posts
Hey I do have an update, what is the code they are getting? Is it P0741 if it is, this is what they replaced. First they replaced the computer, did not fix the situation then they replaced a wiring harness from the torq convertor to the computer and that did not fix the problem. Last they replaced the transmission and I have about 120 miles on the new transmission and no light. Im not sure where you are in the world but Ill give you my personal email [email protected] you can email me on that and I will give you my phone number and we can talk. There has been 11 cases of this happening and I do have the phone numbers of alot of hirer ups in Chrysler since my situation. Basically it seems to be a manufacturing issue with the transmission. What state are you in or country. Please contact me I will help you any way I can because I went through hell to get this squared away.

Unitinbypass
 

·
Registered
Joined
·
362 Posts
Maybe there's a bad batch of trannies? When were your Compass' built? Maybe on the same day/week?

I've got 12K miles (20K km) on my tranny and it's holding up just fine. I haven't had the CEL on yet. Knock on wood.
 

·
Registered
Joined
·
23 Posts
Thank you unitinbypass. I am in the USA in Virginia. I actully mentioned this site to the Service manager. He kinda dismissed the suggestion and stated that last year they had the same issue with the Jeep Cherokee last year and it took about 4 months for them to come up with a fix. However, they have now had my Compass in for the 3rd time. This last time they reset the light then hooked it up to a computer and drove it around until the light came on again. They left me a message stating that they are getting a code that it is an evap leak "somewhere. It could be a very small leak, but will take some time to find." So..... I continue to drive the rental car and wait" If this does not work I will email you for the information.

Thank you for your reply.
 

·
Registered
Joined
·
23 Posts
darth wolf said:
2nd...my engine light is back on, brought it in for the 3rd time in 1 week. Finally found the cause...the manifold is leaking which is causing me to have really bad mileage on the car as well. (Car is around 3months old with only 2700km on it). So if anyone is having this problem as well...have them check the manifold and not just reset the light like they did with mine.

I just spoke with the Service Manager today. He told me that infact they just ordered a manifold and they are waiting for it to come in. I told them, that I had heard of this and even told them about it when I came in the second time. He stated that they had to follow what Chrystler told them to check and this should take care of it. I also told them that there was another car that went as far as needing the transmission replaced. He assured me that that was not the fix that my car would need. :roll:

I will keep you posted.
 
1 - 20 of 22 Posts
Top